Driver ATI

3 risposte [Ultimo messaggio]
Ritratto di Staffilo1975
Staffilo1975
(Geek)
Offline
Geek
Iscritto: 02/02/2007
Messaggi: 58

Ho una FireGL V3400 pertanto la versione del Catalist è la 7.12.

Ho installato correttamente il driver ATI seguendo le varie guide che sconsigliano di utilizzare il sax2.
Tramite fglrxinfo ottengo che:

display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI FireGL V3400
OpenGL version string: 2.1.7170 FireGL Release

Quando apro la configurazione del desktop, non ho accesso ai menù di controllo poiché:

“Your X server is using the RandR extension at version 1.2 or greater which doesn't have any configuration yet”

Inoltre se cerco di aprire il pannello di controllo di Ati esso mi restituisce un errore.

Nel “Il mio sistema” ottengo questo:

Marca: ATI Technologies Inc
Modello:
Driver: fglrx (Supporto 3D)

Perchè non ho delle informazioni più dettagliate? E perchè nel file “/etc/X11/xgl-hardware-list” la mia V3400 risulta in:

# Unrecognized ATI cards
....
U 1002:71ce # RADEON (RV530 VE 71CE)
U 1002:71d2 # FireGL V3400 (RV530 71D2)◄
U 1002:71da # FireGL V5200 (RV530 71DA)
.....

Mai fastidi, tu sei un DIO!
OpenSuse 10.3 - NO INTERNET
Mobo ASUS K8NSLI - Athlon64X2 4200+ 939 - 2GbRam - HDD 160+250Gb Sata2 - FireGL V3400 - Monitor HPw20 (widescreen 1680x1050)

Ritratto di AL9000
AL9000
(Guru)
Offline
Guru
Iscritto: 29/10/2005
Messaggi: 1277

Quote:

Ho una FireGL V3400 pertanto la versione del Catalist è la 7.12.

Questa versione catalist a quale driver corrisponde nella vecchia dicitura? Cioè, quella attuale, la catalist 8.4, corrisponde ai driver ATI 8.476: la tua versione a quale corrisponde?

Quote:

Quando apro la configurazione del desktop, non ho accesso ai menù di controllo poiché:
“Your X server is using the RandR extension at version 1.2 or greater which doesn't have any configuration yet”

questo proprio non lo so...ma pare che tu stia utilizzando qualcosa di "troppo nuovo"
che versione di xorg hai? e su quale distro suse?

Quote:

Inoltre se cerco di aprire il pannello di controllo di Ati esso mi restituisce un errore.

problema già trattato in più di qualche post riguardante driver ATI: prova a cercare in questo forum la parola amdcccle (in ogni caso, anche a me non funzionava ed ho risolto modificando la voce del menu riguardante il pannello di controllo ATI, mettendo nel campo comando di quella voce kdesu amdcccle, anzichè amdcccle)
Comunque ti assicuro che l'utilità del pannello in questione è quasi nulla: io non ho mai avuto la necessità di utilizzarlo.

Quote:

E perchè nel file “/etc/X11/xgl-hardware-list” la mia V3400 risulta in:
# Unrecognized ATI cards

questo non riguarda il server grafico xorg, bensì il server alternativo XGL cioè quello che serve per far girare compiz-fusion: fortunatamente per te, se volessi compiz-fusion, puoi sempre provare aiglx invece di XGL, dato che gli attuali driver ATI lo supportano.
Se invece compiz-fusion non ti interessa allora a maggior ragione non hai nessun problema

In conclusione, se il driver funziona ed è attivo, come mi pare di aver capito, stai contento: con ATI su linux c'è sempre qualche problema.

Ciao

Chi è investito di un'autorità si trasformerà inevitabilmente, secondo una legge sociale immutabile, in un oppressore ed in uno sfruttatore della società. (M.A. Bakunin)

Ritratto di Staffilo1975
Staffilo1975
(Geek)
Offline
Geek
Iscritto: 02/02/2007
Messaggi: 58

Ho fatto la modifica "kdesu" che hai suggerito ed ha funzionato. Laughing
Sebbene tu dica che non hai mai avuto bisogno di usarlo, io l'ho avuto per avere una conferma sull'impostazione del monitor. Io ho un Widescreen da 20" (1680x1050) e, da quando ho installato il driver, non mi ero mai convinto della risoluzione settata. Ieri, tramite il pannello ho scoperto che la risoluzione era impostata a 1600x1024. Non potevo cambiare la risoluzione e l'ho risolta variando le impostazioni dell'anti-alaysing e quant'altro. Ora si vede benissimo!
Laughing

La versione della driver è 8.44.3.

Per quanto riguarda la configurazione del desktop può darsi che tu abbia ragione, ma non saprei come risolvere il problema. Secondo te se installassi l'ultimo kernel od il KDE4 potrei risolvere qualcosa? Thinking

Anche se rischio di attirare maledizioni, non sono interessato affatto a voler installare desktop 3D, perchè li considero completamente inutili. Wink :-P

Mai fastidi, tu sei un DIO!
OpenSuse 10.3 - NO INTERNET
Mobo ASUS K8NSLI - Athlon64X2 4200+ 939 - 2GbRam - HDD 160+250Gb Sata2 - FireGL V3400 - Monitor HPw20 (widescreen 1680x1050)

Ritratto di AL9000
AL9000
(Guru)
Offline
Guru
Iscritto: 29/10/2005
Messaggi: 1277

Quote:

Sebbene tu dica che non hai mai avuto bisogno di usarlo, io l'ho avuto per avere una conferma sull'impostazione del monitor. Io ho un Widescreen da 20" (1680x1050) e, da quando ho installato il driver, non mi ero mai convinto della risoluzione settata. Ieri, tramite il pannello ho scoperto che la risoluzione era impostata a 1600x1024. Non potevo cambiare la risoluzione e l'ho risolta variando le impostazioni dell'anti-alaysing e quant'altro. Ora si vede benissimo!

Puoi cambiare la risoluzione del desktop direttamente nel file /etc/X11/xorg.conf (il server grafico), editandolo a mano con un editor di testi tipo kwrite (ovviamente lo devi fare con i privilegi di root); oppure tramite l'applicazione sax2, che offre un'interfaccia grafica alla configurazione del monitor e della scheda
N.B. sax2 non va molto d'accordo con i nuovi driver ATI, quindi ti potrebbe segnalare, erroneamente, che l'accelerazione 3D è disabilitata, anche se in realtà è perfettamente funzionante: ignora questa eventuale indicazione

Quote:

La versione della driver è 8.44.3

Suppongo che tu abbia già controllato se la versione del driver che hai installato è compatibile con la tua scheda

Altrimenti potresti provare a verificarlo sul sito di AMD/ATI e magari a disinstallare i driver attuali ed installare quelli consoni per la tua scheda

Puoi seguire la mia guida
C'è anche il link per l'installazione via one-click-install dei driver legacy (versione 8.40.4) che dovrebbero funzionare anche per le schede più vecchiotte, anche se non so quanto è recente la tua (tentar non nuoce)

Quote:

Per quanto riguarda la configurazione del desktop può darsi che tu abbia ragione, ma non saprei come risolvere il problema. Secondo te se installassi l'ultimo kernel od il KDE4 potrei risolvere qualcosa?

Non ho ben capito se con configurazione del desktop ti riferisci al modulo di kcontrol (centro di controllo) relativo al desktop: se è così potresti provare ad aggiornare solo kcontrol
In ogni caso tieni a mente che se aggiorni il kernel dovrai disinstallare i tuoi attuali driver e reinstallarli (stessa versione o un'altra, come già detto) in quanto l'aggiornamento del kernel comporterà l'inutilizzabilità della tua attuale configurazione del server grafico con i driver proprietari.

Quote:

Anche se rischio di attirare maledizioni, non sono interessato affatto a voler installare desktop 3D, perchè li considero completamente inutili.

Buon per te: a maggior ragione potresti provare altre versioni dei driver, magari un pò meno recenti, così da vedere se anche questa via può essere una soluzione per il tuo problema con la configurazione del desktop.

Ciao

Chi è investito di un'autorità si trasformerà inevitabilmente, secondo una legge sociale immutabile, in un oppressore ed in uno sfruttatore della società. (M.A. Bakunin)