driver ati, suse 10.0

32 risposte [Ultimo messaggio]
Ritratto di miche11
miche11
(Junior)
Offline
Junior
Iscritto: 06/05/2007
Messaggi: 16

ciao a tutti,
sono appena giunto nel mondo linux per motivi di lavoro, ed essendo totalmente newbie (e cretino) ho già un problema...
perdonatemi se lo scrivo, ho usato la funzione cerca nel forum ma niente di particolareggiato...
ho un acer wlmi 3023, e a quanto pare ci sono problemi con i driver ati radeon mobility x700.
ho cercato su internet, ho trovato una guida in pdf su come installarli propriamente, ma niente di fatto: a) riesco a procurarmi il driver solo da windows (sistema dual boot) perchè non ho saputo installare correttamente internet all'inizio, Cool quando apro xorg.conf ho una schermata vuota, dice che è un file nuovo....
aiuto, sono totalmente nuovo, non so come muovermi !!!
mi sapreste suggerire una guida a prova di deficiente già esistente, o qualcos'altro, sempre a prova di deficiente ?
grazie tante, ciao

Ritratto di spock
spock
(Guru)
Offline
Guru
Iscritto: 03/08/2006
Messaggi: 1196

Hai provato questa guida? è per la 10.2 ma potrebbe andare bene anche per te:
http://www.suseitalia.org/modules/wfsection/article.php?page=1&articleid=106

Ritratto di miche11
miche11
(Junior)
Offline
Junior
Iscritto: 06/05/2007
Messaggi: 16

allora, ci sono riuscito, avevo installato il pacchetto ati, ma non sono riuscito a modificarlo per ottenere un'ampiezza di scermo ragionevole (avevo 600x800 e non andava bene)
pi ho fatto qualcos'altro, ho riavviato, ma di nuovo era in modalità testo.
ho riprovato a rifare quello che avevo fatto, modificare xorg.conf in section--> device---> vesa, ma adesso non trova più questo file, dà schermata bianca, o meglio, nera.
devo reinstallare linux ?
grazie

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Che risoluzione ha il tuo schermo? Anch'io ho una x700 e funziona correttamente. Se vuoi, posso passarti il mio xorg.conf ma prima devi indicare quanto e` grande il tuo schermo (o meglio, postare la section monitor presente in /etc/X11/xorg.conf (che deve esistere, se hai la grafica che funziona).

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di miche11
miche11
(Junior)
Offline
Junior
Iscritto: 06/05/2007
Messaggi: 16

ti ringrazio...
brevemente, riporto i passaggi:
-al momento dell'installazione avevo schermo nero, ho modificato lo xorg.conf, scrivendo vesa, anche se lui aveva già scritto driver ati, e sembrava aver riconosciuto la scheda video.
-così avevo un minimo di grafica 640x480, uno schifo. poi ho installato il paccheto preso dal sito della ati, ha installato un "ati catalyst control center" che non sono mai riuscito ad aprire per modificare le impostazioni, e mi ha detto di riavviare.
- ho riavviato, partiva spontaneamente in modalità prompt, allora ho riprovato a modificare xorg.conf ma sorpresa! non c'era più !!!! cosa faccio ora che non ho xorg ? e soprattutto come aggiungo il tuo ?
son davvero una capra con linux, non mi so orientare !!!

edit: grazie orion, ho un portatile acer 3023wlmi con schermo da 15,4', non riesco a postare il file perchè non me lo apre!

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Fai cosi`: dopo aver avviato il pc, autenticati come root e lancia il comando sax2. In questo modo ti viene generato un nuovo file xorg.conf ed almeno hai la grafica. Poi ti assicuri di avere installato il kernel-source e il gcc (usando yast) e poi ti scarichi l'installer del driver fglrx da qui (e` la versione 8.34.8, quella che sto usando io)

Sempre come root, ti sposti dove hai scaricato il file e dai i comandi:
cp /etc/X11/xorg.conf /etc/X11/xorg.conf-backup
chmod u+x ati-driver-installer-8.34.8-x86.x86_64.run
./ati-driver-installer-8.34.8-x86.x86_64.run --buildpkg SuSE/SUSE102-IA32

A questo punto controlla che non vengano segnalati errori e se non ci sono stati errori, continua con il comando:
rpm -ivh fglrx*.rpm

Se anche questo non segnala errori (qualche warning lo da`, ma non devono esserci errori), autenticati come root in testuale (Ctrl-Alt-F1) e dai i comandi:
telinit 3
modprobe fglrx

Se non ti restituisce nessun messaggio, controlla che sia presente (come dovrebbe essere) il modulo fglrx con il comando
lsmod|grep fglrx

Se fin qui e` andato tutto bene, scarica il mio xorg.conf e salvalo al posto di /etc/X11/xorg.conf
Una cosa: controlla che valore ha il parametro BusID nella section Device del tuo file xorg.conf e se e` diverso da 1:0:0, modifica il valore nel mio file in modo che coincida con il tuo (in testuale, puoi editare i file usando joe come editor).

Arrivati a questo punto, sempre in modalita` testuale, dai il comando startx e guarda se ti parte una sessione grafica corretta. Se cosi` accade, termina la sessione grafica andando su logout e poi dai il comando telinit 5. Ora sei a posto.

Se ci sono problemi in qualche fase, non esitare ad interrompere la sequenza di comandi e a postare.

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di miche11
miche11
(Junior)
Offline
Junior
Iscritto: 06/05/2007
Messaggi: 16

allora, oggi ho iniziato a fare come mi hai detto (il driver lo scarico quando torno a lavoro, ci vorrà un po', qua ho ancora internet a tariffa urbana), ho digitato sax2, lui ha frullato un po' e poi schermata nera (deduco che si è avviata la finestra X ma senza i driver opportuni...)
torno in modalità prompt e do
pico /etc/X11/xorg.conf
ma di nuovo si apre un file nuovo, vuoto, niente scritto, quindi non posso riscrivere "vesa" dove l'ho scritto l'altra volta....
....

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Invece di sax2, prova a lanciare sax2-vesa, che ti dovrebbe generare un file con il driver generico vesa

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di miche11
miche11
(Junior)
Offline
Junior
Iscritto: 06/05/2007
Messaggi: 16

avevo postato stamattina... ma non è stato pubblicato.,.. boh..
cmq grazie orion, ora ho la parte grafica, installerò i driver più avanti quando tornerò a lavoro, ma non riesco a downloadare il tuo file xorg.conf.
nel frattempo leggo un po' suse for dummies per familiarizzare (avete mica altre letture da consigliare ?) e vi farò sapere presto degli altri miei casini...
grazie ancora !

Ritratto di miche11
miche11
(Junior)
Offline
Junior
Iscritto: 06/05/2007
Messaggi: 16

Rieccomi qua dopo un po' di tempo, ho finalmente deciso di installare sti' driver...
ho seguito le tue linee di comando e ho trovato questi problemi:
-come root, quando davo chmod..ecc...ecc.. --build .....
mi diceva "unrecognized option build"; non scirvendola, non riusciva a trovare il file dei driver .run, che avevo messo sul desktop....
-come user autenticato su, son riuscito ad andare avanti, quando ho dato la riga di rpm per fglrx*, dava "file not found by glob"

che faccio ? come faccio a imparare tutte queste cose soprattutto ?

altre due cose: come configuro la dsl che uso con windows ?
perchè a volte a chiusura sessione linux si impalla e devo spegnere in notebook scollegando tutto ?

help, help, help !!! Sad

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Per quanto riguarda l'adsl, meglio se apri una nuova discussione indicando che tipo/modello di modem/router usi, se usb o ethernet. Idem per il problema in spegnimento.

Ora, torniamo al problema con i driver ati.
Supponiamo che il file sia in /home/miche11/Desktop. Per installare i driver, esegui i seguenti passi: su<br />cd /home/miche11/Desktop<br />chmod u+x ati*.run<br />./ati*.run --buildpkg SuSE/SUSE102-IA32<br /><i>se non sono stati segnalati errori, dovresti avere un file <br />fglrx_?_?_?_SUSE102-8.??.?-?.i386.rpm con dei numeri al posto dei ?</i><br />rpm -Uvh fglrx*.rpm<br /><i>anche qui non dovrebbero essere restituiti degli errori, solo dei warning</i><br />modprobe fglrx<br />lsmod | grep fglrx[code]<br />Se tutto e` andato bene, dopo l&#039;ultimo comando dovresti ottenere qualcosa di simile a [code]fglrx                 661216  16<br />agpgart                35528  2 fglrx,intel_agp

Intanto arriva a questo punto, e sappimi dire se ci sono stati dei problemi.

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde