Driver Ati X1650 e Kernel-Source

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Per capire cosa succede, bisogna che mi dai qualche informazione: pertanto, posta i due xorg.conf (fglrx e vesa; quest'ultimo se e` diverso da quello che hai gia` postato) e il file /var/log/Xorg.0.log generato all'avvio con fglrx.
(per fare questo, dopo che si e` avviato con schermo nero, premi Ctrl-Alt-F2, ti logghi e copi il file da qualche altra parte, ad esempio la tua home).

Casomai linkali tutti e tre su un server di free hosting, cosi` e` piu` semplice trattarli.

Una cosa: e` un fisso o un portatile?

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di Draven999
Draven999
(Junior)
Offline
Junior
Iscritto: 09/04/2008
Messaggi: 29

Eccomi qua, allora il pc è un fisso,
qui c'è lo xorg.conf che in teoria dovrebbe andare MA produce schermo nero:

http://www.uploading.com/files/Y3HVL9V1/xorg.conf.fglrx-2.html

Qui c'è lo xorg con VESA funzionante:

http://www.uploading.com/files/H1AT3PBQ/xorg.conf.original-0.html

Qui c'è il log di Xorg all'avvio con schermo nero (sono dovuto entrare in failsafe per prenderlo, altrimenti con lo schermo nero non entrava neanche in modalità testo, è totalmente bloccato)

http://www.uploading.com/files/1KNNKDWE/Xorg.0.log.html

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Allora, dal log non si riesce a capire perche` X non parte, dato che si interrompe bruscamente senza alcuna informazione.

In pratica, confrontando con il mio, si blocca prima di caricare il modulo ddc, che dovrebbe essere built-in (viene caricato anche da vesa).

Ci sarebbero i due warning (WW) xf86OpenConsole: setpgid failed: Operation not permitted<br />(WW) xf86OpenConsole: setsid failed: Operation not permitted ma che comparendo in entrambi i log (fglrx e vesa) non dovrebbero influire.

Purtroppo non riesco a capire il problema, dato che non si riesce a trovare informazioni su possibili cause del problema.

Quello che potresti provare a fare (ma senza alcuna garanzia di utilita`), consiste nell'aggiungere Load "dri" all'interno della section Module, Option "IgnoreABI" "on" e Option "AIGLX" "off" dentro la section "ServerFlags" e aggiungere Section &quot;Extensions&quot;<br />        Option      &quot;Composite&quot; &quot;false&quot;<br />EndSection in coda al file. Cosi` sei piu` vicino al mio xorg.conf, anche se non ho idea se questo possa aiutare.

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di Draven999
Draven999
(Junior)
Offline
Junior
Iscritto: 09/04/2008
Messaggi: 29

Ho capito, appena riesco provo a fare le modifiche allo xorg...Un altra cosa, pensi che una reinstallazione da zero di Suse oppure il passaggio a Ubuntu possano migliorare la situazione?

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Sul passaggio a ubuntu non mi pronuncio (l'ho provata una volta sul portatile e l'ho piallata in 5 minuti).

Una reinstallazione potrebbe aiutare, ma non e` detto.

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di Draven999
Draven999
(Junior)
Offline
Junior
Iscritto: 09/04/2008
Messaggi: 29

Ho notato una cosa: quando avvio il computer lo schermo nero appare al posto della schermata grafica di boot di Suse (quella grigia per intenderci) e il monitor fa un rumore come quando spara a una risoluzione troppo elevata (e in questo caso lo schermo diventa nero), ho notato che dopo aver installato il driver non riesco ad accedere alle impostazioni del monitor in maniera grafica, quindi esiste un comando da shell per forzare il driver ad avviarsi con una determinata risoluzione?

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Ci sarebbe xrandr, ma non l'ho mai usato.

Comunque strano che non funzioni gia` durante il boot.

Prova un po' a postare il contenuto di /boot/grub/menu.lst.

Poi, potresti provare a fare un merge dei file xorg.conf che hai: in pratica, prendi quello vesa e nella section Device metti il driver fglrx al posto di vesa, lasciando immutato tutto il resto.

Almeno sei sicuro che le risoluzioni vengono prese giuste.

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di Draven999
Draven999
(Junior)
Offline
Junior
Iscritto: 09/04/2008
Messaggi: 29

Quote:

orion ha scritto:

Prova un po' a postare il contenuto di /boot/grub/menu.lst.

Poi, potresti provare a fare un merge dei file xorg.conf che hai: in pratica, prendi quello vesa e nella section Device metti il driver fglrx al posto di vesa, lasciando immutato tutto il resto.

Almeno sei sicuro che le risoluzioni vengono prese giuste.

Il boot funziona...è dopo il boot quando si sta per avviare la schermata di suse che si impalla sulla schermata nera...Al momento faccio come hai detto tu, cioè sostituisco solo i file xorg, e quando metto quello impostato per far partire i driver fglrx si impalla...Non so mi servirebbe qualcuno che come casistica ha già avuto questo problema, magari provo a chiedere su qualche forum internazionale...

Ah tra l'altro ho provato a installare i driver di metà del 2007 e da lo stesso problema...

Ritratto di Draven999
Draven999
(Junior)
Offline
Junior
Iscritto: 09/04/2008
Messaggi: 29

Ah un altra cosa...Il sistema non risponde al comando init 3, cioè quando lo lancio da shell non va in modalità grafica, ci vado manualmente con CTRL+ALT+F1 ma è la stessa cosa?

Ritratto di Draven999
Draven999
(Junior)
Offline
Junior
Iscritto: 09/04/2008
Messaggi: 29

Mi viene il dubbio che la mia versione di Xorg sia la 7.1...Come posso fare per aggiornarlo alle versioni più recenti?