openSUSE 12.1 GNOME + problemi con driver AMD (non installare).

117 risposte [Ultimo messaggio]
Ritratto di Gollum
Gollum
(Collaboratore)
Offline
Collaboratore
Iscritto: 03/03/2005
Messaggi: 802

Vedi qui e qui

Desktop DELL XPS8100 => openSUSE_12.2 => KDE 4.10 => Core i7 => 3.4.28-2.20 => Nvidia GT220
Notebook Sony Vaio VPPCA =>openSUSE_12.2 => KDE 4.10 => Core i5 => 3.4.28-2.20 => AMD HD 6470M

Ritratto di Suse98
Suse98
(Guru)
Offline
Guru
Iscritto: 03/10/2010
Messaggi: 1657

Ce l'ho fatta !!!!
Grazie Gollum sei stato di fondamentale aiuto.

Riassumo la procedura:
Ho installato i pacchetti per la compilazione con

# zypper in kernel-devel make gcc gcc-c++

poi ho aggiunto il repo ioda con:

zypper ar -c -f -n "ATI/AMD fglrx non-official" http://linux.ioda.net/mirror/ati/openSUSE_12.1/ "ATI/AMD FGLRX"

ho rimosso le precedenti modifiche ai driver con:

# Remove old conf & stuff
rm -fr /etc/ati
# Remove any old fglrx inside kernel modules
find /lib/modules -type f -iname "fglrx.ko" -exec rm -fv {} \;

Una volta fatto questo, con il seguente comando vediamo se trova il pacchetto fglrx:
zypper se -s fglrx

Installo i suddetti pacchetti

For a 64bits version

zypper in fglrx64_xpic_SUSE121

For a 32bits version

zypper in fglrx_xpic_SUSE121

poi controlliamo che ci siano i driver radeon in blacklist con:

cat /etc/modprobe.d/50-fglrx.conf

Anche se sono in blacklist, io consiglio di modificare la stringa nel file /etc/X11/xorg.conf.d/50-device.conf con driver “fglrx”
E poi entriamo in modalità testuale ( dopo aver chiuso tutti i programmi aperti, non è necessario, non preoccupatevi ) premendo Ctrl+Alt+F1, ci loggiamo come root e diamo un reboot ( sempre meglio di riavviare x con startx o riavviare la schermata login con xdm restart, quando x sta per l'iniziale del vostro DE, ad esempio lxde: ldm restart )

E mi è uscita la schermata login, tutta visibile. Mi sono loggato e tutto Ok !!!

Grazie Gollum !

Applause

HP - Gaming OMEN 15-ek0015nl Notebook
Intel Core i7-10750, Nvidia GeForce RTX 2060 6GB, 32GB RAM, 500GB SSD M2 + 2TB Sabrend SSD M2

Ritratto di Gollum
Gollum
(Collaboratore)
Offline
Collaboratore
Iscritto: 03/03/2005
Messaggi: 802

Di niente. Vediamo di chiudere questo topic tragicomico una volta per tutte, anche in virtù del fatto che le versioni dei driver con cui è stato aperto non sono nemmeno le più recenti.

Desktop DELL XPS8100 => openSUSE_12.2 => KDE 4.10 => Core i7 => 3.4.28-2.20 => Nvidia GT220
Notebook Sony Vaio VPPCA =>openSUSE_12.2 => KDE 4.10 => Core i5 => 3.4.28-2.20 => AMD HD 6470M

Ritratto di Templare
Templare
(Collaboratore)
Offline
Collaboratore
Iscritto: 28/10/2011
Messaggi: 747

Splendido lavoro ragazzi. Suse98 ha avuto la pazienza di continuare a provare e Gollum gli ha dato le dritte migliori.

Un sentito grazie a entrambi!

Ora proverò anche io allora con questa di procedura!

Assemblato 1: Phenom II X4 965 Black Edition + AMD Radeon HD 5770 + Scheda Madre Asus Crosshair IV Formula + Scheda Audio Asus Xonar D2X. Sistema Windows 7 Ultimate 64 Bit
Assemblato 3: Intel Core i3 3220 + nVIDIA Geforce 640 GT. Sistema openSUSE 13.1 64 bit GNOME

Ritratto di Suse98
Suse98
(Guru)
Offline
Guru
Iscritto: 03/10/2010
Messaggi: 1657

Stranamente, ora mi compare 300 frames:

Ma riesco sempre a giocare ad HoN ( ed è perfetto )

Sapete aiutarmi ?
Grazie Wave

HP - Gaming OMEN 15-ek0015nl Notebook
Intel Core i7-10750, Nvidia GeForce RTX 2060 6GB, 32GB RAM, 500GB SSD M2 + 2TB Sabrend SSD M2

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 917

Hahahaha

glxinfo

Guarda le prime 4 righe Rolling On The Floor

Ritratto di Suse98
Suse98
(Guru)
Offline
Guru
Iscritto: 03/10/2010
Messaggi: 1657

name of display: :0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: ATI

dice ati, ma è 300 Plain Face

HP - Gaming OMEN 15-ek0015nl Notebook
Intel Core i7-10750, Nvidia GeForce RTX 2060 6GB, 32GB RAM, 500GB SSD M2 + 2TB Sabrend SSD M2

Ritratto di Gollum
Gollum
(Collaboratore)
Offline
Collaboratore
Iscritto: 03/03/2005
Messaggi: 802

 # hwinfo --gfxcard

Desktop DELL XPS8100 => openSUSE_12.2 => KDE 4.10 => Core i7 => 3.4.28-2.20 => Nvidia GT220
Notebook Sony Vaio VPPCA =>openSUSE_12.2 => KDE 4.10 => Core i5 => 3.4.28-2.20 => AMD HD 6470M

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 917

Allora non preoccuparti .

Avrai cambiato qualche impostazione nel Catalyst control center e ora visualizzi i benchmark con un parametro diverso Party

Acc..

Gollum come fai a ricordarti tutti sti comandi ???

Ritratto di Suse98
Suse98
(Guru)
Offline
Guru
Iscritto: 03/10/2010
Messaggi: 1657

Gollum ha scritto:

 # hwinfo --gfxcard

linux-jl4f:~ # hwinfo --gfxcard
28: PCI 100.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.319]
  Unique ID: VCu0.Yms5qwynux0
  Parent ID: 3hqH.dmRx1m7CVE5
  SysFS ID: /devices/pci0000:00/0000:00:03.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "ATI VGA compatible controller"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x68ba 
  SubVendor: pci 0x174b "PC Partner Limited"
  SubDevice: pci 0xe144 
  Driver: "fglrx_pci"
  Driver Modules: "fglrx"
  Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
  Memory Range: 0xfbbc0000-0xfbbdffff (rw,non-prefetchable)
  I/O Ports: 0xb000-0xbfff (rw)
  Memory Range: 0xfbba0000-0xfbbbffff (ro,non-prefetchable,disabled)
  IRQ: 49 (71615 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00001002d000068BAsv0000174Bsd0000E144bc03sc00i00"
  Driver Info #0:
    Driver Status: radeon is not active
    Driver Activation Cmd: "modprobe radeon"
  Driver Info #1:
    Driver Status: fglrx is active
    Driver Activation Cmd: "modprobe fglrx"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #9 (PCI bridge)
 
Primary display adapter: #28
linux-jl4f:~ # 

HP - Gaming OMEN 15-ek0015nl Notebook
Intel Core i7-10750, Nvidia GeForce RTX 2060 6GB, 32GB RAM, 500GB SSD M2 + 2TB Sabrend SSD M2