Epson stylus dx 4400

6 risposte [Ultimo messaggio]
Ritratto di budrio
budrio
(Junior)
Offline
Junior
Iscritto: 05/07/2011
Messaggi: 17

Ragazzi apro questo post perchè ho problemi ad installare lo scanner della mia mutlifunzione epson stylus dx 4400. Io di solito lo installavo con i driver presi dal sito Avasys, però adesso con suse 12.1 quando ci provo si blocca l'installazione sulla schermata: in attesa dell'avvio del servizio. Qualcuno potrebbe aiutarmi. Grazie in anticipo.

Ritratto di marco.azzalini
marco.azzalini
(Junior)
Offline
Junior
Iscritto: 18/02/2012
Messaggi: 11

Ciao, io ho un problema simile nel senso che con la mia DX 7400 non ho mai avuto problemi come te; invece da quando ho messo su la 12.2 non c'è verso di fargliela vedere, anzi: la vede ma poi non trova mai il driver e se gli carico il PPD a mano e come se lo ignorasse Sad

Nessun altro ha il nostro problema?

ciao
Marco

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2739

marco.azzalini ha scritto:

Ciao, io ho un problema simile nel senso che con la mia DX 7400 non ho mai avuto problemi come te; invece da quando ho messo su la 12.2 non c'è verso di fargliela vedere, anzi: la vede ma poi non trova mai il driver e se gli carico il PPD a mano e come se lo ignorasse Sad

Nessun altro ha il nostro problema?

ciao
Marco


La 12.2,milestone 1?

SUSE Tumbleweed- kernel-5.5.11-1.2- kde-plasma-5.18.3.1- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.132.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di marco.azzalini
marco.azzalini
(Junior)
Offline
Junior
Iscritto: 18/02/2012
Messaggi: 11

Ciao, scusate! Ho scritto 12.2 ma invece volevo scrivere 12.1.

La buona notizie invece è che ho risolto il problema! Smile

In pratica per riuscire ad installare pacchetto pipslite-1.4.0-5.i386.rpm ho installato glib e gtk
in versione 1 (che sono delle sue dipendenze) e poi ho forzato l'installazione perchè c'era comunque
un conflitto con le libjpeg (la Suse 12.1 ha la versione libjpeg ma è marcata come libjpeg6 e quindi il controllo di dipendenza fallisce)
Una volta installato ci si ritrova con una stampante 'pipslite' e con il seguente processo:

/usr/lib/pipslite/pipslited -p /var/run/pipslited.pid

E in CUPS risultano sia la stampante via USB che questa via lp

Epson Inkjet Printer #1 (Photo Image Print System Lite)
Connessione: pipslitelp:/var/run/pipslitelp0

Il problema è che anche usando questa rimane il fatto che fallisce la ricerca del driver e quindi la gui di
CUPS si blocca, l'unico mezzo è seguire quanto c'è nel README di pipslite e andare via riga di comando:

# lpadmin -p PRINTER_NAME -v pipslitelp:/var/run/pipslitelp0 -P PPD_FILE -E

A questo punto mi sono trovato la mia stampante in CUPS e funziona a meraviglia (finalmente!)

Spero possa essere utile anche ad altri

ciao
Marco

Ritratto di Abbio
Abbio
(Newbie)
Offline
Newbie
Iscritto: 22/02/2012
Messaggi: 1

Sì ma non è possibile dover fare una procedura del genere per una stampante che con altre distribuzioni viene automaticamente installata senza problemi... La mia prima grande delusione di openSuse... Io per la mia SX100 ho installato PIPS scaricato dal sito della Epson, mi compare fra le stampanti visualizzate in Yast ma non mi stampa un fico secco. Non so se ho voglia di provare tutta sta procedura, purtroppo sto pensando di rebootare su Kubuntu e rimanerci per un bel pezzo sul muletto...

Ritratto di marco.azzalini
marco.azzalini
(Junior)
Offline
Junior
Iscritto: 18/02/2012
Messaggi: 11

Ciao, scusa il ritardo. Tendenzialmente hai ragione, è un vero peccato che una distro come OpenSuse caschi su queste cose. Ad ogni modo io con Yast non ho mai avuto una gran fortuna con le stampanti. Visto che a te mi pare di capire i driver li vede bene, hai provato a cancellarla e ricrearla da CUPS, da Amministrazione|Stampanti|Aggiungi stampante?

fammi sapere se puoi.

ciao
Marco

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1741

marco.azzalini ha scritto:


La buona notizie invece è che ho risolto il problema! Smile

In pratica per riuscire ad installare pacchetto pipslite-1.4.0-5.i386.rpm ho installato glib e gtk
in versione 1 (che sono delle sue dipendenze) e poi ho forzato l'installazione perchè c'era comunque
un conflitto con le libjpeg (la Suse 12.1 ha la versione libjpeg ma è marcata come libjpeg6 e quindi il controllo di dipendenza fallisce)
Una volta installato ci si ritrova con una stampante 'pipslite' e con il seguente processo:
(...)

Invece con i diritti di root vai su /lib/ fai una ricerca di libjpeg e duplica quello che trovi come libjpeg6 in libjpeg.

reinstalla pipslite-1.4.0-5.i386.rpm ed op-la!

Party

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao