Firefox dopo upgrade non parte, messaggio "Inconsistency detected by ld.so: dl-open.c

4 risposte [Ultimo messaggio]
Ritratto di elasoft
elasoft
(Junior)
Offline
Junior
Iscritto: 11/01/2009
Messaggi: 6

Sperando di aiutare chi ha questo problema:
Dopo recente upgrade non sono più stato in grado di avviare Firefox, da KDE ci pensava un pò su e non partiva nulla, mentre da shell ottenevo il msg:
Inconsistency detected by ld.so: dl-open.c: 596: _dl_open: Assertion `_dl_debug_initialize (0, args.nsid)->r_state == RT_CONSISTENT' failed!
Ho disinstallato e reinstallato Firefox usando il gestore di pacchetti... nulla!
Ho cercato sul web... tutte soluzioni inutili o complicate! Anche se il sintomo comune a tutte le distro sembra essere un plugin oppure un'estensione incompatibile...
Ho scaricato ultima versione da http://releases.mozilla.org/pub/mozilla.org/firefox/releases/latest/linux-x86_64/it/
Ho rinominato /usr/lib64/firefox per non perdere l'installazione di default;
Ho estratto il .bz2 di ultima versione scaricata in /usr/lib64
Firefox è partito al volo!!!!
Ora non ho tempo di studiare cosa è successo e vedere se manca qualcosa al Firefox così ripristinato, ma il browser funziona con i suoi plugin Flash e Java e tanto mi basta per lavorare.

Ritratto di Andrea85
Andrea85
(Collaboratore)
Offline
Collaboratore
Iscritto: 22/12/2008
Messaggi: 801

Grazie!

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1750

Potrebbe essere che avevi installato la 32bit. Quella non funziona su 64.

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di Templare
Templare
(Collaboratore)
Offline
Collaboratore
Iscritto: 28/10/2011
Messaggi: 747

elasoft ha scritto:

Sperando di aiutare chi ha questo problema:
Dopo recente upgrade non sono più stato in grado di avviare Firefox, da KDE ci pensava un pò su e non partiva nulla, mentre da shell ottenevo il msg:
Inconsistency detected by ld.so: dl-open.c: 596: _dl_open: Assertion `_dl_debug_initialize (0, args.nsid)->r_state == RT_CONSISTENT' failed!
Ho disinstallato e reinstallato Firefox usando il gestore di pacchetti... nulla!
Ho cercato sul web... tutte soluzioni inutili o complicate! Anche se il sintomo comune a tutte le distro sembra essere un plugin oppure un'estensione incompatibile...
Ho scaricato ultima versione da http://releases.mozilla.org/pub/mozilla.org/firefox/releases/latest/linux-x86_64/it/
Ho rinominato /usr/lib64/firefox per non perdere l'installazione di default;
Ho estratto il .bz2 di ultima versione scaricata in /usr/lib64
Firefox è partito al volo!!!!
Ora non ho tempo di studiare cosa è successo e vedere se manca qualcosa al Firefox così ripristinato, ma il browser funziona con i suoi plugin Flash e Java e tanto mi basta per lavorare.

Grazie per averlo condiviso con noi

Assemblato 1: Phenom II X4 965 Black Edition + AMD Radeon HD 5770 + Scheda Madre Asus Crosshair IV Formula + Scheda Audio Asus Xonar D2X. Sistema Windows 7 Ultimate 64 Bit
Assemblato 3: Intel Core i3 3220 + nVIDIA Geforce 640 GT. Sistema openSUSE 13.1 64 bit GNOME

Ritratto di elasoft
elasoft
(Junior)
Offline
Junior
Iscritto: 11/01/2009
Messaggi: 6

No no, si tratta proprio della 64bit: se leggi bene il problema l'ho avuto dopo un upgrade generale del sistema.