Installare driver chiavetta Wi-fi D-link DWL-G122 rev.E1

19 risposte [Ultimo messaggio]
Ritratto di kimiko1086
kimiko1086
(Junior)
Offline
Junior
Iscritto: 04/03/2007
Messaggi: 34

massiccio@linux-h154:~> iwlist scan
Absolute path to 'iwlist' is '/usr/sbin/iwlist', so running it may require superuser privileges (eg. root).
massiccio@linux-h154:~> su
Password:
linux-h154:/home/massiccio # iwlist scan
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

vboxnet0 Interface doesn't support scanning.

wlan0 Interface doesn't support scanning : Network is down

linux-h154:/home/massiccio #

Ritratto di Gollum
Gollum
(Collaboratore)
Offline
Collaboratore
Iscritto: 03/03/2005
Messaggi: 802

Thinking

Output del comando dmesg | grep rt2870

Desktop DELL XPS8100 => openSUSE_12.2 => KDE 4.10 => Core i7 => 3.4.28-2.20 => Nvidia GT220
Notebook Sony Vaio VPPCA =>openSUSE_12.2 => KDE 4.10 => Core i5 => 3.4.28-2.20 => AMD HD 6470M

Ritratto di Gollum
Gollum
(Collaboratore)
Offline
Collaboratore
Iscritto: 03/03/2005
Messaggi: 802

Penso che manchi il firmware che attivi il modulo rt2870 per esserne sicuro dall'output del comando dmesg dovrebbe essere chairo il messaggio che il kernel restituisce.
Se è come penso, credo che si possa risolvere installando il pacchetto kernel-firmware e, usando KnetworkManager come gestore della rete.
Usa il comando

# zypper in kernel-firmware

Desktop DELL XPS8100 => openSUSE_12.2 => KDE 4.10 => Core i7 => 3.4.28-2.20 => Nvidia GT220
Notebook Sony Vaio VPPCA =>openSUSE_12.2 => KDE 4.10 => Core i5 => 3.4.28-2.20 => AMD HD 6470M

Ritratto di kimiko1086
kimiko1086
(Junior)
Offline
Junior
Iscritto: 04/03/2007
Messaggi: 34

eccolo

massiccio@linux-h154:~> dmesg | grep rt2870
[ 5681.596147] rt2870sta: module is from the staging directory, the quality is unknown, you have been warned.
[ 5681.608300] usbcore: registered new interface driver rt2870

Ritratto di kimiko1086
kimiko1086
(Junior)
Offline
Junior
Iscritto: 04/03/2007
Messaggi: 34

Gollum ha scritto:

Penso che manchi il firmware che attivi il modulo rt2870 per esserne sicuro dall'output del comando dmesg dovrebbe essere chairo il messaggio che il kernel restituisce.
Se è come penso, credo che si possa risolvere installando il pacchetto kernel-firmware e, usando KnetworkManager come gestore della rete.
Usa il comando

# zypper in kernel-firmware

kernel-firemware risulta già installato trà i pacchetti, ho impostato knetworkmanager e mi è usciata un'iconcina stilizzata della rete, ma del wi-fi nessuna traccia, la spia è spenta.

il comando # zypper in kernel-firmware non mi ha ristituito nulla

Ritratto di kimiko1086
kimiko1086
(Junior)
Offline
Junior
Iscritto: 04/03/2007
Messaggi: 34

riavviato sistema, partito tutto correttamente!!! grazie 1000 dell'aiuto!

Ritratto di Gollum
Gollum
(Collaboratore)
Offline
Collaboratore
Iscritto: 03/03/2005
Messaggi: 802

Ottimo lavoro Wink

Desktop DELL XPS8100 => openSUSE_12.2 => KDE 4.10 => Core i7 => 3.4.28-2.20 => Nvidia GT220
Notebook Sony Vaio VPPCA =>openSUSE_12.2 => KDE 4.10 => Core i5 => 3.4.28-2.20 => AMD HD 6470M

Ritratto di kimiko1086
kimiko1086
(Junior)
Offline
Junior
Iscritto: 04/03/2007
Messaggi: 34

unica cosa che mi sembra strana, l'SSID deve essere visibile se no non si connette ... solitamente utilizzo l'SSID hidden ... anche tu hai riscontrato problemi simili?

Ritratto di Gollum
Gollum
(Collaboratore)
Offline
Collaboratore
Iscritto: 03/03/2005
Messaggi: 802

Non mi è mai capitato perchè non uso connessioni wireless, però dovresti poter ovviare dalle impostazioni di KnetworkManager. Clicca su l'icona della rete, poi lascia il mouse qualche secondo sulla voce dove si trova il nome della rete (ad es. Wlan0) guarda cosa ti dice.

Desktop DELL XPS8100 => openSUSE_12.2 => KDE 4.10 => Core i7 => 3.4.28-2.20 => Nvidia GT220
Notebook Sony Vaio VPPCA =>openSUSE_12.2 => KDE 4.10 => Core i5 => 3.4.28-2.20 => AMD HD 6470M