OSuse 13.1 Driver NVidia proprietari aiuto per procedura di installazione

17 risposte [Ultimo messaggio]
Ritratto di 3nricox
3nricox
(Geek)
Offline
Geek
Iscritto: 28/02/2012
Messaggi: 75

Ho installato la nuova relase 13.1 di OpenSUSE, installazione "pulita", vorrei procedere alla sostituzione dei driver installati di default "Nouveau" con quelli proprietari NVidia.

Ho letto l'articolo di Templare, in prima pagina, "Benvenuta openSUSE 13.1 LTS! Con alcune annotazioni..." dove segnala e suggerisce la procedura di installazione per le schede grafiche NVidia

cito:

"PS: Riguardo i driver nVIDIA per schede RECENTI (dalla serie 8000 fino la serie 700), potete provare a cuor leggero (significa che siete disposti in caso di problemi a reinstallare tutto) a installare questo pacchetto (non dò garanzia del successo in quanto non l'ho provato) da questo link:

http://software.opensuse.org/download.html?project=home%3Antami%3Anvidia&package=nvidia-gfxG03 "

Ho provato la procedura disinstallando i Nouveau ma aimè la cosa non è andata a buon fine

Quindi per farla breve vi chiedo cortesemente se potete indicarmi i vari passaggi da seguire per portare a termine in modo corretto questa installazione.

P.S.:
Driver NVidia proprietari su scheda grafica GForce 8500 GT.

Grazie, Enrico.

HP Pavilion 500-333nl - Intel Core i7-4790S CPU 3.20GHz - 16GB DDR3 - NVIDIA GeForce GTX 745 - 4GB - Monitor: HP Envy 23" led 1080p - NVIDIA High Definition Audio - SSD SanDisk 16GB - HDD Seagate Barracuda 2TB

Ritratto di Craft
Craft
(Geek)
Offline
Geek
Iscritto: 19/09/2009
Messaggi: 77

A breve potrai installarli col comodissimo 1-click.....aspetta qualche giorno

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2727

http://download.opensuse.org/repositories/home:/ntami:/nvidia/openSUSE_13.1/
aggiungi questo repo.
ciao

SUSE Tumbleweed- kernel-5.2.14-1-1 kde-plasma-5.16.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di 3nricox
3nricox
(Geek)
Offline
Geek
Iscritto: 28/02/2012
Messaggi: 75

Ciao Dragoncello ciao Craft ciao SuseItalia

Ho già provato con quel repo e con i driver x11-video-nvidiaG03-331.20-21.1.i586.rpm ma non vanno vengono installati ma mi ritrovo con una risoluzione di 640x480

poi se da yast2 installo altro per capire se le cose possono cambiare

e riavvio il sistema il risultato è questo:


quindi dal login:

su
password
sudo yast

Per rimuovere driver nvidia e repositoty

Altra prova:

aggiunta dei repository Bumblebee-Project_nVidia

http://download.opensuse.org/repositories/home:/Bumblebee-Project:/nVidia:/latest/openSUSE_13.1/

ma il risultato non cambia risoluzione 640x480 e aggiungendo

al riavvio ... FATAL: ERROR .... ecc. ecc. potrei provare ancora con il file .run scaricabile direttamente dal sito nvidia, ma mi sa che a questo punto conviene aspettare che qualcosa esca fuori ufficialmente nel portale opensuse.

Ok! grazie, saluti, enrico.

HP Pavilion 500-333nl - Intel Core i7-4790S CPU 3.20GHz - 16GB DDR3 - NVIDIA GeForce GTX 745 - 4GB - Monitor: HP Envy 23" led 1080p - NVIDIA High Definition Audio - SSD SanDisk 16GB - HDD Seagate Barracuda 2TB

Ritratto di Craft
Craft
(Geek)
Offline
Geek
Iscritto: 19/09/2009
Messaggi: 77

Ho avuto lo stesso tuo problema....ma a me è andata peggio, il pc si è bloccato e non si avviava più.....ho reinstallato con gnome (prima avevo kde) e per ora vado bene con i driver nvidia open, appena arriverà il 1 click installerò con quello....

Ritratto di Sargon6
Sargon6
(Guru)
Offline
Guru
Iscritto: 13/11/2008
Messaggi: 723

dragoncello ha scritto:

http://download.opensuse.org/repositories/home:/ntami:/nvidia/openSUSE_13.1/
aggiungi questo repo.
ciao


Anche io vorrei installare i driver proprietari per schede video nVidia su due PCsui quali ho installato OpenSUSE 13.1:
- un portatile IBM Lenovo ThinkPad R61 con scheda video nVidia Quadro NVS 140M
opensuse13k1@linux-ogm5:~> /sbin/lspci -nnk | grep VGA -A2
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G86M [Quadro NVS 140M] [10de:0429] (rev a1)
        Subsystem: Lenovo ThinkPad T61 [17aa:20d8]
        Kernel driver in use: nouveau
opensuse13k1@linux-ogm5:~> l

- un PC fisso assemblato con scheda video nVidia GeForce 6150SE nForce 430

opensuse13k1b64@linux-gid6:~> /sbin/lspci -nnk | grep VGA -A2
00:0d.0 VGA compatible controller [0300]: NVIDIA Corporation C61 [GeForce 6150SE nForce 430] [10de:03d0] (rev a2)
        Subsystem: ASRock Incorporation Device [1849:03d0]
        Kernel modules: nvidiafb, nouveau
opensuse13k1b64@linux-gid6:~> 

Se aggiungo il repo suggerito da dragoncello, poi quali pacchetti devo installare per ciascuna scheda video?

E se invece decidessi di instrallare i driver nVidia proprietari usando il metodo "OneClick", la pagina giusta da cui cliccare è questa
http://it.opensuse.org/SDB:Driver_NVIDIA
o è un'altra (quale)?
e se la pagina giusta è proprio questa
http://it.opensuse.org/SDB:Driver_NVIDIA
su cosa devo cliccare per installare i driver proprietari sul portatile con scheda video nVidia Quadro NVS 140M, e su cosa devo cliccare per installare i driver proprietari sul PC assemblato con scheda video nVidia GeForce 6150SE nForce 430 ??
Saluto.

Nel mio blog, ho scritto delle cose che forse ti interessano.
http://www.suseitalia.org/blog/9923

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2727

Sargon6 ha scritto:

dragoncello ha scritto:

http://download.opensuse.org/repositories/home:/ntami:/nvidia/openSUSE_13.1/
aggiungi questo repo.
ciao


Anche io vorrei installare i driver proprietari per schede video nVidia su due PCsui quali ho installato OpenSUSE 13.1:
- un portatile IBM Lenovo ThinkPad R61 con scheda video nVidia Quadro NVS 140M
opensuse13k1@linux-ogm5:~> /sbin/lspci -nnk | grep VGA -A2
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G86M [Quadro NVS 140M] [10de:0429] (rev a1)
        Subsystem: Lenovo ThinkPad T61 [17aa:20d8]
        Kernel driver in use: nouveau
opensuse13k1@linux-ogm5:~> l

- un PC fisso assemblato con scheda video nVidia GeForce 6150SE nForce 430

opensuse13k1b64@linux-gid6:~> /sbin/lspci -nnk | grep VGA -A2
00:0d.0 VGA compatible controller [0300]: NVIDIA Corporation C61 [GeForce 6150SE nForce 430] [10de:03d0] (rev a2)
        Subsystem: ASRock Incorporation Device [1849:03d0]
        Kernel modules: nvidiafb, nouveau
opensuse13k1b64@linux-gid6:~> 

Se aggiungo il repo suggerito da dragoncello, poi quali pacchetti devo installare per ciascuna scheda video?

E se invece decidessi di instrallare i driver nVidia proprietari usando il metodo "OneClick", la pagina giusta da cui cliccare è questa
http://it.opensuse.org/SDB:Driver_NVIDIA
o è un'altra (quale)?
e se la pagina giusta è proprio questa
http://it.opensuse.org/SDB:Driver_NVIDIA
su cosa devo cliccare per installare i driver proprietari sul portatile con scheda video nVidia Quadro NVS 140M, e su cosa devo cliccare per installare i driver proprietari sul PC assemblato con scheda video nVidia GeForce 6150SE nForce 430 ??
Saluto.


Metto il repo vado di aggiornamento e mi setta in automatico i driver per la mia scheda NVIDIA.

SUSE Tumbleweed- kernel-5.2.14-1-1 kde-plasma-5.16.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di Sargon6
Sargon6
(Guru)
Offline
Guru
Iscritto: 13/11/2008
Messaggi: 723

dragoncello ha scritto:

Sargon6 ha scritto:

dragoncello ha scritto:

http://download.opensuse.org/repositories/home:/ntami:/nvidia/openSUSE_13.1/aggiungi questo repo.
ciao

Anche io vorrei installare i driver proprietari per schede video nVidia su due PC...

Metto il repo vado di aggiornamento e mi setta in automatico i driver per la mia scheda NVIDIA.

Sul PC assemblato con scheda video nVidia GeForce 6150SE nForce 430, ho inserito, abilitato e flaggato come "Aggiornamento automatico" il repository suggerito da dragoncello. poi ho spent il PC, riacceso il PC, ed ho tentato di fare un aggiornamento.
Secondo YaST non c'era nulla da aggiornare.
Perché i dirver attualmente installati sono preferiti ai driver proprietari?

Nel mio blog, ho scritto delle cose che forse ti interessano.
http://www.suseitalia.org/blog/9923

Ritratto di Duke
Duke
(Geek)
Offline
Geek
Iscritto: 13/10/2010
Messaggi: 57

Dato che per la mia scheda (NVIDIA GeForce 7035) la 13.1 aveva dei driver Nouveau farlocchi (schermo a macchie, instabilità del sistema etc...) e che NVIDIA e che i repository non contenevano i driver aggiornati (ne tanto meno era prevista l'opzione del 1 click), ho provato con l'installazione dell'eseguibile. Ho quindi scaricato il pacchetto NVIDIA-Linux-x86_64-304.116.run (quello per la mia scheda) e ho la procedura qui sotto:

1. assicurarsi di aver prima scaricato i sorgenti del kernel e riavviare il sistema
2. all'avvio di Grub premere “e” e cercare la riga che inizia con “linux...”, portarsi alla fine e aggiungere “nomodeset 3”, premere F10 e autenticarsi con “root” al termine del caricamento del sistema;
3. portarsi nella cartella dove si è salvato il pacchetto;
4. digitare sh ./NVIDIA-Linux-x86_64-304.116.run e seguire le istruzioni a video.

Ci pensa l'eseguibile a disabilitare i Nouveau mettendoli in black list e a caricare i nuovi moduli.
Ovvio che tale operazione, essendo fatta al di fuori di Yast, deve essere ripetuta quando si aggiorna il kernel.

p.s.: fino alla 12.2 i driver Nouveau funzionavano benissimo, da lì in avanti solo rogne, almeno per quello che riguarda la mia scheda...

Ritratto di Arin
Arin
(Junior)
Offline
Junior
Iscritto: 18/11/2009
Messaggi: 44

salve a tutti,
per i driver Nvidia, basta andare su yast

  • andare su Repository dei programmi clicca su aggiungi
    seleziona Repository della comunità
    clicca avanti
    seleziona i repoche interessano tra i quali quelli di Nvidia
    fai aggiornare la lista
    finito, vai su Gestione pacchetti
    netti su cerca Nvidia
    dovrebbero essere selezionati in automatico i g03
oviamente ciò dovrebbe essere fatto ad istallazione pulita, per non esserci conflitti con repo non ufficiali.

Ritratto di dax
dax
(Geek)
Offline
Geek
Iscritto: 21/11/2004
Messaggi: 170

Di solito installo i driver Nvidia da Repository e fila tutto liscio.

Questa volta però c'è qualche cosa che non va: il PC è lentissimo a spegnersi... ci mette almeno 5 minuti.
Questo proprio da quando ho installato i driver Nvidia.

Qualche idea su come risolvere?

Core i5-2500 @ 3.30 GHz 8GB RAM - AMD RX560
OpenSUSE Tumbleweed
www.arzigogolato.it