problema driver ati radeon 1300

9 risposte [Ultimo messaggio]
Ritratto di mardokk
mardokk
(Junior)
Offline
Junior
Iscritto: 19/10/2007
Messaggi: 21

Allora ho scaricato l'ultima versione del driver dal sito ati, ho seguito alla lettera la vostra guida per l'installazzione però al passo tre dove dò il comando rpm -Uvh fgl*.rpm invece di installare mi da tutte queste dipendenze :

libgl libice libsm lib x11 libx cursor libx ext libx i libx randr libc.so.6 libdl.so lib fontconfig lib freetype.so libgcc_s.so.1 libm.so.6 libpthread.so
librt.so libatdc++.so.s

cosa sono?

Ritratto di anubis
anubis
(Guru)
Offline
Guru
Iscritto: 07/04/2007
Messaggi: 3656

i drivers ati non supportano più i dispositivi radeon oramai vecchi, i drivers open di xorg fanno bene il loro dovere, da root digita

sax2 -r -m 0=radeon

quindi sempre da sax abilita il 3d!

---edit---

quelle comunque sono librerie mancanti che devi installare prima di installare il pacchetto che le richiede!

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el

Ritratto di mardokk
mardokk
(Junior)
Offline
Junior
Iscritto: 19/10/2007
Messaggi: 21

come faccio ad installare quelle librerie? ho provato con il gestore di pacchetti ma per ogni voce mi da un sacco di pacchetti, cosa devo fare? aiutatemi sto impazzendo.

Ritratto di anubis
anubis
(Guru)
Offline
Guru
Iscritto: 07/04/2007
Messaggi: 3656

ti ricordo che:
Quote:

anubis ha scritto:
i drivers ati non supportano più i dispositivi radeon oramai vecchi, i drivers open di xorg fanno bene il loro dovere, da root digita

sax2 -r -m 0=radeon

quindi sempre da sax abilita il 3d!

ciò vuol dire che installare i drivers ufficiali non servirebbe a niente, ad ogni modo, da yast metti il check SOLO su rpm PROVIDES quindi cerca quelle librerie

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el

Ritratto di mardokk
mardokk
(Junior)
Offline
Junior
Iscritto: 19/10/2007
Messaggi: 21

Allora ho cercato di mettere queste librerie:
error: Failed dependencies:
libGL.so.1()(64bit) is needed by fglrx64_7_1_0_SUSE103-8.42.3-1.x86_64
libICE.so.6()(64bit) is needed by fglrx64_7_1_0_SUSE103-8.42.3-1.x86_64
libSM.so.6()(64bit) is needed by fglrx64_7_1_0_SUSE103-8.42.3-1.x86_64
libX11.so.6()(64bit) is needed by fglrx64_7_1_0_SUSE103-8.42.3-1.x86_64
libXcursor.so.1()(64bit) is needed by fglrx64_7_1_0_SUSE103-8.42.3-1.x86
_64
libXext.so.6()(64bit) is needed by fglrx64_7_1_0_SUSE103-8.42.3-1.x86_64
libXi.so.6()(64bit) is needed by fglrx64_7_1_0_SUSE103-8.42.3-1.x86_64
libXrandr.so.2()(64bit) is needed by fglrx64_7_1_0_SUSE103-8.42.3-1.x86_
64
libXrender.so.1()(64bit) is needed by fglrx64_7_1_0_SUSE103-8.42.3-1.x86
_64
libc.so.6()(64bit) is needed by fglrx64_7_1_0_SUSE103-8.42.3-1.x86_64
libc.so.6(GLIBC_2.2.5)(64bit) is needed by fglrx64_7_1_0_SUSE103-8.42.3-
1.x86_64
libc.so.6(GLIBC_2.3)(64bit) is needed by fglrx64_7_1_0_SUSE103-8.42.3-1.
x86_64
libdl.so.2()(64bit) is needed by fglrx64_7_1_0_SUSE103-8.42.3-1.x86_64
libdl.so.2(GLIBC_2.2.5)(64bit) is needed by fglrx64_7_1_0_SUSE103-8.42.3
-1.x86_64
libfontconfig.so.1()(64bit) is needed by fglrx64_7_1_0_SUSE103-8.42.3-1.
x86_64
libfreetype.so.6()(64bit) is needed by fglrx64_7_1_0_SUSE103-8.42.3-1.x8
6_64
libgcc_s.so.1()(64bit) is needed by fglrx64_7_1_0_SUSE103-8.42.3-1.x86_6 4
libgcc_s.so.1(GCC_3.0)(64bit) is needed by fglrx64_7_1_0_SUSE103-8.42.3- 1.x86_64
libm.so.6()(64bit) is needed by fglrx64_7_1_0_SUSE103-8.42.3-1.x86_64
libm.so.6(GLIBC_2.2.5)(64bit) is needed by fglrx64_7_1_0_SUSE103-8.42.3- 1.x86_64
libpthread.so.0()(64bit) is needed by fglrx64_7_1_0_SUSE103-8.42.3-1.x86 _64
libpthread.so.0(GLIBC_2.2.5)(64bit) is needed by fglrx64_7_1_0_SUSE103-8 .42.3-1.x86_64
libpthread.so.0(GLIBC_2.3.2)(64bit) is needed by fglrx64_7_1_0_SUSE103-8 .42.3-1.x86_64
librt.so.1()(64bit) is needed by fglrx64_7_1_0_SUSE103-8.42.3-1.x86_64
librt.so.1(GLIBC_2.2.5)(64bit) is needed by fglrx64_7_1_0_SUSE103-8.42.3 -1.x86_64
libstdc++.so.5()(64bit) is needed by fglrx64_7_1_0_SUSE103-8.42.3-1.x86_ 64
libstdc++.so.5(CXXABI_1.2)(64bit) is needed by fglrx64_7_1_0_SUSE103-8.4 2.3-1.x86_64
libstdc++.so.5(GLIBCPP_3.2)(64bit) is needed by fglrx64_7_1_0_SUSE103-8. 42.3-1.x86_64
Ma quando le cerco nel gestore pacchetti mi dice che le ho già installate come mai?

Ritratto di anubis
anubis
(Guru)
Offline
Guru
Iscritto: 07/04/2007
Messaggi: 3656

onestamente non so probabilmente cerca quelli a 32 bit! cmq ti ricordo che:

i drivers ati non supportano più i dispositivi radeon oramai vecchi, i drivers open di xorg fanno bene il loro dovere, da root digita

sax2 -r -m 0=radeon

quindi sempre da sax abilita il 3d!

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el

Ritratto di mardokk
mardokk
(Junior)
Offline
Junior
Iscritto: 19/10/2007
Messaggi: 21

scusa chiarisco sennò sembra che non voglio darti retta, ho lanciato il comando che mi hai dato ma quando apro sax2 mi da un avvertimento che il 3d non funziona e poi nelle impostazioni mi resta vesa come posso fare per cambiare?

Un'altra domanda in windows avendo uno schermo lcd 32 pollici uso una risoluzione di 1360x768 come mai nell'impostazione di linux non appare?

Ritratto di anubis
anubis
(Guru)
Offline
Guru
Iscritto: 07/04/2007
Messaggi: 3656

la tua è una "mobility"??

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el

Ritratto di mardokk
mardokk
(Junior)
Offline
Junior
Iscritto: 19/10/2007
Messaggi: 21

raedon x1300/x1550 series

Ritratto di moviemaniac
moviemaniac
(Geek)
Offline
Geek
Iscritto: 10/10/2005
Messaggi: 135

Quote:

mardokk ha scritto:
raedon x1300/x1550 series

Ecco!
Allora la prossima volta per piacere, quella x non tralasciarla perchè è fondamentale. Altrimenti è chiaro che anubis sclera a dirti che il driver fglrx non supporta l'hardware vecchio Big Grin

In ogni caso, lascia perdere il driver ati che si scarica dal sito ufficiale.
Se proprio devi mettere il driver ati, hai due alternative:

1) molto consigliata, installa i drivers presenti sui repository ufficiali, quelli già blli e compilati (sono due pacchetti che nel nome hanno fglrx, uno dei due ha nel nome anche una stringa che identifica il tuo kernel, nel mio caso "default")

2) da me sconsigliata, scarica il file .run dal sito ati, rendilo eseguibile e poi avvialo da root, ma invece di creare il file .rpm come consigliato nelle guide, procedi direttamente con l'installazione del driver (procedura automatica), scegli la tua distribuzione e via. funziona decisamente meglio.

Finita l'installazione riavvia il server X con ctrl+alt+backspace

Infine: al primo riavvio del sistema, potresti trovarti con l'icona dell'orologio ferma, e kdm che non si carica (non puoi entrare in kde).

Se dovesse succedere, fai così: ctrl+alt+f1, quindi loggati come root, poi digita il comando

killall glxinfo

quindi digita il comando

exit

quindi ctlr+alt+f7 per tornare a kdm
loggati nel tuo account, avvia yast e aggiorna il server X (ci sono i repo ufficiali)

Ciao

aka FaithFulSoft
once MaxDev's staff developer