Problemi kernel 4.9.3 e driver nvidia 340.101

23 risposte [Ultimo messaggio]
Ritratto di drudox
drudox
(Junior)
Offline
Junior
Iscritto: 25/01/2017
Messaggi: 13

Salve a tutti,
Come da titolo .. uso OpenSuse tumbleweed, quindi per i driver nvidia devo per forza usare gli eseguibili nvidia ... ma da quando ho aggiornato il nuovo kernel (e per altro sono stati rilasciati anche i nuovi driver da NVIDIA) ottengo un errore subito dopo la fase di building kernel module :

Error: unable to load kernel module 'nvidia.ko' this happens most frequently when this kernel module was built against the wrong or 
improperly configured kernel sources, with a version of gcc that differs from the one used to build the target kernel, or if a driver such a rivafb, nvidiafb , or nouveau is present and prevents the NVIDIA kernel module from obtaining the ownership of the NVIDIA graphics device(s) , or no NVIDIA GPU installed in this system is supported by this NVIDIA linux graphics driver relese

in questo link troverete il file di log
[url] https://paste.pound-python.org/show/30u3msNZVaBFDttrkiqx/[/url]

spero qualcuno possa darmi una mano

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2721

Scheda video nvida? sono stati messi in blaklist i nouveau? una volta eliminati i nouveau,da shell come root dai:
mkinitrd

SUSE Tumbleweed- kernel-5.1.4-1.2- kde-plasma-5.15.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di drudox
drudox
(Junior)
Offline
Junior
Iscritto: 25/01/2017
Messaggi: 13

Geforce 210

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2721

rispondi alle domande del post sopra.

SUSE Tumbleweed- kernel-5.1.4-1.2- kde-plasma-5.15.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di drudox
drudox
(Junior)
Offline
Junior
Iscritto: 25/01/2017
Messaggi: 13

Si messi in blacklist i nouveau, e` una installazione che faccio spesso .. usando tumbleweed il link che mi hai dato a che mi serve ?

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2721

Quindi stanno già in blacklist? dai da shell come root il comando per pulire residui nvidia:
nvidia-installer --uninstall poi dai un bel:mkinitrd
poi riprovi a installare nuovamente i drive nvidia
il link l'ho aperto per vedere quale drive sono per la tua scheda grafica.
Ma non ti conviene aggiornare il kernel 4.9.4 visto che ci devi mettere le mani,per poi reinstallare i drive.

SUSE Tumbleweed- kernel-5.1.4-1.2- kde-plasma-5.15.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di drudox
drudox
(Junior)
Offline
Junior
Iscritto: 25/01/2017
Messaggi: 13

non e` ancora uscito il 4.9.4 ... ora provo i comandi

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2721

Errore: impossibile caricare il modulo del kernel 'nvidia.ko' questo accade più di frequente quando questo modulo del kernel è stato costruito contro il male o
non configurato correttamente sorgenti del kernel, con una versione di gcc che si differenzia da quello utilizzato per costruire il kernel di destinazione, o se un driver tale rivafb, nvidiafb, o nouveau è presente e impedisce che il modulo del kernel di NVIDIA di ottenere la proprietà della grafica NVIDIA dispositivo (s), o nessuna GPU NVIDIA installato in questo sistema è supportato da questa grafica NVIDIA Linux conducente relese
la traduzione dell'errore.
è uscito il 24 lo vedi in firma sull mio sistema.

SUSE Tumbleweed- kernel-5.1.4-1.2- kde-plasma-5.15.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di drudox
drudox
(Junior)
Offline
Junior
Iscritto: 25/01/2017
Messaggi: 13

su che repositori ?? io ho fatto un upgrade oggi ma niente !

cmq ho dato i comandi .. ma stesso errore

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2721

Metti i nvidia antecedenti ai 340.101,sicuramente non sono stati compilati per i kernel 4.9.3...
http://download.opensuse.org/tumbleweed/iso/
io installa con la net scaricando da qui.

SUSE Tumbleweed- kernel-5.1.4-1.2- kde-plasma-5.15.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di drudox
drudox
(Junior)
Offline
Junior
Iscritto: 25/01/2017
Messaggi: 13

Ho fatto l'upgrade al 4.9.4 ... ho lanciato di nuovo l'installer ma stesso messaggio :\