Scheda lan RTL8111/8168/8411 prestazioni

4 risposte [Ultimo messaggio]
Ritratto di mictre
mictre
(Junior)
Offline
Junior
Iscritto: 08/03/2005
Messaggi: 20

Ciao A tutti,

Ho un problema di prestazioni con la scheda in oggetto

19:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
Subsystem: Micro-Star International Co., Ltd. [MSI] Device 7a34
Flags: bus master, fast devsel, latency 0, IRQ 66
I/O ports at f000 [=256]
Memory at fe604000 (64-bit, non-prefetchable) [=4K]
Memory at fe600000 (64-bit, non-prefetchable) [=16K]
Capabilities: [40] Power Management version 3
Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [70] Express Endpoint, MSI 01
Capabilities: [b0] MSI-X: Enable- Count=4 Masked-
Capabilities: [100] Advanced Error Reporting
Capabilities: [140] Virtual Channel
Capabilities: [160] Device Serial Number 01-00-00-00-68-4c-e0-00
Capabilities: [170] Latency Tolerance Reporting
Capabilities: [178] L1 PM Substates
Kernel driver in use: r8168
Kernel modules: r8169, r8168

In pratica pur essendo collegato ad uno switch gigabit la scheda non va oltre i 40/45 Mbyte al secondo quando scrivo leggo su un nas.

Ho letto che opensise leap 15.1 ha bannato il driver r8169 per problemi, qualcuno riesce a darmi una dritta.

Grazie

Ritratto di CarloCC
CarloCC
(Monster)
Offline
Monster
Iscritto: 06/04/2017
Messaggi: 384

Prova a vedere se trovi qualcosa che ti interessa qui https://software.opensuse.org/search?utf8=%E2%9C%93&baseproject=ALL&q=r8168

Acer Aspire E1-522 Amd Quad-Core E2-3800--Amd Radeon 8280
Acer Aspire M5500 Intel Quad-Core - Amd Radeon R5 230
Distribuzione openSUSE Leap 15 Kde Plasma5 - Tumbleweed

Ritratto di mictre
mictre
(Junior)
Offline
Junior
Iscritto: 08/03/2005
Messaggi: 20

Ciao Grazie,

Ho gia provato, con scarsi risultati.

Per il momento ho aggornato il kernel alla versione 5.6 e rimosso il r8168 in favore del r8169 standanrd, le prerstazioni sembrano migliori, vediamo come va.
Ma penso che sia proprio la scheda schifosa o i driver.

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1761

È l'auto-negoziazione di quella scheda, in pratica si setta sentendo il router cosa dice e scende di velocità perchè non capisce velocità superiori.

Quindi è da provare quello descritto qui:
https://francoconidi.it/variare-la-velocita-della-scheda-di-rete-in-linux/

Ovvero imporre la tua velocità e disabilitare l'auto-negoziazione.

Nel caso imporre una giusta negoziazione al tuo router, ma qui si tocca il tasto dolente che ogni router dispone di un suo sistema (bisogna vedere sul router ci dovrebbe essere una sezione del suo menu dedicata) e poi non è detto che sbagli il router magari quella gli dice la velocità minima ed è la scheda che sbaglia pensando che sia la massima. Un aggiornamento firmware del router (è nelle impostazioni del router ed è facile e sicuro) spesso risolve questo problema senza smanettare troppo.

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di mictre
mictre
(Junior)
Offline
Junior
Iscritto: 08/03/2005
Messaggi: 20

Cioa Mauriziod, grazie per la dritta. Il router è un mikrotik rb750 ed è dietro uno switch non credo sia lui il problema (acne perche l'rb750 è di classe 10/100), provo a disabilitare l'auto-negoziazione e impostare la velocità manualmente e vedere come si comporta.