Schermo nero all'avvio di OpenSUSE 42.1

13 risposte [Ultimo messaggio]
Ritratto di Sargon6
Sargon6
(Guru)
Offline
Guru
Iscritto: 13/11/2008
Messaggi: 723

Scarico il DVD di OpenSUSE 42.1 64 bit dal sito ufficiale, installo la versione LXDE nella partizione

File system    Tipo      Dim. Usati Dispon. Uso% Montato su
/dev/sda7      ext4       20G  5,2G     14G  29% /mnt/L2

di un portatile Sony Vaio VGN-FE41M che, visto da PCLinuxOS montato in un'altra partizione dello stesso, ha queste caratteristiche
[pclinuxosm@localhost ~]$ lspci -nnk | grep VGA -A3
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G72M [GeForce Go 7400] [10de:01d8] (rev a1)
	Subsystem: Sony Corporation Device [104d:81ef]
	Kernel driver in use: nvidia
	Kernel modules: nvidia304, nvidia96xx, nvidia-current, nvidia173, nvidiafb, nouveau
[pclinuxosm@localhost ~]$ lscpu
Architecture:          i686
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                2
On-line CPU(s) list:   0,1
Thread(s) per core:    1
Core(s) per socket:    2
Socket(s):             1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 15
Model name:            Intel(R) Core(TM)2 CPU         T5500  @ 1.66GHz
Stepping:              2
CPU MHz:               1000.000
CPU max MHz:           1667,0000
CPU min MHz:           1000,0000
BogoMIPS:              3325.02
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              2048K
Flags:                 fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm lahf_lm dtherm tpr_shadow
[pclinuxosm@localhost ~]$ free -o
             total       used       free     shared    buffers     cached
Mem:       2073264    1416932     656332          0      42236     423628
Swap:      2096476          0    2096476
[pclinuxosm@localhost ~]$ df -T -h
File system    Tipo      Dim. Usati Dispon. Uso% Montato su
/dev/root      ext4       20G  9,0G    9,4G  49% /
/dev           devtmpfs 1010M  792K   1009M   1% /dev
none           tmpfs    1013M  236K   1013M   1% /dev/shm
/dev/sda6      ext4       20G  6,6G     12G  36% /mnt/L1
/dev/sda7      ext4       20G  5,2G     14G  29% /mnt/L2
/dev/sda9      ext4       20G  7,4G     11G  41% /mnt/L4
/dev/sda10     ext4       20G  2,9G     17G  16% /mnt/L5
/dev/sda1      fuseblk    28G  9,0G     20G  32% /mnt/Win
/dev/sda11     ext4      104G   58G     46G  56% /mnt/dati
[pclinuxosm@localhost ~]$ 

All'avvio, amara sorpresa: SCHERMO NERO.
Avvio la riga di comando di OpenSUSE 42.1 e, quello che segue è l'output del comando
lspci -v |grep -iA13 vga > vga.txt
01:00.0 VGA compatible controller: NVIDIA Corporation G72M [GeForce Go 7400] (rev a1) (prog-if 00 [VGA controller])
	Subsystem: Sony Corporation Device 81ef
	Flags: bus master, fast devsel, latency 0, IRQ 29
	Memory at d1000000 (32-bit, non-prefetchable) [size=16M]
	Memory at b0000000 (64-bit, prefetchable) [size=256M]
	Memory at d0000000 (64-bit, non-prefetchable) [size=16M]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [60] Power Management version 2
	Capabilities: [68] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [78] Express Endpoint, MSI 00
	Capabilities: [100] Virtual Channel
	Capabilities: [128] Power Budgeting <?>
	Kernel driver in use: nouveau
	Kernel modules: nouveau
impartito da Super Utente.

A questo punto, presumo che sia un problema di scheda grafica, anche perché su PCLinuxOS ho installato i driver proprietari e funziona a meraviglia, mentre da OpenSUSE 42.1 con i driver nouveau ho lo schermo nero.

Risolverei qualcosa se installassi i driver proprietari da riga di comando? Se SI, come si fa?

Nel mio blog, ho scritto delle cose che forse ti interessano.
http://www.suseitalia.org/blog/9923

Ritratto di boffo
boffo
(Guru)
Offline
Guru
Iscritto: 17/10/2005
Messaggi: 687

https://it.opensuse.org/SDB:NVIDIA_la_via_difficile

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2719

Ciao sarcons6,non ti perdi niente se non la installi plasma 5 è veramente inguardabile,non ci sono settaggi rimani come uno scemo siamo tornati indietro,invece di migliorare,almeno potevano presentarcelo piu in là,o almeno farci scegliere tra plasma e kde4,kde4 tutta la vita,fanculo plasma 5.

SUSE Tumbleweed- kernel-5.1.3-1.2- kde-plasma-5.15.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di Sargon6
Sargon6
(Guru)
Offline
Guru
Iscritto: 13/11/2008
Messaggi: 723

boffo ha scritto:

https://it.opensuse.org/SDB:NVIDIA_la_via_difficile


Premo la combinazione di tasti [Ctrl]+[Alt]+[F2] per avviare la riga di comando.
Eseguo il Log-In
Impartisco i comandi per diventare SuperUtente ed installare i pacchetti gcc make kernel-devel
su
zypper install gcc
zypper install make
zypper install kernel-devel

accedo alla pagina WEB
http://www.nvidia.it/Download/index.aspx?lang=it
e da lì cerco i driver per la mia scheda video GeForce Go 7400
[GeForce] [GeForce Go 7 series (NoteBook)] [GeForce Go 7400] [Linux 64-bit]

Scarico il file NVIDIA-Linux-x86_64-304.131.run
e lo copio nella home dell'utente di OpenSUSE 42.1

(proseguo domani, adesso sono stanco, e non vorrei fare cavolate...)

Nel mio blog, ho scritto delle cose che forse ti interessano.
http://www.suseitalia.org/blog/9923

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 877

Sargon6 possibile che son anni che conosci Opensuse e ancora dimentichi che Yast si avvia anche testuale , da li aggiungi il repo nvidia e poi installi i driver ?

Ritratto di Sargon6
Sargon6
(Guru)
Offline
Guru
Iscritto: 13/11/2008
Messaggi: 723

Grinch ha scritto:

Sargon6 possibile che son anni che conosci Opensuse e ancora dimentichi che Yast si avvia anche testuale , da li aggiungi il repo nvidia e poi installi i driver ?


Mai avviato OpenSUSE in modalità testuale.
Se mi spieghi come fare l'operazione da te appena nominata, ne darò tesoro.
Al momento, sono riuscito solo ad avviare Yast in modalità testuale, ed a fare gli aggiornamenti.
Non ho idea di come fare per aggiungere i repo nvidia.
Sto andando per tentativi.
Ho inutilmente tentato di installare il repo ftp
ftp://download.nvidia.com/opensuse/leap/42.1/

Ricevo il messaggio:

impossibile accedere al supporto di installazione
ftp://download.nvidia.com/opensuse/leap/42.1/
(supporto 1)
Verificare che il server sia accessibile.

E poi, se riuscissi ad accedere, dentro
ftp://download.nvidia.com/opensuse/leap/42.1/x86_64/
c'è
Nome 	Dimensione 	Ultima modifica
File: _buildenv
	17 KB 	02/11/2015 	18:32:00
File: _statistics
	1 KB 	02/11/2015 	18:32:00
File: nvidia-computeG02-304.128-34.1.x86_64.rpm
	9246 KB 	02/11/2015 	18:33:00
File: nvidia-computeG03-340.93-36.1.x86_64.rpm
	13241 KB 	02/11/2015 	18:33:00
File: nvidia-computeG04-352.55-17.1.x86_64.rpm
	12157 KB 	02/11/2015 	18:34:00
File: nvidia-gfxG02-kmp-default-304.128_k4.1.12_1-33.7.x86_64.rpm
	3470 KB 	02/11/2015 	18:34:00
File: nvidia-gfxG02-kmp-pv-304.128_k4.1.12_1-33.7.x86_64.rpm
	3469 KB 	02/11/2015 	18:34:00
File: nvidia-gfxG03-kmp-default-340.93_k4.1.12_1-36.7.x86_64.rpm
	3656 KB 	02/11/2015 	18:35:00
File: nvidia-gfxG03-kmp-pv-340.93_k4.1.12_1-36.7.x86_64.rpm
	3652 KB 	02/11/2015 	18:35:00
File: nvidia-gfxG04-kmp-default-352.55_k4.1.12_1-17.5.x86_64.rpm
	3628 KB 	02/11/2015 	18:35:00
File: nvidia-gfxG04-kmp-pv-352.55_k4.1.12_1-17.5.x86_64.rpm
	3618 KB 	02/11/2015 	18:35:00
File: nvidia-glG03-340.93-36.1.x86_64.rpm
	21380 KB 	02/11/2015 	18:37:00
File: nvidia-glG04-352.55-17.1.x86_64.rpm
	20205 KB 	02/11/2015 	18:38:00
File: nvidia-uvm-gfxG03-kmp-default-340.93_k4.1.12_1-36.7.x86_64.rpm
	3653 KB 	02/11/2015 	18:38:00
File: nvidia-uvm-gfxG03-kmp-pv-340.93_k4.1.12_1-36.7.x86_64.rpm
	3646 KB 	02/11/2015 	18:38:00
File: nvidia-uvm-gfxG04-kmp-default-352.55_k4.1.12_1-17.5.x86_64.rpm
	3680 KB 	02/11/2015 	18:38:00
File: nvidia-uvm-gfxG04-kmp-pv-352.55_k4.1.12_1-17.5.x86_64.rpm
	3680 KB 	02/11/2015 	18:39:00
File: x11-video-nvidiaG02-304.128-34.1.x86_64.rpm
	33984 KB 	02/11/2015 	18:40:00
File: x11-video-nvidiaG03-340.93-36.1.x86_64.rpm
	29848 KB 	02/11/2015 	18:42:00
File: x11-video-nvidiaG04-352.55-17.1.x86_64.rpm
	39251 KB 	02/11/2015 	18:44:00

quindi non mi pare ci sia il driver per la mia scheda video
NVIDIA Corporation G72M [GeForce Go 7400]

Nel mio blog, ho scritto delle cose che forse ti interessano.
http://www.suseitalia.org/blog/9923

Ritratto di Sargon6
Sargon6
(Guru)
Offline
Guru
Iscritto: 13/11/2008
Messaggi: 723

Sargon6 ha scritto:

boffo ha scritto:

https://it.opensuse.org/SDB:NVIDIA_la_via_difficile


Premo la combinazione di tasti [Ctrl]+[Alt]+[F2] per avviare la riga di comando.
Eseguo il Log-In
Impartisco i comandi per diventare SuperUtente ed installare i pacchetti gcc make kernel-devel
su
zypper install gcc
zypper install make
zypper install kernel-devel

accedo alla pagina WEB
http://www.nvidia.it/Download/index.aspx?lang=it
e da lì cerco i driver per la mia scheda video GeForce Go 7400
[GeForce] [GeForce Go 7 series (NoteBook)] [GeForce Go 7400] [Linux 64-bit]

Scarico il file NVIDIA-Linux-x86_64-304.131.run
e lo copio nella home dell'utente di OpenSUSE 42.1

(proseguo domani, adesso sono stanco, e non vorrei fare cavolate...)

Il comando
sh /home/opensuse42k1/NVIDIA-Linux-x86_64-304.131.run
viene lanciato, ma non può essere completato se prima non disinstallo nouveau, ma non riesco a disinstallare nouveau

Nel mio blog, ho scritto delle cose che forse ti interessano.
http://www.suseitalia.org/blog/9923

Ritratto di max.riservo
max.riservo
(Geek)
Offline
Geek
Iscritto: 04/02/2012
Messaggi: 166

Hai provato ad usare yast da riga di comando come suggerito da Grinch ?

ctr+alt+f1
al prompt : root
+ pwd di root
al prompt : yast

si dovrebbe aprire yast dentro la konsole ...

Altrimenti cerca con google : zypper user manual

A volte sono presente anche in altri forum di programmazione ....

Ritratto di boffo
boffo
(Guru)
Offline
Guru
Iscritto: 17/10/2005
Messaggi: 687

devi premere ctrl+alt+fx
con x da 1 a 6 a scelta, perche puoi scegliere 6 terminali + il settimo che e' il grafico.
Poi ti loggi come root
digita
init 3
sh /home/opensuse42k1/NVIDIA-Linux-x86_64-304.131.run

Almeno io cosi facevo quando avevo un nvidia.

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 877

Entri nella console > ti logghi Root > con su - > digiti yast2 > lo avvii > entri in Repository > segui le istruzioni riportate sotto > F3 dovrebbe essere aggiungi , e comunque vedi come muoverti all' interno sotto , devi usare i tasti tab e invio > spunti il repository > esci sempre usando i tasti > vai nel gestore software e installi il driver per la tua scheda , è più difficile da spiegare che fare .
In pratica è Yast uguale a quello grafico , ma testuale , devi solo capire come fare a muoverti all' interno , ti consiglio di usare il computer con il cavo heternet inserito Party

Ritratto di max.riservo
max.riservo
(Geek)
Offline
Geek
Iscritto: 04/02/2012
Messaggi: 166

Citazione:

Entri nella console > ti logghi Root > con su - > digiti yast2 > lo avvii .....

Interessante : da me (openSuse 13.2) , dentro la console, con yast si avvia la versione testuale e con yast2 si avvia la versione grafica ....

A volte sono presente anche in altri forum di programmazione ....