Tormentone Installazione driver ATI

20 risposte [Ultimo messaggio]
Ritratto di docora
docora
(Junior)
Offline
Junior
Iscritto: 01/03/2007
Messaggi: 12

OK ragazzi voglio provarci anch'io anche se sono schifosamente newbie.
Ho capito che devo seguire la guida http://www.suseitalia.org/modules/wfsection/article.php?articleid=106
e qui ho subito il primo problema:
La mia suse 10.2.lavora con una ati radeon 9250 (agp).
quale versione del driver devo scaricare? La 8.28.8 così come indicato da ATI o la 8.34.8 che è l'ultima versione (21 feb.) del driver?
Poi dico subito che uso smart pakage manager per l'aggiornamento/addizione/rimozione dei pacchetti. Serve forse ripristinare ZEN?
Grazie a chi mi vorrà rispondere.
docora

Ritratto di ferdybassi
ferdybassi
(Guru)
Offline
Guru
Iscritto: 11/09/2005
Messaggi: 2668

Scarica l'ultima versione

Amministratore di
www.it-opensuse.org

Ritratto di ap1978
ap1978
(Guru)
Offline
Guru
Iscritto: 01/10/2004
Messaggi: 2972

Se la scheda è supportata, installa i KMP.

http://www.suseitalia.org/modules/news/article.php?storyid=522

Ciao

ap Big Grin

Ritratto di skapestrato86
skapestrato86
(Monster)
Offline
Monster
Iscritto: 07/02/2007
Messaggi: 279

Quote:

ap1978 ha scritto:
Se la scheda è supportata, installa i KMP.

http://www.suseitalia.org/modules/news/article.php?storyid=522

Ciao

http://www2.ati.com/suse/10.2

File not found.

questa è la risposta Sad
e senza il "2" cambia poco

Ritratto di doc_pluto
doc_pluto
(Guru)
Offline
Guru
Iscritto: 08/02/2007
Messaggi: 871

Quote:

skapestrato86 ha scritto:
Quote:
ap1978 ha scritto:
Se la scheda è supportata, installa i KMP.

http://www.suseitalia.org/modules/news/article.php?storyid=522

Ciao

http://www2.ati.com/suse/10.2

File not found.

questa è la risposta Sad
e senza il "2" cambia poco

non devi cliccarci sopra, ma copia l'indirizzo e aggiungerlo nei repository, attraverso la solita procedura:

Yast - > Software -> Cambia Sorgente di Installazione -> Specifica URL -> incolli -> ok -> attendi -> accetti -> fine

dopo attraverso:

Yast - > Software -> Gestione Pacchetti

e seguendo la guida
http://www.suse.de/~sndirsch/ati-installer-HOWTO.html
vedi se risolvi..

aloha.. Laughing

Hardware: MB:P5E3_Deluxe - CPU:Core2Duo E8400 3.0GHz - RAM:Kingstone_2Gb_DDR3 - Video:GeForce9600GT/PCI/SSE2 - HD: 2x WDCaviarBlue 1TB
--------------------------------
Software: SO:openSuSE 12.1 - ARCH:64bit - DE:Gnome3 - DriverVideo:Ufficiali Nvidia

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Se non sbaglio, la tua scheda non e` piu` supportata dai driver ati ufficiali, quindi probabilmente dovrai usare il modulo radeon.

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di Darky360
Darky360
(Junior)
Offline
Junior
Iscritto: 28/02/2007
Messaggi: 17

Ricordati che per funzionare i driver ati hanno bisogn del kernel-source, lo devi installare dal cd.
Cmq segui la guida che è chiarissima e ti installa tutto! :idea:

:roll: Laughing Linux? Ah si, l'ho visto in tv, è quello della coperta... Laughing :roll:

Ritratto di ap1978
ap1978
(Guru)
Offline
Guru
Iscritto: 01/10/2004
Messaggi: 2972

Quote:

Darky360 ha scritto:
Ricordati che per funzionare i driver ati hanno bisogn del kernel-source, lo devi installare dal cd.
Cmq segui la guida che è chiarissima e ti installa tutto! :idea:

No, se usa i kmp.

Il sito dice file not found ma è un repository attivo.

Ciao

ap Big Grin

Ritratto di docora
docora
(Junior)
Offline
Junior
Iscritto: 01/03/2007
Messaggi: 12

Bene, ho seguito un po' quello che mi avete suggerito.Ho aggiunto il repository. Con Yast gestione pacchetti ho scaricato i pacchetti:
x11-video-fglrxG01 e (poichè uname -r mi da 2.6.18.2-34-default) anche ati-fglrxG01-kmp-default e non gli altri due con suffisso debug e
bigsmp.
Dando sax2 -r ottengo:
SaX: initializing please wait...
SaX: your current configuration will not be read in

SaX: access to your display has been granted
SPP: prepare device [0] profile: Depth24
SPP: prepare device [0] profile: Radeon
SPP: calling device [0] profile script: Radeon
SPP: including prepared profile(s)...

SaX: startup
SaX: X-Server: :0.0 -> grant
SaX: using cache data...

e mi apre la finestra grafica di configurazione di X11.
Suppungo dunque di aver installato kmp come suggerito da ap1978 (monster) ma non so se la mia scheda è supportata (chip radeon 9250 128 MB su slot agp). D'altra parte Orion (monster pure lui) mi ricorda che la mia scheda non è supportata dagli ultimi drivers ufficiali e quindi dovrò usare il modulo radeon....(???).
Ehm... come dire... ho poche idee ma ben confuse.
Ora che faccio?
Grazie sempre e comunque a tutti.

Ritratto di Rosella
Rosella
(Junior)
Offline
Junior
Iscritto: 23/02/2007
Messaggi: 20

Anche io ho una scheda ati 9550 con 256 MB di ram, ti posso dire che ho seguito passo passo la guida e sono riuscito ad installare anche beryl e quindi ho un desk 3d funzionante. Ho utilizzato Yast2.
Perchè forse non cominci tutto d'accapo con Yast2?
Certe volte è la cosa migliore... e segui la guida.
Ciao e scusa se mi sono intromessa.

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Rosella, la tua 9550 e` una tra le ultime ad essere supportate ufficialmente (fonte: http://www2.ati.com/drivers/linux/linux_8.34.8.html).

docora, dopo aver avviato sax2 e configurato X (vedendo che tutto funziona), fai partire X tramite startx e, se funziona, guarda in /etc/X11/xorg.conf che driver stai effettivamente usando (all'interno della Section Device). Molto probabilmente ci sara` scritto radeon e non fglrx.

Ora, se c'e` scritto radeon, fai una copia di backup di tale file e poi puoi provare a vedere se riesci lo stesso a usare i driver ufficiali (anche se dubito). Come da guida, dai il comando aticonfig --initial --input=/etc/X11/xorg.conf e poi il comando sax2 -r -m 0=fglrx
Se funziona, sei a posto, altrimenti ripristini il backup di xorg.conf

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde