Tormentone Installazione driver ATI

20 risposte [Ultimo messaggio]
Ritratto di docora
docora
(Junior)
Offline
Junior
Iscritto: 01/03/2007
Messaggi: 12

In questo momento funziona tutto e la situazione in /etc/X11/xorg.conf è:
Section "Device"
BoardName "RV280 5960" (è proprio la 9250)
BusID "1:0:0"
Driver "radeon"
Identifier "Device[0]"
VendorName "ATI"
EndSection

Come aveva felicemente pronosticato Orion non sto ancora usando "fglrx"
Ora , prima di continuare, cercherò informarmazioni su come si fa il backup di un file e soprattutto come si fa a ripristinarlo se le cose dovvessero precipitare....
Grazie anche a Rossella per il suo contributo.

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Il backup si fa semplicemente con il comando cp, come pure il ripristino. Qualcosa del tipo:     backup: cp /etc/X11/xorg.conf /etc/X11/xorg.conf-radeon<br />ripristino: cp /etc/X11/xorg.conf-radeon /etc/X11/xorg.conf

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di Mastertapan
Mastertapan
(Newbie)
Offline
Newbie
Iscritto: 21/09/2007
Messaggi: 2

ciao.

Scusa mi potresti spiegare bene come si fa un backup? sono piuttosto ignorante su quest'argomento.

Che cos'è il comando cp?

Vale per tutti i file?

Illuminami

Laughing

Ritratto di ferdybassi
ferdybassi
(Guru)
Offline
Guru
Iscritto: 11/09/2005
Messaggi: 2668

Quote:

Mastertapan ha scritto:
ciao.

Scusa mi potresti spiegare bene come si fa un backup? sono piuttosto ignorante su quest'argomento.

Che cos'è il comando cp?

Vale per tutti i file?

Illuminami

Laughing

I files di configurazione di Linux sono files di testo, non dll, inf, reg o cose strane. Come tali li puoi semplicemente copiare in una cartella di "backup" e ricopiare al loro posto originale se qualcosa ti si sputtana...

Il comando cp è il comando di copia nella shell di linux. Lo puoi usare per copiare qualsiasi files (se ne hai i permessi) e qualsiasi directory...

Se vuoi invece un sistema di backup automatico o una cosa tipo ghost ti consiglio di cercare nel forum. Tempo fa avevo affrrontato la cosa in un thread che si era rivelato interessante e istruttivo.

Ciao ciao

Amministratore di
www.it-opensuse.org

Ritratto di Mastertapan
Mastertapan
(Newbie)
Offline
Newbie
Iscritto: 21/09/2007
Messaggi: 2

ok.

Capisco, e per caso sai come si fa uno in windows?

Ritratto di ferdybassi
ferdybassi
(Guru)
Offline
Guru
Iscritto: 11/09/2005
Messaggi: 2668

Quote:

Mastertapan ha scritto:
ok.
Capisco, e per caso sai come si fa uno in windows?

Dipende da che tipo di backup vuoi fare...

- un'immagine del sistema tipo ghost?
- backup dei dati?
- backup della configurazione?

Per ogni tipo di backup ci sono dei tool diversi e appositi...

Ciao ciao

Amministratore di
www.it-opensuse.org

Ritratto di doc_pluto
doc_pluto
(Guru)
Offline
Guru
Iscritto: 08/02/2007
Messaggi: 871

non voglio aprire un topic nuovo su questo argomento trrattato e ritrattato, quindi posto qua..

io ho aggiornato oggi il kernel alla versione 2.6.18 e, di conseguenza, ho reinstallato i driver video ATI.. mi son detto, prendiamo gli ultimi: ho scaricato la versione 8.40, tutto bene fino a quando do il comando

sax2 -r -m 0=fglrx

a questo punto il monitor mi va fuori frequenza per un po', poi torna a funzionare normalmente, do l'ok alla configurazione nel server X di prova, poi di nuovo fuori frequenza, ma stavolta non torna normale.. suppongo che il comando sia terminato, così digito

reboot

e quando provo a modificare le impostazioni sax mi dice che il 3D non è abilitabile perchè non supportato dalla scheda, ma il 3D funziona.. provato a far girare Chromium e WoW..

l'unica noia è che la risoluzione è fissata a 1024*768 non modificabile.. piccolina..

qualcuno sa aiutarmi?

Hardware: MB:P5E3_Deluxe - CPU:Core2Duo E8400 3.0GHz - RAM:Kingstone_2Gb_DDR3 - Video:GeForce9600GT/PCI/SSE2 - HD: 2x WDCaviarBlue 1TB
--------------------------------
Software: SO:openSuSE 12.1 - ARCH:64bit - DE:Gnome3 - DriverVideo:Ufficiali Nvidia

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Quando si aggiorna kernel o driver fglrx, non serve fare l'intera procedura d'installazione.
Per l'aggiornamento del kernel, e` sufficiente lanciare il comando fglrx-kernel-build.sh (come root, ovviamente) dopo aver riavviato con il nuovo kernel.
Per l'aggiornamento del driver, basta installare l'rpm generato dall'installer e poi riavviare il pc (o in alternativa, entrare come root in una shell testuale, passare in init 3, scaricare il modulo con il comando rmmod fglrx, installare l'rpm, ricaricare il modulo con modprobe fglrx e poi riavviare X passando in init 5).

doc_pluto, cerca in /etc/X11 la vecchia configurazione di X che avevi con la precedente versione dei driver (dovrebbe esserci, in qualche file di backup) e sostituiscila a quella attuale. Poi riavvia X e vedi se e` tornato a posto.

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di doc_pluto
doc_pluto
(Guru)
Offline
Guru
Iscritto: 08/02/2007
Messaggi: 871

Quote:

orion ha scritto:
Quando si aggiorna kernel o driver fglrx, non serve fare l'intera procedura d'installazione.
Per l'aggiornamento del kernel, e` sufficiente lanciare il comando fglrx-kernel-build.sh (come root, ovviamente) dopo aver riavviato con il nuovo kernel.
Per l'aggiornamento del driver, basta installare l'rpm generato dall'installer e poi riavviare il pc (o in alternativa, entrare come root in una shell testuale, passare in init 3, scaricare il modulo con il comando rmmod fglrx, installare l'rpm, ricaricare il modulo con modprobe fglrx e poi riavviare X passando in init 5).

doc_pluto, cerca in /etc/X11 la vecchia configurazione di X che avevi con la precedente versione dei driver (dovrebbe esserci, in qualche file di backup) e sostituiscila a quella attuale. Poi riavvia X e vedi se e` tornato a posto.

utile parentesi Wink

proverò e vi farò sapere..

edit: ehm.. quale sarebbe il file??

Hardware: MB:P5E3_Deluxe - CPU:Core2Duo E8400 3.0GHz - RAM:Kingstone_2Gb_DDR3 - Video:GeForce9600GT/PCI/SSE2 - HD: 2x WDCaviarBlue 1TB
--------------------------------
Software: SO:openSuSE 12.1 - ARCH:64bit - DE:Gnome3 - DriverVideo:Ufficiali Nvidia

Ritratto di testa88
testa88
(Guru)
Offline
Guru
Iscritto: 27/10/2006
Messaggi: 776

In ogni caso...se i nuovi driver 8.40 non danno segni di vita con sax2 -r -m 0=fglrx fai così:
dopo aver installato i driver dai da shell con i privilegi di amministratore: init 3 (e passerai nella modalità testuale)
scrivi root e digita la password di root
ora scrivi "ldconfig" dai invio e scrivi "aticonfig --initial --input=/etc/X11/xorg.conf".
Rispetta le maiuscole ad esempio la X di X11 e tutto andrà bene....poi non dare il comando sax2 -r -m 0=fglrx....riavvia semplicemente scrivendo reboot.

Ciao