configurazione chiavetta internet Onda MT689DC

28 risposte [Ultimo messaggio]
Ritratto di Alberto62
Alberto62
(Junior)
Offline
Junior
Iscritto: 18/03/2013
Messaggi: 40

ho installato kernel devel e anche kernel source
poi reinstallato software chiavetta come al solito sudo ./install.sh
la chiavetta non funziga
allego file ho evidenziato gli errori

AllegatoDimensione
errore-chiavetta-internet-linux3.doc 13 KB
Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1741

Manca Gcc (librerie di compilazione), cavoli!!! Lo dovevo sapere, ma spesso si danno per scontate molte cose.

Qui se è 32bit il tuo PC
http://download.opensuse.org/repositories/openSUSE:/12.3/standard/i586/gcc-4.7-7.1.1.i586.rpm
http://download.opensuse.org/repositories/openSUSE:/12.3/standard/i586/gcc47-4.7.2_20130108-2.1.6.i586.rpm

Qui se disponi di un 64bit
http://download.opensuse.org/repositories/openSUSE:/12.3/standard/x86_64/gcc-4.7-7.1.1.x86_64.rpm
http://download.opensuse.org/repositories/openSUSE:/12.3/standard/x86_64/gcc47-4.7.2_20130108-2.1.6.x86_64.rpm

Dovrebbe essere l'ultima cosa. Prometto che dopo che avremo risolto faccio un Blog che servirà ad altri. Comunque stai diventando bravo, già becchi gli errori di esecuzione!

Tornando ad noi, dopo prova la compilazione del driver-Onda e dimmi come è andata

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di Alberto62
Alberto62
(Junior)
Offline
Junior
Iscritto: 18/03/2013
Messaggi: 40

gcc installati
allego file , chiavetta non funzionante , incomincio a pensare che non se ne venga a capo

AllegatoDimensione
errore-chiavetta-internet-linux4.doc 16 KB
Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1741

Adesso funziona tutto dalla nostra parte MA non dalla sua:
--
error: ‘usb_serial_probe’ undeclared here (not in a function)
--

Quanto sembra il problema è ora di quel cavolo di driver!!!

Dimmi da dove è stato preso quel driver che provo ad vedere sul suo sito se cera da scaricare anche dell'altro (che non sia completo?), difatti mi sembra strano che mancava il file README.

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di Alberto62
Alberto62
(Junior)
Offline
Junior
Iscritto: 18/03/2013
Messaggi: 40

la riga d'errore è generata durante l'installazione del software allegato alla chiavetta Tim "famigerata"
il file in questione è sicuramente parte dello stesso
sul sito Onda è presente il software dedicato a Linux x questa chiavetta

http://www.ondacommunication.com/dati/app/clg/it/MT68xDC-TIM-L-B05-tar.gz

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1741

C'è un manuale!
http://www.ondacommunication.com/dati/app/clg/it/MT689DC-qug-IT-v1-0-print.pdf

---
Segui il manuale e specialmente:

Installa usb_modeswitch e wvdial, QT3, libqt3-mt (ecco cosa mancava)

Ricordato di installare anche kppp?

POI

Devi scompattare tutto anche "chiavetta_internet_MT689dc.tar.gz"

Esegui "install.sh" come utente root (prima devi dare il comando "su")

Big Grin (forse ci siamo?)

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao

Ritratto di Alberto62
Alberto62
(Junior)
Offline
Junior
Iscritto: 18/03/2013
Messaggi: 40

usb_modeswitch è già installato
wvdial è già installato
kppp è già installato
mentre libqt3-mt non è installato è presente però libqt4 e libqt4-qt3support (forse sostituiscono libqt3-mt ? )
qt3 non è installato ( vale lo stesso discorso per libqt3-mt )

1)se devo installare libqt3-mt e qt3 comunque , non saprei dove prelevarli
2)scompattare "chiavetta_internet_MT689dc.tar.gz" è quello che ho già fatto e
che da come risultato quei listati di errori che ho postato
mi sa che "purtroppo" non ci siamo Big Hug

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1741

Lui nella guida dice che gli serve quello per funzionare.

Caricati questi:
http://software.opensuse.org/search?q=qt3&baseproject=openSUSE%3A12.3&search_devel=false&search_unsupported=false
http://software.opensuse.org/package/opt-libQt3D5?search_term=libqt3

Se non funziona proviamo vedere se almeno adesso la riconosce con il comando

lsusb

(postami il risultato)

SO: Linux desktop Sistema: OpenSUSE Leap 15.1 (64bit) KDEE 5.12
SO: Linux desktop Sistema: OpenSUSE Tumbleweed (64bit) KDE 5
Miao