Huawei E169

14 risposte [Ultimo messaggio]
Ritratto di davidebond
davidebond
(Junior)
Offline
Junior
Iscritto: 09/03/2006
Messaggi: 22

Salve. Io ho installato openSuse 11 su un Ibm thinkpad z60m. Vorrei connettermi ad internet con una chiavetta usb Huawei E169 della Tim. Dando il comando lsusb, vedo che Suse riconosce la chiavetta e la riconosce come modem. Che procedura devo seguire per connettermi? Ho provato ad aprire kppp, ma mi si dice che non ho i permessi sufficienti per eseguire pppd. D'altra parte, controllando vedo che questi diritti ce li ho. Ed ovviamente, interrogando il modem mi si dice che non posso scrivere sul file di lock.

Aggiungo anche che tutte le procedure trovate per connettersi via chiavetta ad internet hanno sempre fallito nelle altre distro. Le stringhe di inizializzazione vengono dette non corrette: in particolare AT+ZOPRT=5.

Grazie,

davide

Ritratto di alt_canc
alt_canc
(Monster)
Offline
Monster
Iscritto: 14/10/2005
Messaggi: 201

usa network manager... mi fa connettere senza problemi, devi soltanto, ovviamente, configurare la connessione con i parametri relativi al pin e l'APN. prova direttamente cosi... poi nel caso vediamo che altro aggiungere!

Ritratto di auris
auris
(Guru)
Offline
Guru
Iscritto: 10/09/2004
Messaggi: 4923

Segui questa guida di GizMo:
http://www.openlinux.eu/content/view/124/39/

Se sei stanco di virus e schermate blu passa a Linux

Ritratto di davidebond
davidebond
(Junior)
Offline
Junior
Iscritto: 09/03/2006
Messaggi: 22

Ho provato a seguire la guida nel link. Non funziona. Il log mi dice che il modem non risponde alla stringa AT+CFUN=1. Ho provato a cambiarla ma non riesco. Anche se dubito che questo possa servire. Questa guida l'avevo seguita per Sabayon, ma senza successo.

Ciao e grazie,

davide

Ritratto di cioma2
cioma2
(Monster)
Offline
Monster
Iscritto: 05/01/2007
Messaggi: 262

ciao

girovagando ho notato che più di una distro l'hanno fatta funzionare grazie al progr Usbmodeswitch

prova a dare un occhio a questa guida, è per eeepc ma magari con qualche ritocco..........
http://www.eeepc.it/huawei-e169-hsdpa-wind-sulleee-pc/

Ritratto di auris
auris
(Guru)
Offline
Guru
Iscritto: 10/09/2004
Messaggi: 4923

Da cosa hai capito che lo riconosce come modem?
Altra guida: http://mater.kurgan.org/kb/HardWare/HuaweiE169

Se sei stanco di virus e schermate blu passa a Linux

Ritratto di davidebond
davidebond
(Junior)
Offline
Junior
Iscritto: 09/03/2006
Messaggi: 22

Ho seguito tutte e due le vie ma senza successo. Arrivo ad installare usb_modeswitch che mi dà lo stesso resoconto fornito nelle guide. Dopo mi blocco. In un caso, mi si chiede di lanciare /etc/init.d/udev ma non esiste tale comando. Nell'altra guida si fa riferimento alla directory chatscript che non sono riuscito a trovare.

Come fare?

Ciao,

davide

Ritratto di auris
auris
(Guru)
Offline
Guru
Iscritto: 10/09/2004
Messaggi: 4923

Dopo che hai cambiato gli identificativi USB tramite usb_modeswitch, devi passarli al modulo usbserial. In questo modo sei sicuro che il dispositivo sarà visto come modem.
Per farti un'idea di quello che ti dico leggi questa mia guida sul forum:
http://www.suseitalia.org/modules/wfsection/article.php?articleid=172

Se sei stanco di virus e schermate blu passa a Linux

Ritratto di davidebond
davidebond
(Junior)
Offline
Junior
Iscritto: 09/03/2006
Messaggi: 22

Mi dice:

+CME ERROR: SIM PIN required
--> Bad init string.

Ciao,

davide

Ritratto di auris
auris
(Guru)
Offline
Guru
Iscritto: 10/09/2004
Messaggi: 4923

Nella stringa di inizializzazione devi inserire il PIN della tua SIM:
AT+CPIN=xxxx
dove xxxx è il tuo PIN.
Seconda stringa per TIM: AT+CGDCONT=1,"ip","ibox.tim.it","",0,0

Se sei stanco di virus e schermate blu passa a Linux

Ritratto di davidebond
davidebond
(Junior)
Offline
Junior
Iscritto: 09/03/2006
Messaggi: 22

Non funziona ancora:

--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: AT+CPIN = 0000
AT+CPIN = 0000
OK
--> Sending: AT+CFUN=1
AT+CFUN=1
OK
--> Sending: AT+CGDCONT=1,"ip","ibox.tim.it","",0,0
AT+CGDCONT=1,"ip","ibox.tim.it","",0,0
OK
--> Modem initialized.
--> Idle Seconds = 300, disabling automatic reconnect.
--> Sending: ATDT*99***1#
--> Waiting for carrier.
ATDT*99***1#
NO CARRIER
--> No Carrier! Trying again.
--> Sending: ATDT*99***1#
--> Waiting for carrier.
ATDT*99***1#
NO CARRIER
--> No Carrier! Trying again.
--> Sending: ATDT*99***1#
--> Waiting for carrier.

ecc.

Ciao,

davide