Schermata nera all'avvio

11 risposte [Ultimo messaggio]
Ritratto di marco87
marco87
(Junior)
Offline
Junior
Iscritto: 05/05/2010
Messaggi: 11

Ciao,
Ho installato Opensuse 11.0 su un Asus x50sr, ma non riesco a farlo partire normalmente, ma solo in modalità sicura. Credovo che avesse a che fare con la risoluzione dello schermo. Ho un scheda video Ati Radeon 3400. Ho tentato da Yast, con Sax2 a settare tutte le possibili risoluzioni, ma niente mi da sempre una schermata nera. Cosa posso fare?
grazie

Ritratto di superlex
superlex
(Geek)
Offline
Geek
Iscritto: 06/03/2010
Messaggi: 109

Ciao!
Ma perché la 11.0 quando adesso c'è la 11.2?

Ritratto di marco87
marco87
(Junior)
Offline
Junior
Iscritto: 05/05/2010
Messaggi: 11

è una lunga storia, non è stata una scelta mia.

Ritratto di Mirko
Mirko
(Guru)
Offline
Guru
Iscritto: 19/12/2005
Messaggi: 1602

Prova così:

sax2 -r 0=vesa
Ritratto di marco87
marco87
(Junior)
Offline
Junior
Iscritto: 05/05/2010
Messaggi: 11

Ho tentato, ma niente da fare!!!

Ritratto di Mirko
Mirko
(Guru)
Offline
Guru
Iscritto: 19/12/2005
Messaggi: 1602

Puoi postare il contenuto di

/var/log/Xorg.0.log

?

Ritratto di marco87
marco87
(Junior)
Offline
Junior
Iscritto: 05/05/2010
Messaggi: 11

This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.

X.Org X Server 1.4.0.90
Release Date: 5 September 2007
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux linux-bzoi 2.6.25.5-1.1-pae #1 SMP 2008-06-07 01:55:22 +0200 i686
Build Date: 07 June 2008 12:37:27AM

Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri May 7 09:43:35 2010
(==) Using config file: "/etc/X11/xorg.conf.install"
(==) ServerLayout "Layout[all]"
(**) |-->Screen "Screen[fbdev]" (0)
(**) | |-->Monitor "Monitor[0]"
(**) | |-->Device "Device[fbdev]"
(**) |-->Input Device "Keyboard[0]"
(**) |-->Input Device "Mouse[1]"
(**) Option "AllowMouseOpenFail"
(**) Option "BlankTime" "0"
(**) Option "Xinerama" "off"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/uni/" does not exist.
Entry deleted from font path.
(==) Including the default font path /usr/share/fonts/misc:unscaled,/usr/share/fonts/TTF/,/usr/share/fonts/OTF,/usr/share/fonts/Type1/,/usr/share/fonts/100dpi:unscaled,/usr/share/fonts/75dpi:unscaled.
(**) FontPath set to:
/usr/share/fonts/truetype/,
/usr/share/fonts/misc/,
/usr/share/fonts/misc:unscaled,
/usr/share/fonts/TTF/,
/usr/share/fonts/OTF,
/usr/share/fonts/Type1/,
/usr/share/fonts/100dpi:unscaled,
/usr/share/fonts/75dpi:unscaled
(==) RgbPath set to "/usr/share/X11/rgb"
(**) Input device list set to "/dev/ttyS0,/dev/ttyS1,/dev/ttyS2,/dev/ttyS3,/dev/ttyS4,/dev/ttyS5,/dev/ttyS6,/dev/ttyS7,/dev/ttyS8,/dev/psaux,/dev/logibm,/dev/sunmouse,/dev/atibm,/dev/amigamouse,/dev/atarimouse,/dev/inportbm,/dev/gpmdata,/dev/usbmouse,/dev/adbmouse,/dev/input/mice,/dev/input/event0"
(**) ModulePath set to "/usr/lib/xorg/modules"
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(II) No APM support in BIOS or kernel
(II) Loader magic: 0x81e65a0
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.3
X.Org Video Driver: 2.0
X.Org XInput driver : 2.0
X.Org Server Extension : 0.3
X.Org Font Renderer : 0.5
(II) Loader running on linux
(II) LoadModule: "pcidata"
(II) Loading /usr/lib/xorg/modules//libpcidata.so
(II) Module pcidata: vendor="X.Org Foundation"
compiled for 1.4.0.90, module version = 1.0.0
ABI class: X.Org Video Driver, version 2.0
(++) using VT number 7

(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 1039,0671 card 1039,0671 rev 00 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 1039,0004 card 0000,0000 rev 00 class 06,04,00 hdr 01
(II) PCI: 00:02:0: chip 1039,0968 card 0000,0000 rev 01 class 06,01,00 hdr 80
(II) PCI: 00:02:5: chip 1039,5513 card 1043,1b07 rev 01 class 01,01,80 hdr 00
(II) PCI: 00:03:0: chip 1039,7001 card 1043,1b07 rev 0f class 0c,03,10 hdr 80
(II) PCI: 00:03:1: chip 1039,7001 card 1043,1b07 rev 0f class 0c,03,10 hdr 00
(II) PCI: 00:03:3: chip 1039,7002 card 1043,1b07 rev 00 class 0c,03,20 hdr 00
(II) PCI: 00:04:0: chip 1039,0191 card 1043,1815 rev 02 class 02,00,00 hdr 00
(II) PCI: 00:05:0: chip 1039,1183 card 1043,1b07 rev 03 class 01,01,85 hdr 00
(II) PCI: 00:06:0: chip 1039,000a card 0000,0000 rev 00 class 06,04,00 hdr 01
(II) PCI: 00:07:0: chip 1039,000a card 0000,0000 rev 00 class 06,04,00 hdr 01
(II) PCI: 00:0f:0: chip 1039,7502 card 1043,1783 rev 00 class 04,03,00 hdr 00
(II) PCI: 01:00:0: chip 1002,95c4 card 1043,19e2 rev 00 class 03,00,00 hdr 00
(II) PCI: 02:00:0: chip 168c,002a card 1a3b,1067 rev 01 class 02,80,00 hdr 00
(II) PCI: End of PCI scan
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (0,0,3), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x001b (VGA_EN is set)
(II) Bus 1 I/O range:
[0] -1 0 0x0000d000 - 0x0000dfff (0x1000) IX[B]
(II) Bus 1 non-prefetchable memory range:
[0] -1 0 0xfde00000 - 0xfdefffff (0x100000) MX[B]
(II) Bus 1 prefetchable memory range:
[0] -1 0 0xc0000000 - 0xdfffffff (0x20000000) MX[B]
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:2:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(II) PCI-to-PCI bridge:
(II) Bus 2: bridge is at (0:6:0), (0,2,2), BCTRL: 0x0003 (VGA_EN is cleared)
(II) Bus 2 non-prefetchable memory range:
[0] -1 0 0xfdf00000 - 0xfdffffff (0x100000) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 3: bridge is at (0:7:0), (0,3,5), BCTRL: 0x0003 (VGA_EN is cleared)
(II) Bus 3 I/O range:
[0] -1 0 0x0000e000 - 0x0000efff (0x1000) IX[B]
(II) Bus 3 non-prefetchable memory range:
[0] -1 0 0xfe000000 - 0xfebfffff (0xc00000) MX[B]
(II) Bus 3 prefetchable memory range:
[0] -1 0 0xfa000000 - 0xfcffffff (0x3000000) MX[B]
(--) PCI:*(1:0:0) ATI Technologies Inc unknown chipset (0x95c4) rev 0, Mem @ 0xc0000000/29, 0xfdef0000/16, I/O @ 0xd800/8, BIOS @ 0xfdec0000/17
(II) Addressable bus resource ranges are
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
[1] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
[0] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(Cool
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[5] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) Active PCI resource ranges:
[0] -1 0 0xfdff0000 - 0xfdffffff (0x10000) MX[B]
[1] -1 0 0xfddf8000 - 0xfddfbfff (0x4000) MX[B]
[2] -1 0 0xfddfcc00 - 0xfddfcc7f (0x80) MX[B]
[3] -1 0 0xfddfd000 - 0xfddfdfff (0x1000) MX[B]
[4] -1 0 0xfddfe000 - 0xfddfefff (0x1000) MX[B]
[5] -1 0 0xfddff000 - 0xfddfffff (0x1000) MX[B]
[6] -1 0 0xfdec0000 - 0xfdedffff (0x20000) MX[B](Cool
[7] -1 0 0xfdef0000 - 0xfdefffff (0x10000) MX[B](Cool
[8] -1 0 0xc0000000 - 0xdfffffff (0x20000000) MX[B](Cool
[9] -1 0 0x0000b400 - 0x0000b47f (0x80) IX[B]
[10] -1 0 0x0000b800 - 0x0000b80f (0x10) IX[B]
[11] -1 0 0x0000bc00 - 0x0000bc03 (0x4) IX[B]
[12] -1 0 0x0000c000 - 0x0000c007 (0x8) IX[B]
[13] -1 0 0x0000c400 - 0x0000c403 (0x4) IX[B]
[14] -1 0 0x0000c800 - 0x0000c807 (0x8) IX[B]
[15] -1 0 0x0000cc00 - 0x0000cc7f (0x80) IX[B]
[16] -1 0 0x0000ffe0 - 0x0000ffef (0x10) IX[B]
[17] -1 0 0x000001f0 - 0x000001f0 (0x1) IX[B]
[18] -1 0 0x000001f0 - 0x000001f7 (0x8) IX[B]
[19] -1 0 0x000001f0 - 0x000001f0 (0x1) IX[B]
[20] -1 0 0x000001f0 - 0x000001f7 (0x8) IX[B]
[21] -1 0 0x0000d800 - 0x0000d8ff (0x100) IX[B](Cool
(II) Active PCI resource ranges after removing overlaps:
[0] -1 0 0xfdff0000 - 0xfdffffff (0x10000) MX[B]
[1] -1 0 0xfddf8000 - 0xfddfbfff (0x4000) MX[B]
[2] -1 0 0xfddfcc00 - 0xfddfcc7f (0x80) MX[B]
[3] -1 0 0xfddfd000 - 0xfddfdfff (0x1000) MX[B]
[4] -1 0 0xfddfe000 - 0xfddfefff (0x1000) MX[B]
[5] -1 0 0xfddff000 - 0xfddfffff (0x1000) MX[B]
[6] -1 0 0xfdec0000 - 0xfdedffff (0x20000) MX[B](Cool
[7] -1 0 0xfdef0000 - 0xfdefffff (0x10000) MX[B](Cool
[8] -1 0 0xc0000000 - 0xdfffffff (0x20000000) MX[B](Cool
[9] -1 0 0x0000b400 - 0x0000b47f (0x80) IX[B]
[10] -1 0 0x0000b800 - 0x0000b80f (0x10) IX[B]
[11] -1 0 0x0000bc00 - 0x0000bc03 (0x4) IX[B]
[12] -1 0 0x0000c000 - 0x0000c007 (0x8) IX[B]
[13] -1 0 0x0000c400 - 0x0000c403 (0x4) IX[B]
[14] -1 0 0x0000c800 - 0x0000c807 (0x8) IX[B]
[15] -1 0 0x0000cc00 - 0x0000cc7f (0x80) IX[B]
[16] -1 0 0x0000ffe0 - 0x0000ffef (0x10) IX[B]
[17] -1 0 0x000001f0 - 0x000001f0 (0x1) IX[B]
[18] -1 0 0x000001f0 - 0x000001f7 (0x8) IX[B]
[19] -1 0 0x000001f0 - 0x000001f0 (0x1) IX[B]
[20] -1 0 0x000001f0 - 0x000001f7 (0x8) IX[B]
[21] -1 0 0x0000d800 - 0x0000d8ff (0x100) IX[B](Cool
(II) OS-reported resource ranges after removing overlaps with PCI:
[0] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(Cool
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[5] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) All system resource ranges:
[0] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(Cool
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0xfdff0000 - 0xfdffffff (0x10000) MX[B]
[5] -1 0 0xfddf8000 - 0xfddfbfff (0x4000) MX[B]
[6] -1 0 0xfddfcc00 - 0xfddfcc7f (0x80) MX[B]
[7] -1 0 0xfddfd000 - 0xfddfdfff (0x1000) MX[B]
[8] -1 0 0xfddfe000 - 0xfddfefff (0x1000) MX[B]
[9] -1 0 0xfddff000 - 0xfddfffff (0x1000) MX[B]
[10] -1 0 0xfdec0000 - 0xfdedffff (0x20000) MX[B](Cool
[11] -1 0 0xfdef0000 - 0xfdefffff (0x10000) MX[B](Cool
[12] -1 0 0xc0000000 - 0xdfffffff (0x20000000) MX[B](Cool
[13] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[14] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[15] -1 0 0x0000b400 - 0x0000b47f (0x80) IX[B]
[16] -1 0 0x0000b800 - 0x0000b80f (0x10) IX[B]
[17] -1 0 0x0000bc00 - 0x0000bc03 (0x4) IX[B]
[18] -1 0 0x0000c000 - 0x0000c007 (0x8) IX[B]
[19] -1 0 0x0000c400 - 0x0000c403 (0x4) IX[B]
[20] -1 0 0x0000c800 - 0x0000c807 (0x8) IX[B]
[21] -1 0 0x0000cc00 - 0x0000cc7f (0x80) IX[B]
[22] -1 0 0x0000ffe0 - 0x0000ffef (0x10) IX[B]
[23] -1 0 0x000001f0 - 0x000001f0 (0x1) IX[B]
[24] -1 0 0x000001f0 - 0x000001f7 (0x8) IX[B]
[25] -1 0 0x000001f0 - 0x000001f0 (0x1) IX[B]
[26] -1 0 0x000001f0 - 0x000001f7 (0x8) IX[B]
[27] -1 0 0x0000d800 - 0x0000d8ff (0x100) IX[B](Cool
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded by default.
(II) "freetype" will be loaded by default.
(II) "type1" will be loaded by default.
(II) "record" will be loaded by default.
(II) "dri" will be loaded by default.
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules//extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 1.4.0.90, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.3
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules//extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 1.4.0.90, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.3
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules//extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
compiled for 1.4.0.90, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.3
(==) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "freetype"
(II) Loading /usr/lib/xorg/modules//fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
compiled for 1.4.0.90, module version = 2.1.0
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.5
(II) Loading font FreeType
(II) LoadModule: "type1"
(II) Loading /usr/lib/xorg/modules//fonts/libtype1.so
(II) Module type1: vendor="X.Org Foundation"
compiled for 1.4.0.90, module version = 1.0.2
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.5
(II) Loading font Type1
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules//extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
compiled for 1.4.0.90, module version = 1.13.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.3
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules//extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
compiled for 1.4.0.90, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.3
(II) Loading extension XFree86-DRI
(II) LoadModule: "fbdev"
(II) Loading /usr/lib/xorg/modules//drivers/fbdev_drv.so
(II) Module fbdev: vendor="X.Org Foundation"
compiled for 1.4.0.90, module version = 0.4.0
ABI class: X.Org Video Driver, version 2.0
(II) LoadModule: "kbd"
(II) Loading /usr/lib/xorg/modules//input/kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
compiled for 1.4.0.90, module version = 1.3.1
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 2.0
(II) LoadModule: "mouse"
(II) Loading /usr/lib/xorg/modules//input/mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
compiled for 1.4.0.90, module version = 1.3.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 2.0
(II) FBDEV: driver for framebuffer: fbdev
(II) Primary Device is: PCI 01:00:0
(II) Loading sub module "fbdevhw"
(II) LoadModule: "fbdevhw"
(II) Loading /usr/lib/xorg/modules/linux//libfbdevhw.so
(II) Module fbdevhw: vendor="X.Org Foundation"
compiled for 1.4.0.90, module version = 0.0.2
ABI class: X.Org Video Driver, version 2.0
(II) FBDEV(0): using default device
(II) Running in FRAMEBUFFER Mode
(==) FBDEV(0): Depth 16, (==) framebuffer bpp 16
(==) FBDEV(0): RGB weight 565
(==) FBDEV(0): Default visual is TrueColor
(==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
(II) FBDEV(0): hardware: VESA VGA (video memory: 3750kB)
(II) FBDEV(0): checking modes against framebuffer device...
(II) FBDEV(0): mode "default" not found
(II) FBDEV(0): checking modes against monitor...
(--) FBDEV(0): Virtual size is 800x600 (pitch 800)
(**) FBDEV(0): Built-in mode "current": 48.0 MHz, 46.9 kHz, 75.1 Hz
(II) FBDEV(0): Modeline "current"x0.0 48.00 800 832 928 1024 600 604 608 624 -hsync -vsync -csync (46.9 kHz)
(==) FBDEV(0): DPI set to (75, 75)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
compiled for 1.4.0.90, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.3
(**) FBDEV(0): using shadow framebuffer
(II) Loading sub module "shadow"
(II) LoadModule: "shadow"
(II) Loading /usr/lib/xorg/modules//libshadow.so
(II) Module shadow: vendor="X.Org Foundation"
compiled for 1.4.0.90, module version = 1.1.0
ABI class: X.Org ANSI C Emulation, version 0.3
(II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
(==) FBDEV(0): Backing store disabled
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension XAccessControlExtension
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) AIGLX: Screen 0 is not DRI capable
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading /usr/lib/xorg/modules//extensions/libGLcore.so
(II) Module GLcore: vendor="X.Org Foundation"
compiled for 1.4.0.90, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.3
(II) GLX: Initialized MESA-PROXY GL provider for screen 0
(**) Option "CoreKeyboard"
(**) Keyboard[0]: always reports core events
(**) Option "Protocol" "Standard"
(**) Keyboard[0]: Protocol: Standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xfree86"
(**) Keyboard[0]: XkbRules: "xfree86"
(**) Option "XkbModel" "pc104"
(**) Keyboard[0]: XkbModel: "pc104"
(**) Option "XkbLayout" "us"
(**) Keyboard[0]: XkbLayout: "us"
(**) Option "XkbKeycodes" "xfree86"
(**) Keyboard[0]: XkbKeycodes: "xfree86"
(**) Option "CustomKeycodes" "off"
(**) Keyboard[0]: CustomKeycodes disabled
(**) Option "Protocol" "explorerps/2"
(**) Mouse[1]: Device: "/dev/input/mice"
(**) Mouse[1]: Protocol: "explorerps/2"
(**) Option "CorePointer"
(**) Mouse[1]: always reports core events
(**) Option "Device" "/dev/input/mice"
(==) Mouse[1]: Emulate3Buttons, Emulate3Timeout: 50
(**) Mouse[1]: ZAxisMapping: buttons 4 and 5
(**) Mouse[1]: Buttons: 9
(**) Mouse[1]: Sensitivity: 1
(II) evaluating device (Mouse[1])
(II) XINPUT: Adding extended input device "Mouse[1]" (type: MOUSE)
(II) evaluating device (Keyboard[0])
(II) XINPUT: Adding extended input device "Keyboard[0]" (type: KEYBOARD)
(II) Mouse[1]: ps2EnableDataReporting: succeeded
Could not init font path element /usr/share/fonts/TTF/, removing from list!
Could not init font path element /usr/share/fonts/OTF, removing from list!
(II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(II) 3rd Button detected: disabling emulate3Button
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)
(WW) Open ACPI failed (/var/run/acpid.socket) (Connection refused)

Ritratto di Mirko
Mirko
(Guru)
Offline
Guru
Iscritto: 19/12/2005
Messaggi: 1602

1) hai installato qualche driver video? Se sì, prova innanzitutto a rimuoverlo.
2) posta anche il contenuto del file

/etc/X11/xorg.conf

3) come root, posta l'output del comando:

lspci | grep -i vga

4) Verifica che il pacchetto:

acpid

sia installato
5) Ma in modalità sicura il desktop parte?
6) All'avvio, quando ti viene mostrato il menù di grub, prova a inserire nella riga relativa a opensuse, alla fine:

acpi=off

oppure:

noacpi

Fammi sapere.

Ritratto di marco87
marco87
(Junior)
Offline
Junior
Iscritto: 05/05/2010
Messaggi: 11

ciao, Mirko
1) Non ho installato nessun driver video
2)Questo è il file /etc/X11/xorg.conf

# /.../
# SaX generated X11 config file
# Created on: 2010-05-07T11:30:34+0200.
#
# Version: 8.1
# Contact: Marcus Schaefer , 2005
# Contact: SaX-User list
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
Option "ZapWarning" "on"
EndSection

Section "Module"
Load "freetype"
Load "type1"
Load "dbe"
Load "glx"
Load "extmod"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "it"
Option "XkbModel" "pc102"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Driver "synaptics"
Identifier "Mouse[1]"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "on"
Option "HorizScrollDelta" "0"
Option "InputFashion" "Mouse"
Option "Name" "Synaptics;Touchpad"
Option "Protocol" "explorerps/2"
Option "SHMConfig" "on"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[3]"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "ImPS/2 Generic Wheel Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
DisplaySize 331 207
HorizSync 29-62
Identifier "Monitor[0]"
ModelName "N154I3-L03 LCD MONITOR"
Option "PreferredMode" "1280x800"
VendorName "CMO"
VertRefresh 50-60
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
EndSection

Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Device"
BoardName "ATI Mobility Radeon HD 3400 Series (M82)"
BusID "1:0:0"
Driver "radeonhd"
Identifier "Device[0]"
Option "monitor-PANEL" "Monitor[0]"
Screen 0
VendorName "ATI"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
InputDevice "Mouse[3]" "SendCoreEvents"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection

3) questo è l'output del comando:

lspci | grep -i vga

"01:00.0 VGA compatible controller: ATI Technologies Inc Mobilitiy Radeon HD 3400 Series"

4)ho contrallato su Yast2 ed il pacchetto acpid risulta installato
5)si in modalità sicura posso fare tutto quello che voglio, a parte il fatto che ho una risoluzione pessima, e devo settare ogni volta che entro la tastiera.
6)avevo già  messo acpi=off, ma non ha sortito nessuno effetto
Se ti può essere utile questo è la stringa del bootloader :
resume=/dev/sda5 splash=silent showopts ide=nodma apm=off acpi=off
mentre per il failsafe:
showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off x11failsafe

Grazie per l'aiuto.

Ritratto di Mirko
Mirko
(Guru)
Offline
Guru
Iscritto: 19/12/2005
Messaggi: 1602

Prova così:

sax2 -m 0=vesa

Se non funziona nemmeno così, in xorg.conf modifica da:

Driver "radeonhd"

a

Driver "vesa"

E così dovrebbe funzionare. Voglio dire: se la modalità sicura funziona, ci deve essere un modo per far funzionare il sistema normalmente. E quel modo dovrebbe essere usare i driver vesa Smile

Comunque, hai aggiornato il sistema?

Provato a installare i driver ati proprietari?
Installa il pacchetto x11-video-fglrxG02, poi da terminale come root:

aticonfig --initial -f

Insomma, le possibilità sono 4:
- driver vesa (sono dei driver generici, che ti permettono un uso minimo e con poche possibilità di configurazione, ma dovrebbero funzionare sempre o quali);
- driver radeon (driver open ati);
- driver radeonhd (driver open ati, quello che stai usando ora);
- driver fglrx (driver proprietari ati)

Quindi prova un po' i vesa, i radeon, poi al massimo provi fglrx

Ritratto di marco87
marco87
(Junior)
Offline
Junior
Iscritto: 05/05/2010
Messaggi: 11

Ciao Mirko,
è andata la prima, è partito ed ho settato una risoluzione migliore(anche se non quella sperata, ma mi accontento) 1024*768.
Non so come ringraziarti.
P.s. Mi ritroverai ancora nei forum perchè i problemi non sono ancora finiti. Smile