Aggiornamento Kernel

6 risposte [Ultimo messaggio]
Ritratto di theinvoker
theinvoker
(Geek)
Offline
Geek
Iscritto: 04/12/2005
Messaggi: 151

Dopo un aggiornamento di alcuni pacchetti kernel,tra coui sicuramente il kernel.source...al riavvio successivo il boot non presentava + le voci "opensuse 10.2" e il "failsafe" ma aveva solamente la voce "kernel + codice"........come si fa a ripristinare il tutto?
e soprattutto come si fa ad evitare che mi succeda ancora?

Ritratto di pernix
pernix
(Guru)
Offline
Guru
Iscritto: 07/07/2006
Messaggi: 995

Mah, se selezioni quel kernel file tutto liscio? Il nome che viene presentato può essere cambiato a piacere dal tool di configurazione di grub all'interno di YaST.
Giusto a titolo di esempio ti posto il mio /boot/grub/menu.lst nel caso possa essere utile.
# Modified by YaST2. Last modification on dom dic 10 11:20:52 UTC 2006<br />default 0<br />timeout 8<br />gfxmenu (hd0,2)/boot/message<br />##YaST - activate<br /><br />###Don&#039;t change this comment - YaST2 identifier: Original name: linux###<br />title openSUSE 10.2<br />    root (hd0,2)<br />    kernel /boot/vmlinuz-2.6.18.2-34-default root=/dev/hda3 vga=0x317    resume=/dev/hda2 splash=silent showopts<br />    initrd /boot/initrd-2.6.18.2-34-default<br /><br />###Don&#039;t change this comment - YaST2 identifier: Original name: windows###<br />title Windows<br />    rootnoverify (hd0,0)<br />    chainloader (hd0,0)+1<br /><br />###Don&#039;t change this comment - YaST2 identifier: Original name: floppy###<br />title Dischetto<br />    rootnoverify (hd0,0)<br />    chainloader (fd0)+1<br /><br />###Don&#039;t change this comment - YaST2 identifier: Original name: failsafe###<br />title Failsafe -- openSUSE 10.2<br />    root (hd0,2)<br />    kernel /boot/vmlinuz-2.6.18.2-34-default root=/dev/hda3 vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3<br />    initrd /boot/initrd-2.6.18.2-34-default

In a world without walls and fences, who needs Windows ad Gates?

openSUSE 10.3 - KDE+Compiz
Dell Latitude D820N: Intel T7200 2GHz; 2GB RAM 667MHz; Nvidia Quadro NVS 120M 512MB

Ritratto di theinvoker
theinvoker
(Geek)
Offline
Geek
Iscritto: 04/12/2005
Messaggi: 151

scusa non l'ho scritto......l'avvio procede ma una volta dentro non si muove il puntatore del mouse.

Ritratto di pernix
pernix
(Guru)
Offline
Guru
Iscritto: 07/07/2006
Messaggi: 995

Io proverei ad avviare il tool di riparazione dal dvd di suse per vedere se trova delle cose da correggere.

In a world without walls and fences, who needs Windows ad Gates?

openSUSE 10.3 - KDE+Compiz
Dell Latitude D820N: Intel T7200 2GHz; 2GB RAM 667MHz; Nvidia Quadro NVS 120M 512MB

Ritratto di theinvoker
theinvoker
(Geek)
Offline
Geek
Iscritto: 04/12/2005
Messaggi: 151

Ok proverò........ma come può essere successa una cosa del genere?

di mio non ho installato niente ( a parte i driver video)....per il resto ho preso solo cose dai repository e nemmeno chissà cosa:
un paio di temi,decorazioni finestre,i codec win32,thunderbird......basta credo

Ritratto di boffo
boffo
(Guru)
Offline
Guru
Iscritto: 17/10/2005
Messaggi: 687

Prova a fare cosi:
accendi il computer.
dopo che si e caricato tutto premi CTRL + Alt + F1 e ti aparira la modalita a tesnto.
digita root come nome utente
ti chiedere la password
digita init 3
digita sax2

fatto cio riavia il pc con init 6 .

Se tutto va bene dovrai reinstallare i driver video, cosa che si deve fare sempre quando si installa un nuovo kernel.

Ritratto di boffo
boffo
(Guru)
Offline
Guru
Iscritto: 17/10/2005
Messaggi: 687

Quote:

theinvoker ha scritto:
Ok proverò........ma come può essere successa una cosa del genere?

di mio non ho installato niente ( a parte i driver video)....per il resto ho preso solo cose dai repository e nemmeno chissà cosa:
un paio di temi,decorazioni finestre,i codec win32,thunderbird......basta credo

Dovrebbe essere un problema di configurazione tra il nuovo kernel e i vecchi file di configurazione per il precedente kernel.