Aggiornare a KDE 3.5.3 su Suse 9.3 Pro

19 risposte [Ultimo messaggio]
Ritratto di antwal
antwal
(Monster)
Offline
Monster
Iscritto: 24/07/2005
Messaggi: 260

Salve,

avevo aggiornato il KDE da 3.4.0 a 3.5.2 usando Yast, ma da come ho potuto vedere sul sito della OpenSuse, questo non è più possibile e non ne capisco il motivo, cmq solo le versioni Suse 10.0 e 10.1 possono aggiornare il KDE 3.5.3 usando Yast, per gli altri devono usare Smart o Yum.

Volevo sapere da quelli che lo hanno fatto, come devo aggiornare il KDE 3.5.2 a 3.5.3 usando i soft Smart o Yum visto che non li ho mai usati, inoltre su Yast non riesco a vedere più la versione 3.5.2 dopo che ho fatto l'update delle sorgenti e vedo solo 3.4.0

potete auitarmi?

Grazie.

Novell Suse 9.1 Professional 32bit / 9.3 Professional 32bit
Novell Suse Enterprise Desktop 10 SP1 64bit
openSuSE 10.2 x86 / 64bit

Ritratto di antwal
antwal
(Monster)
Offline
Monster
Iscritto: 24/07/2005
Messaggi: 260

ho provato ad installare Smart seguendo la guida su questo forum, ma pultroppo ricevo un errore dalla GUI:

antwal@linux:~> su
Password:
linux:/home/antwal # smart --gui
errore: System has no support for gtk python interface

mi sembra strano che il sistema non support gtk python in quanto tutti i pacchetti gtk, gtk2 e python sono installati e aggiornati alle utlime versioni.

sapete come risolvere?

inoltre adesso stò provando ad installare Yum, sperando che almeno questo funzioni...

Novell Suse 9.1 Professional 32bit / 9.3 Professional 32bit
Novell Suse Enterprise Desktop 10 SP1 64bit
openSuSE 10.2 x86 / 64bit

Ritratto di antwal
antwal
(Monster)
Offline
Monster
Iscritto: 24/07/2005
Messaggi: 260

con Yum, Yumex installati attraverso apt
quando lancio Yumex mi dà questo errore:

Traceback (most recent call last):
File "/usr/share/yumex/yumex.py", line 24, in ?
import gtk
File "/usr/lib/python2.4/site-packages/gtk-2.0/gtk/__init__.py", line 37, in ?
from _gtk import *
ImportError: /usr/lib/python2.4/site-packages/gtk-2.0/gtk/_gtk.so: undefined symbol: gtk_scrolled_window_get_hscrollbar

cosa posso fare?

qualcuno penso che lo abbia installato il nuovo kde 3.5.3 su Suse 9.3?

grazie.

Novell Suse 9.1 Professional 32bit / 9.3 Professional 32bit
Novell Suse Enterprise Desktop 10 SP1 64bit
openSuSE 10.2 x86 / 64bit

Ritratto di antwal
antwal
(Monster)
Offline
Monster
Iscritto: 24/07/2005
Messaggi: 260

Salve,

da come ho potuto controllare su alcuni siti in questi giorni ho visto che le GUI di Smart e Yum non funzionano sulle versioni di suse precedenti alla 10.0 in quanto richiedono di un pacchetto denominato python-cairo che è disponibile a partire dalla 10.0; pertanto l'installazione del kde 3.5.3 può essere fatta solo usando i comandi da shell con smart e yum.

ora stò scaricando tutto il kde 3.5.3 per fare l'update usando come sorgente un cartella sul disco, non appena installato vi faccio sapere.

grazie.

Novell Suse 9.1 Professional 32bit / 9.3 Professional 32bit
Novell Suse Enterprise Desktop 10 SP1 64bit
openSuSE 10.2 x86 / 64bit

Ritratto di Murdock
Murdock
(Guru)
Offline
Guru
Iscritto: 06/10/2004
Messaggi: 573

Quote:

antwal ha scritto:
Salve,

da come ho potuto controllare su alcuni siti in questi giorni ho visto che le GUI di Smart e Yum non funzionano sulle versioni di suse precedenti alla 10.0 in quanto richiedono di un pacchetto denominato python-cairo che è disponibile a partire dalla 10.0; pertanto l'installazione del kde 3.5.3 può essere fatta solo usando i comandi da shell con smart e yum.

Falso, io ho installato smart e relativa gui sulla 9.3 e funziona perfettamente.
Solo che per installarlo io ho digitoato "apt-get install smart" e si è preoccupato lui di tutte le dipendenze...

Murdock - There's no place like /home
openSUSE Leap 42.2 64bit - Plasma 5

Ritratto di antwal
antwal
(Monster)
Offline
Monster
Iscritto: 24/07/2005
Messaggi: 260

ho terminato il download de lkde 3.5.3 scaricando tutta la cartella dall'ftp circa 1,4Gb -> ftp://ftp.unina.it/pub/linux/kde/stable/3.5.3/SuSE/SUSE_Linux_9.3/

Quote:

Murdock ha scritto:
Falso, io ho installato smart e relativa gui sulla 9.3 e funziona perfettamente.
Solo che per installarlo io ho digitoato "apt-get install smart" e si è preoccupato lui di tutte le dipendenze...

ho provato come dici tu, cmq prima l'ho eliminato da Yast e reinstallato
con apt-get:

antwal@linux:~> su
Password:
linux:/home/antwal # apt-get install smart
Lettura della lista di pacchetti... Done
Calcolo dell'albero delle dipendenze... Done
Saranno installati i seguenti pacchetti NUOVI:
smart
0 upgraded, 1 newly installed, 0 removed and 0 not upgraded.
Need to get 551kB of archives.
After unpacking 2842kB of additional disk space will be used.
Get:1 ftp://ftp4.gwdg.de SuSE/9.3-i386/suser-guru smart 0.42-1.guru.suse93 [551kB]
Fetched 551kB in 1m30s (6093B/s)
Committing changes...
Preparing... ########################################### [100%]
1:smart ########################################### [100%]
Done.
apt executing: /sbin/SuSEconfig
...
Finished.
apt executing: /sbin/ldconfig
linux:/home/antwal # smart --gui
errore: Interfaccia 'gtk' non disponibile

-------------------------------

Vi faccio notare che il comando che avete postato installa solo smart e non la gui, in quanto dovete fare anche "apt-get install smart-gui", cmq come su Yast, anche lui mi faceva installare smart con la gui soltanto che non funzionava:

linux:/home/antwal # apt-get install smart-gui
Lettura della lista di pacchetti... Done
Calcolo dell'albero delle dipendenze... Done
Saranno installati i seguenti pacchetti NUOVI:
smart-gui
0 upgraded, 1 newly installed, 0 removed and 0 not upgraded.
Need to get 76,0kB of archives.
After unpacking 314kB of additional disk space will be used.
Get:1 ftp://ftp4.gwdg.de SuSE/9.3-i386/suser-guru smart-gui 0.42-1.guru.suse93 [76,0kB]
Fetched 76,0kB in 11s (6613B/s)
Committing changes...
Preparing... ########################################### [100%]
1:smart-gui ########################################### [100%]
Done.
apt executing: /sbin/SuSEconfig
...
Finished.
apt executing: /sbin/ldconfig
linux:/home/antwal # smart --gui
errore: System has no support for gtk python interface

e di conseguenza da come puoi vedere non funziona.

-------------------------------

Puoi gentilmente se hai il suse 9.3 pro e hai installato il kde 3.5.3, eseguire questi comandi e postarmi l'output?:

rpm -qa | sort | grep gtk
rpm -qa | sort | grep python
rpm -qa | sort | grep smart

Novell Suse 9.1 Professional 32bit / 9.3 Professional 32bit
Novell Suse Enterprise Desktop 10 SP1 64bit
openSuSE 10.2 x86 / 64bit

Ritratto di Murdock
Murdock
(Guru)
Offline
Guru
Iscritto: 06/10/2004
Messaggi: 573

Quote:

antwal ha scritto:

Puoi gentilmente se hai il suse 9.3 pro e hai installato il kde 3.5.3, eseguire questi comandi e postarmi l'output?:

rpm -qa | sort | grep gtk
rpm -qa | sort | grep python
rpm -qa | sort | grep smart

Stasera dopo cena ci do un'occhio...

Ciao

Murdock - There's no place like /home
openSUSE Leap 42.2 64bit - Plasma 5

Ritratto di Murdock
Murdock
(Guru)
Offline
Guru
Iscritto: 06/10/2004
Messaggi: 573

Quote:

antwal ha scritto:
rpm -qa | sort | grep gtk

gtk-1.2.10-885.1
gtk2-2.6.4-6.3
gtk2-32bit-9.3-7.1
gtk-32bit-9.3-7.1
gtkmm24-2.4.11-3.1
gtk-qt-engine-0.6cvs20050229-4.1
gtk-qt-engine-32bit-9.3-7.1
gtkspell-2.0.8-4.1
libgtkhtml-2.6.3-4.1
python-gtk-2.5.3-3.1

Quote:

rpm -qa | sort | grep python

kdebindings3-python-3.5.3-2.6
python-2.4-14.1
python-32bit-9.3-7.1
python-gtk-2.5.3-3.1
python-numeric-23.7-3.1
python-qt-3.5.3-2.6
python-xml-2.4-14.1
rpm-python-4.1.1-208

Quote:

rpm -qa | sort | grep smart

smart-0.41-25.guru.suse93
smart-addons-0.41-25.guru.suse93
smart-gui-0.41-25.guru.suse93
smart-ksmarttray-0.41-25.guru.suse93

Murdock - There's no place like /home
openSUSE Leap 42.2 64bit - Plasma 5

Ritratto di antwal
antwal
(Monster)
Offline
Monster
Iscritto: 24/07/2005
Messaggi: 260

Quote:

Murdock ha scritto:

gtk2-32bit-9.3-7.1
gtk-32bit-9.3-7.1
gtk-qt-engine-32bit-9.3-7.1

python-32bit-9.3-7.1
python-qt-3.5.3-2.6

mi mancano questi pacchetti che nn trovo in Yast, per il kdebindings3-python ho la 3.5.2

ma i 23bit non li trovo

Novell Suse 9.1 Professional 32bit / 9.3 Professional 32bit
Novell Suse Enterprise Desktop 10 SP1 64bit
openSuSE 10.2 x86 / 64bit

Ritratto di antwal
antwal
(Monster)
Offline
Monster
Iscritto: 24/07/2005
Messaggi: 260

ho capito xkè non trovo i pacchetti 32bit, essi sono solo per x86_64 e non per x86 come me,

cmq ancora nn l'ho installato il kde 3.5.3, in quanto voglio risolvere questo problema con smart-gui....

Novell Suse 9.1 Professional 32bit / 9.3 Professional 32bit
Novell Suse Enterprise Desktop 10 SP1 64bit
openSuSE 10.2 x86 / 64bit

Ritratto di antwal
antwal
(Monster)
Offline
Monster
Iscritto: 24/07/2005
Messaggi: 260

da foto potrete vedere i problemi di dipendenze che ho con la smart-gui e python-gtk in Yast, anche se lui, smart, yum, synaptic, apt, ecc... mi fanno installare senza problemi la gui di smart; solo in caso che provo ad aggiornare python-gtk ricevo l'errore...

Novell Suse 9.1 Professional 32bit / 9.3 Professional 32bit
Novell Suse Enterprise Desktop 10 SP1 64bit
openSuSE 10.2 x86 / 64bit