Aggiornare a KDE 3.5.3 su Suse 9.3 Pro

19 risposte [Ultimo messaggio]
Ritratto di Il_Cjargnel
Il_Cjargnel
(Guru)
Offline
Guru
Iscritto: 04/08/2005
Messaggi: 1886

anche io ho tentato l'aggiornalmento di KDE con smart... tutto bene tranne che non si sono piu gli RPM di KDE per la suse 9.3 dove dovrebber esserci, quindi no files, no aggiornamento....
speriamo ricompaiano come x magia....... mandi

OpenSuse 11.0+ OpenSuse 11.2

Ritratto di Il_Cjargnel
Il_Cjargnel
(Guru)
Offline
Guru
Iscritto: 04/08/2005
Messaggi: 1886

Non se se vi fa comodo ma ho rovato un lgi rmp x agiornare KDE (3.5.3) a questo in dirizzo (con smart):
ftp://ftp.kde.org/pub/kde/stable/3.5.3/SuSE/SUSE_Linux_9.3/

a chi servisse.... mandi mandi

OpenSuse 11.0+ OpenSuse 11.2

Ritratto di antwal
antwal
(Monster)
Offline
Monster
Iscritto: 24/07/2005
Messaggi: 260

ho fatto dei test,

installando Suse 9.3 Pro su un'altro pc ma con installazione a 64bit di Suse senza dover fare nessun aggiornamento, ho installanto smart con la gui da yast che giustamente ha anche verificato le dipendenze con questi pacchetti:

kdebindings3-python 3.4.0-6
python 2.4-14
python-elements 1.2.6-1.guru
python-32bit 9.3-7 --> solo per installazione 64Bit
python-gtk 2.5.3-3
python-numeric 23.7-3
python-xml 2.4-14
rpm-python 4.1.1-208

poi avviando smart gui funzionava senza problemi.

Poi sono andato sul mio a 32bit e ho fatto il downgrade del pacchetto python-gtk; io avevo il python-gtk 2.8.2-3 e l'ho riportato alla versione 2.5.3-3 che si trova nel dvd originale, ho corretto anche tutte le dipendeze con la vecchia versione in quanto avevo il kde 3.5.2 e non il 3.4.0 che si trova nel dvd, inoltre mi ha fatto anche aggiornare il pacchetto libgda alla versione 1.3.91-32.i586 e ora la gui di smart funziona benissimo, senza problemi.

Di alcuni pacchetti che ho installato senza usare Yast, che utilizzano il python-gtk 2.6.x o superiori, quindi la versione 2.8.2-3 che avevo, non funzionano più...

Questa sera provo a fare l'update del sistema passando a kde 3.5.3 e vedo come va, poi provo a fare l'aggiornamento di python-gtk alla 2.8.2-3 sempre se non lo fa smart con il passaggio al nuovo kde, cmq non capisco per quale motivo mi dà disponibile la versione python-gtk 2.8.2-21 che richiede per il funzionamento il python-cairo, pacchetto che non esiste su Suse 9.3 Pro ma solo dalla Suse 10.x o superiore.

vi terrò informati...

Novell Suse 9.1 Professional 32bit / 9.3 Professional 32bit
Novell Suse Enterprise Desktop 10 SP1 64bit
openSuSE 10.2 x86 / 64bit

Ritratto di antwal
antwal
(Monster)
Offline
Monster
Iscritto: 24/07/2005
Messaggi: 260

non ho potuto fare l'aggiornamento a kde 3.5.3 per problemi con la linea, cmq dopo che ho riacceso il pc, quando lancio l'update di smart ricevo questo errore:

linux:/home/antwal # smart update
Caricando la cache...
Traceback (most recent call last):################### ( 54%)
File "/usr/bin/smart", line 194, in ?
main(sys.argv[1:])
File "/usr/bin/smart", line 167, in main
exitcode = iface.run(opts.command, opts.argv)
File "/usr/lib/python2.4/site-packages/smart/interface.py", line 53, in run
result = _command.main(self._ctrl, opts)
File "/usr/lib/python2.4/site-packages/smart/commands/update.py", line 77, in main
ctrl.reloadChannels()
File "/usr/lib/python2.4/site-packages/smart/control.py", line 375, in reloadChannels
self._cache.load()
File "/usr/lib/python2.4/site-packages/smart/backends/rpm/yast2.py", line 276, in load
self.parseEntry()
File "/usr/lib/python2.4/site-packages/smart/backends/rpm/yast2.py", line 163, in parseEntry
requires = self.getInfoEntity("Req")
File "/usr/lib/python2.4/site-packages/smart/backends/rpm/yast2.py", line 96, in getInfoEntity
data.append((parts[0], parts[1], parts[2]))
IndexError: list index out of rang

se apro la gui, invece ho questo prima dell'errore precedente:

linux:/home/antwal # smart --gui
sh: kde-config: command not found
sh: kde-config: command not found

non capisco dove sia il problema, visto che 2 giorni prima funzionava tutto senza problemi... qualcuno ne sà qualcosa?

grazie.

Novell Suse 9.1 Professional 32bit / 9.3 Professional 32bit
Novell Suse Enterprise Desktop 10 SP1 64bit
openSuSE 10.2 x86 / 64bit

Ritratto di antwal
antwal
(Monster)
Offline
Monster
Iscritto: 24/07/2005
Messaggi: 260

rispondo al post precedente:

ho reinstallato i pacchetti python con le stesse versioni che avevo, poi sono andato (come root) su /var/lib/smart dove ci sono tutti i temporani di smart e ho cancellato tutti i file delle cartelle:

channels
packages
tmp

sulla directory /var/lib/smart ho lasciato solo il file config

poi ho eseguito da console smart update ed è andato tutto bene, poi ho effettuato subito l'aggiornamento al kde 3.5.3 facendo dalla Gui Upgrade All.

Novell Suse 9.1 Professional 32bit / 9.3 Professional 32bit
Novell Suse Enterprise Desktop 10 SP1 64bit
openSuSE 10.2 x86 / 64bit

Ritratto di antwal
antwal
(Monster)
Offline
Monster
Iscritto: 24/07/2005
Messaggi: 260

se può servire agli utenti con Suse 9.3 Pro che hanno aggiornato il KDE 3.4.x a 3.5.3 o 3.5.4 continuo da qui: Problemi dopo aggiornamento KDE 3.5.3 e 3.5.4

Novell Suse 9.1 Professional 32bit / 9.3 Professional 32bit
Novell Suse Enterprise Desktop 10 SP1 64bit
openSuSE 10.2 x86 / 64bit

Ritratto di lelec
lelec
(Monster)
Offline
Monster
Iscritto: 15/09/2004
Messaggi: 299

Quote:

antwal ha scritto:
ho provato ad installare Smart seguendo la guida su questo forum, ma pultroppo ricevo un errore dalla GUI:

antwal@linux:~> su
Password:
linux:/home/antwal # smart --gui
errore: System has no support for gtk python interface

mi sembra strano che il sistema non support gtk python in quanto tutti i pacchetti gtk, gtk2 e python sono installati e aggiornati alle utlime versioni.

sapete come risolvere?

molto strano
ho installato smart sulla 9.3
ed e pure nel menu
comunque io lo scaricato da suse-guru
e non mi ha dato problemi di dipendenze

l'unico pacchetto che non ho installato e l'applet per il pannello

|L|E|L|E|

Ritratto di lelec
lelec
(Monster)
Offline
Monster
Iscritto: 15/09/2004
Messaggi: 299

Quote:

antwal ha scritto:
Salve,

avevo aggiornato il KDE da 3.4.0 a 3.5.2 usando Yast, ma da come ho potuto vedere sul sito della OpenSuse, questo non è più possibile e non ne capisco il motivo, cmq solo le versioni Suse 10.0 e 10.1 possono aggiornare il KDE 3.5.3 usando Yast, per gli altri devono usare Smart o Yum.

Volevo sapere da quelli che lo hanno fatto, come devo aggiornare il KDE 3.5.2 a 3.5.3 usando i soft Smart o Yum visto che non li ho mai usati, inoltre su Yast non riesco a vedere più la versione 3.5.2 dopo che ho fatto l'update delle sorgenti e vedo solo 3.4.0

potete auitarmi?

Grazie.

aggiungi questa fonte in yast
tipo http
nome del server software.opensuse.org
directory sul server download/KDE:/KDE3/SUSE_Linux_9.3/

l'ho aggiunta proprio ora e funzia

|L|E|L|E|

Ritratto di antwal
antwal
(Monster)
Offline
Monster
Iscritto: 24/07/2005
Messaggi: 260

Quote:

lelec ha scritto:

aggiungi questa fonte in yast
tipo http
nome del server software.opensuse.org
directory sul server download/KDE:/KDE3/SUSE_Linux_9.3/

l'ho aggiunta proprio ora e funzia

ho aggiunto la fonte ma mi crea tutti duplicati del rep, se li cancello e ne lascio uno solo non funziona.

allego foto.

Novell Suse 9.1 Professional 32bit / 9.3 Professional 32bit
Novell Suse Enterprise Desktop 10 SP1 64bit
openSuSE 10.2 x86 / 64bit