Aggiungere Repositories in Yast

30 risposte [Ultimo messaggio]
Ritratto di ginoza
ginoza
(Geek)
Offline
Geek
Iscritto: 19/11/2004
Messaggi: 104

Saluto tutti.
Scusate se posto una domanda simile a una già fatta, ma è che vorrei risolvere una volta per sempre questo problema, del quale non riesco a trovare la soluzione. Ho provato a trovare la soluzione nel Forum, senza successo e facendomi molta confusione!
Ho installato Suse 10.1 dai 5 CD. Ora vorrei aggiungere in Yast/Cambia sorgente alcuni Repositories presi dal sito di opensuse: Additional_Yast_Package_Repositories, tipo Packman... Guru, ecc.
Ma ogni volta che tento di fare questo.. (per es. aggiungere Packman: Http - packman.iu-bremen.de - suse/10.1), mi viene detto in una finestrella: Impossibile creare il mezzo di installazione della URL 'http://packman.iu-bremen.de/suse/10.1
Se provo ad aggiungere Guru mi viene l'avviso: Signature Chack Failed: "Non posso usare questo file se non a rischio dell'integrità del mio sistema".
E così per tutti gli altri Repository che ci sono a disposizione.
Qualcuno con pazienza mi può dare un preciso suggerimento in merito? Altrimenti sto considerando l'opportunità di reinstallarmi la Suse 10.0, che non mi creava tanti problemi! Ma sarebbe il colmo andare indietro!....
Grazie infinite.
Gino.

Il mio nuovo indirizzo di posta è:

Saluti.
Gino.

Ritratto di fmeazza
fmeazza
(Geek)
Offline
Geek
Iscritto: 03/02/2005
Messaggi: 119

Ciao a tutti, in effetti è un problema che ho anche io, anche se credo di non avere capito ancora nulla

Ritratto di ap1978
ap1978
(Guru)
Offline
Guru
Iscritto: 01/10/2004
Messaggi: 2972

L'errore sulle firme GPG è un avvertimento, perché da ora Yast controlla le firme della fonte dei pacchetti e chiede come procedere, quindi puoi ignorare l'avvertimento dal momento che la fonte è affidabile.

Aggiungi i repository tramite Zen (icona nella barra) -> Configure -> Add source.

I parametri sono:

Packman:

Tipo: YUM
URL: http://packman.mirrors.skynet.be/pub/packman/suse/10.1/
Nome: Packman (ma va bene qualsiasi)

Nota: Vi invito a non usare il repository primario di Packman perché è sovraccarico. Ci sono molti mirror con tempi di aggiornamento irrisori. Usate quelli.

Guru:

Tipo: ZYPP
URL: ftp://ftp.gwdg.de/pub/linux/misc/suser-guru/rpm/10.1/
Nome: Guru

Suggerisco anche di leggersi per benino le istruzioni di rug e Zen. Sono due tool nuovi per gli utenti SuSE, che all'inizio disorientano, ma sono davvero comodi e potenti, oltre che più rapidi di Yast ad avviarsi Wink

Ciao

ap Big Grin

Ritratto di ginoza
ginoza
(Geek)
Offline
Geek
Iscritto: 19/11/2004
Messaggi: 104

Finalmente!... Grazie, apt1978! ci voleva proprio una tua informazione così precisa: ho installato, come hai suggerito, Packman e Guru tramite Zen. Grazie di cuore... dopo tanti giorni di delusioni e dispiaceri, mi si è aperto un nuovo orrizzonte!
Una cosa, per favore, ci sono altri Repository, oltre packman e Guru, che potrei installare con questo sistema dello Zen?
Grazie.
Gino

Il mio nuovo indirizzo di posta è:

Saluti.
Gino.

Ritratto di Daddenux
Daddenux
(Geek)
Offline
Geek
Iscritto: 15/11/2005
Messaggi: 121

Anche io ho seguito le procedure di configurazione di Zen che ha postato ap1978 e in effetti Zen mi trova ben 8 aggiornamenti.
Il problema viene dopo pero!

Vado ad aggiornare con Zen e dopo un po mi dice che è impossibile risolvere le dipendenze dei pacchetti.

Mi sapete dire perchè????

A. C. F. 1926

POWERED openSuse 10.2!

Ritratto di umountbrain
umountbrain
(Guru)
Offline
Guru
Iscritto: 15/01/2005
Messaggi: 611

I repository non sono ancora comppleti....dategli qualche giorno....

Ritratto di SWZone
SWZone
(Geek)
Offline
Geek
Iscritto: 18/12/2005
Messaggi: 172

Ho appena installato suse 10.1 ora. Apparte che tra zen e quell'altro non ci ho capito nulla, ho seguito il vostro consiglio:
ho aggiunto al programmino in basso vicino all'ora questo source:
ftp://ftp.gwdg.de/pub/linux/misc/suser-guru/rpm/10.1/
ma non mi trova nessun aggiornamento... è normale?
inoltre perchè se scrivo per esempio:
rug in amule non trova il pacchetto? ricordo che apt lo trovava. Devo aggiungere altri repository?
Ciao

Ritratto di Alfio
Alfio
(Guru)
Offline
Guru
Iscritto: 30/08/2005
Messaggi: 2678

Ricordate che molti pacchetti devono ancora essere convertiti per suse 10.1.
Ciao

Ritratto di Daddenux
Daddenux
(Geek)
Offline
Geek
Iscritto: 15/11/2005
Messaggi: 121

Allora, se elimino dalla lista degli aggiornamenti k3b e kaffeine, l'aggiornamento parte.
Arriva fino alla preparazione dell'installazione degli aggiornamenti e poi si blocca tutto perchè dice che non ho i permessi di root per eseguire l'operazione.... :-o

Help.....

A. C. F. 1926

POWERED openSuse 10.2!

Ritratto di tryfirst
tryfirst
(Geek)
Offline
Geek
Iscritto: 18/03/2006
Messaggi: 120

devi aggiungere l'utente con rug:

tratto da man rug
User Management Commands:

user-add (ua) [username] [privilege] ...
Adds a new user with the specified username and privileges. The
following privileges can be granted: 'install', 'lock',
'remove', 'subscribe', 'trusted', 'upgrade', 'view', 'supe-
ruser'. If you do not provide arguments, you are prompted for
them. After the user is added, rug user-update is launched auto-
matically. Use this tool to grant additional privileges or press
Enter to exit.

ciao

Ritratto di Daddenux
Daddenux
(Geek)
Offline
Geek
Iscritto: 15/11/2005
Messaggi: 121

Mi sapresti indicare in pratica come fare?
Non sono molto pratico di Linux....

A. C. F. 1926

POWERED openSuse 10.2!