Dipendenze

6 risposte [Ultimo messaggio]
Ritratto di Maurizio1230
Maurizio1230
(Geek)
Offline
Geek
Iscritto: 20/06/2006
Messaggi: 86

Salve a tutti Wink . Deo installare un programma che si chiama verlihub su suse 10.1 e mi da le seguenti dipendenze:

<ome/Maurizio1230/Desktop/verlihub-0.9.8a-1.i386.rpm';echo RESULT=$?
error: Failed dependencies:
GeoIP is needed by verlihub-0.9.8a-1.i386
MySQL-client is needed by verlihub-0.9.8a-1.i386
libGeoIP.so.1 is needed by verlihub-0.9.8a-1.i386
libmysqlclient.so.12 is needed by verlihub-0.9.8a-1.i386
libpcre0 is needed by verlihub-0.9.8a-1.i386
mysql-libs is needed by verlihub-0.9.8a-1.i386
RESULT=1

Le ho trovate quasi tutte tranne : GeoIP, LibgeoIP.so.1 e libcre0

Aiutatemi perfavore

Ritratto di pernix
pernix
(Guru)
Offline
Guru
Iscritto: 07/07/2006
Messaggi: 995

GeoIP e, di conseguenza libgeoip.so.1, sono qui:
http://software.opensuse.org/download/jarpack/SL10.1/i586/
per libpcre dovresti installare il pacchetto pcre che trovi qui:
http://ftp.gwdg.de/pub/linux/suse/opensuse/distribution/SL-10.1/inst-source/suse/i586/

Ciao 8-)

In a world without walls and fences, who needs Windows ad Gates?

openSUSE 10.3 - KDE+Compiz
Dell Latitude D820N: Intel T7200 2GHz; 2GB RAM 667MHz; Nvidia Quadro NVS 120M 512MB

Ritratto di Maurizio1230
Maurizio1230
(Geek)
Offline
Geek
Iscritto: 20/06/2006
Messaggi: 86

grazie. Ora vedo se va tutto bene

Ritratto di Maurizio1230
Maurizio1230
(Geek)
Offline
Geek
Iscritto: 20/06/2006
Messaggi: 86

Non mi vede Geoip, libpcre0

Potresti dirmi anche dove posso trovare mysql-libs, libmysqlclient.so.12, MySQL-client perchè yast li trova ma non me li installa

Ritratto di pernix
pernix
(Guru)
Offline
Guru
Iscritto: 07/07/2006
Messaggi: 995

Quote:

Maurizio1230 ha scritto:
Non mi vede Geoip, libpcre0

Potresti dirmi anche dove posso trovare mysql-libs, libmysqlclient.so.12, MySQL-client perchè yast li trova ma non me li installa

Scusa, ma non capisco: gli rpm li trovi nei link che ti ho dato, scarichi i pacchetti e li installi con tutte le dipendenze.
libmysqlclient.so.12 è nel pacchetto mysql-shared, (la versione 4.1.13 fornisce libmysqlclient.so.14), mysql-libs non l'ho trovato, ma credo che mysql-shared dovrebbe bastare.

In a world without walls and fences, who needs Windows ad Gates?

openSUSE 10.3 - KDE+Compiz
Dell Latitude D820N: Intel T7200 2GHz; 2GB RAM 667MHz; Nvidia Quadro NVS 120M 512MB

Ritratto di Maurizio1230
Maurizio1230
(Geek)
Offline
Geek
Iscritto: 20/06/2006
Messaggi: 86

Salve. A me serve la libmysqlclient.so.12 e inoltre ho notato che anche se ho installato gli rpm geoip, libpcre0 e mysql client,verlihub non li vede ovvero mi dice che si devono installare. Forse richiederà delle versioni precedenti?

Aiutatemi

Ritratto di biopsia05
biopsia05
(Newbie)
Offline
Newbie
Iscritto: 10/06/2006
Messaggi: 3

Solitamente basta un buon motore di ricerca per trovare i pacchetti desiderati (io ad esempio uso google e trovo di tutto).
Per il tuo secondo problema, visto che mi sono trovato anch'io con lo stesso problema, ti posso consigliare di cercare una versione più aggiornata del pacchetto CHE STAI INSTALLANDO E CHE RICHIEDE LE DIPENDENZE, spesso e volentieri questi "bug" sono stati risolti con versioni aggiornate.
Spero di essere stato preciso e d'aiuto.

PS:facendo un rapido controllo su internet,credo che tu possa trovare la libreria su questo sito:

http://www.wesmo.com/rpm2html/contributed/RPMS/MySQL-shared-compat-4.1.10-0.i386.html

cmq basta che cerchi con un motore di ricerca.

Ma quanto sono niubbo...
Laughing Laughing Laughing Laughing Laughing Laughing