Dualboot Windows 7-openSUSE 42.1 su differenti hard disk.

12 risposte [Ultimo messaggio]
Ritratto di AngeloVendetta
AngeloVendetta
(Junior)
Offline
Junior
Iscritto: 10/02/2016
Messaggi: 26

Buona notte a tutti,
vengo subito al punto del mio problema; sul mio pc fisso ho installato Windows7 su un ssd, e opensuse 42.1 su un normale disco meccanico. sto cercando il modo per attivare il menù di scelta di grub2 all'avvio, per non usare il bios per la scelta del sistema operativo. adesso è opensuse come sistema oprativo primario, e windows7 secondario, e per avviarlo uso il boot meno del bios.

mi poter dare dare una mano! grazie dell'attenzione

PC fisso: gigabyte h97m-d3h, intel i3 4150, sapphire r7 250x, 2x4 gb ddr3 1600 mhz crucial, due ssd crucial uno da 250gb e uno da 500gb, due hard disk western digital da un 1tb e uno da 2tb. Dual boot: Windows7-opensuse 42.1 con gnome shell 3.16

Ritratto di AngeloVendetta
AngeloVendetta
(Junior)
Offline
Junior
Iscritto: 10/02/2016
Messaggi: 26

è sorto un altro problema, ho smanettato nel sezione bootloader di yast, è mi sparita dal menu boot del bios, ssd su cui è caricato windows. sapete come istallare il grub2?

PC fisso: gigabyte h97m-d3h, intel i3 4150, sapphire r7 250x, 2x4 gb ddr3 1600 mhz crucial, due ssd crucial uno da 250gb e uno da 500gb, due hard disk western digital da un 1tb e uno da 2tb. Dual boot: Windows7-opensuse 42.1 con gnome shell 3.16

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2728

Smanettato nella sezione del boot yast,è stato aggiunto qualcosa o è stato tolto qualcosa alla/alle righe del grub2 in yast?

SUSE Tumbleweed- kernel-5.3.5-1 kde-plasma-5.16.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di gi-gi
gi-gi
(Moderatore)
Offline
Moderatore
Iscritto: 09/12/2014
Messaggi: 418

Ciao.

Prova da YaST --> Sistema --> Bootloader --> Opzioni di bootloader (3a scheda) a selezionare "Verifica altro OS".

gigi

Ritratto di AngeloVendetta
AngeloVendetta
(Junior)
Offline
Junior
Iscritto: 10/02/2016
Messaggi: 26

guardate scusate se sono un idiota, tra bios e yast ho fatto solo casini, ho toccato tasti che non dovevo toccare e adesso non so come descrivere cosa ho fatto. adesso l'unico sistema operativo che si avvia è windows7, e il bootloader di opensuse è disabilitato, e non fa caricare il sistema. sto tentanto di ripristinare l'avvio di opensuse dalla rescue mode del dvd d'installazione che ho, ma non ho concluso niente,cerco consigli per favore.

grazie dell'attenzione, notte

PC fisso: gigabyte h97m-d3h, intel i3 4150, sapphire r7 250x, 2x4 gb ddr3 1600 mhz crucial, due ssd crucial uno da 250gb e uno da 500gb, due hard disk western digital da un 1tb e uno da 2tb. Dual boot: Windows7-opensuse 42.1 con gnome shell 3.16

Ritratto di SilverHawk
SilverHawk
(Geek)
Offline
Geek
Iscritto: 31/05/2014
Messaggi: 180

Qual'è l'ultima operazione che hai fatto?
Possibili opzioni che mi vengono in mente:
1) Hai selezionato l'avvio dal disco di Win7 e non di SuSE
2) Hai "riparato" l'avvio con il disco di Win7
3) Hai cambiato la partizione con il flag di boot attivo

Ritratto di AngeloVendetta
AngeloVendetta
(Junior)
Offline
Junior
Iscritto: 10/02/2016
Messaggi: 26

La terza risposta.

PC fisso: gigabyte h97m-d3h, intel i3 4150, sapphire r7 250x, 2x4 gb ddr3 1600 mhz crucial, due ssd crucial uno da 250gb e uno da 500gb, due hard disk western digital da un 1tb e uno da 2tb. Dual boot: Windows7-opensuse 42.1 con gnome shell 3.16

Ritratto di AngeloVendetta
AngeloVendetta
(Junior)
Offline
Junior
Iscritto: 10/02/2016
Messaggi: 26

La terza risposta.

PC fisso: gigabyte h97m-d3h, intel i3 4150, sapphire r7 250x, 2x4 gb ddr3 1600 mhz crucial, due ssd crucial uno da 250gb e uno da 500gb, due hard disk western digital da un 1tb e uno da 2tb. Dual boot: Windows7-opensuse 42.1 con gnome shell 3.16

Ritratto di SilverHawk
SilverHawk
(Geek)
Offline
Geek
Iscritto: 31/05/2014
Messaggi: 180

Rimetti il flag di boot alla partizione di root (o di boot, se separata): se il codice nell'MBR è quello generico, dovrebbe funzionare fin dal primo riavvio.

Ritratto di AngeloVendetta
AngeloVendetta
(Junior)
Offline
Junior
Iscritto: 10/02/2016
Messaggi: 26

Buon giorno, guarda ho risolto reinstallando opnesuse da capo su un ssd da 250gb, e windows7 su un'altro ssd da 500gb. opensuse si avvia come primo sistema operativo, windows7 ci accedo attraverso il menu boot del bios, e selezionando altro ssd.
Arrivato a questo punto, mi potete per favore spiegare come posso creare un menu boot di grub2 all'avvio, da cui posso scegliere il sistema operativo da lanciare, prima che faccio un altro casino.
Grazie dell 'attenzione, buona giornata.

PC fisso: gigabyte h97m-d3h, intel i3 4150, sapphire r7 250x, 2x4 gb ddr3 1600 mhz crucial, due ssd crucial uno da 250gb e uno da 500gb, due hard disk western digital da un 1tb e uno da 2tb. Dual boot: Windows7-opensuse 42.1 con gnome shell 3.16

Ritratto di SilverHawk
SilverHawk
(Geek)
Offline
Geek
Iscritto: 31/05/2014
Messaggi: 180

In realtà dovrebbe essere già presente, tutto sta in quale ordine hai fatto le operazioni, ovvero:
1) Installo Windows
2) Installo Linux
Al momento dell'installazione di Linux, GRUB2 vede Windows e lo considera nel menu di boot.
Se è stato fatto il contrario (Lin e poi Win), GRUB2 non è a conoscenza dell'ospite e gli va indicato.

Da console, come utente root e previo backup del file in questione, puoi lanciare:
grub2-mkconfig -o /boot/grub2/grub.cfg
Riavvia e dovresti trovarti Win tra le voci del menu.