Grub2 dopo installazione win7

1 risposta [Ultimo messaggio]
Ritratto di energie895
energie895
(Newbie)
Offline
Newbie
Iscritto: 10/12/2012
Messaggi: 2

Ciao ragazzi, vi espongo il guaio dove sono andato a cacciarmi.L'HD del mio portatile ha (da anni ormai) installati win7 e opensuse 1x.x (attualmente il 12.2).Fino a quando ho installato prima win7 e poi opensuse ,riuscendo quindi a configurare grub da yast con il sistema avviato, era tutto funzionante.Poi il simpatico win7 ha fatto qualche casino cn gli aggiornamenti ed ho dovuto reinstallarlo.Da quì comincia la mia sventura...dopo aver ripristinato win ovviamente l'mbr è stato riscritto.."ok" ,esclamo io sicuro di me stesso,"guardo qualche guida online e ripristino da riga di comando l'mbr".Per farla breve ho eseguito tutte le guide possibili..ma l'unica cosa che sono riuscito a fare comparire anche riscrivendo il file grub2.cfg è "welcome grub2" seguito dal terminale # grub>...e resta lì come se aspettasse un mio comando..sapete dirmi dove mi sono ficcato? grazie anticipatamente

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Se durante l'installazione di openSUSE 12.2 hai lasciato le impostazioni predefinite per il boot loader (grub2) è probabile che questo fosse stato installato nella partizione primaria (o estesa) in cui è installata la "root" (/) di openSUSE, e non nell'MBR del disco rigido, per cui dovrebbe bastare reimpostare suddetta partizione come avviabile, ovvero come era prima di aver reinstallato/aggiornato win, leggi qui http://it.opensuse.org/SDB:Riparare_l%27MBR_dopo_l%27installazione_di_Windows#Procedura_per_openSUSE_12.2_.28con_GRUB2.29 (presta attenzione anche all'avviso/warning lì indicato e ai collegamenti in esso presenti). Tieni conto (come riportato in fondo alla sezione del link indicatati) che per avviare automaticamente un'installazione di GNU/Linux "persa" puoi anche usare l'opzione specifica di SystemRescueCD, e poi una volta dentro openSUSE reinstallare GRUB2 semplicemente da YaST.