Helpissimissimo!! Ho fatto un danno con il Kernel!!!

7 risposte [Ultimo messaggio]
Ritratto di ArticMan
ArticMan
(Geek)
Offline
Geek
Iscritto: 15/06/2006
Messaggi: 72

http://www.suseitalia.org/modules/newbb/viewtopic.php?topic_id=7402&forum=1
In questo post mi era stato consigliato di settare il processore...
...nel momento in cui sono entrato nel menu grafico delle impostazioni mi sono detto: toh, proprio come quando avevo montato gentoo, posso scegliere tutto io! allora caldo caldo, oltre che cambiare il modello del processore nella ricompilazione del kernel, ho cominciato a togliere le cose che non mi servivano...
...l'avessi mai fatto!
Ora non parte più nulla.
Ho provato con il nuovo kernel e non va, si blocca ad un certo punto.
Poi mi sono detto: vabbeh, ripartiamo con quello vechio, tanto l'avevo lasciato nel boot...
...niente! Si blocca anche questo, ma in modo diverso! Mi dice che non trova moduli, bla bla bla, e rimane bloccato sul login testuale (senza darmi la possibilità di scrivere nulla!)
Ora la mia domanda è: posso in qualche modo ripristinare tutto come era prima senza formattare?
Ho provato a fare una riparazione dalla modalità grafica dell'installazione ma si blocca ad un certo punto!

Help!!!!!!!!!!

Ritratto di ArticMan
ArticMan
(Geek)
Offline
Geek
Iscritto: 15/06/2006
Messaggi: 72

Vi prego aiutatemi! Non so più come fare!

Ritratto di sim77
sim77
(Monster)
Offline
Monster
Iscritto: 06/12/2004
Messaggi: 297

inserisci i cd/dvd di suse e fai il ripristino

Ritratto di ArticMan
ArticMan
(Geek)
Offline
Geek
Iscritto: 15/06/2006
Messaggi: 72

Ho provato a fare il ripristino ma non va lo stesso!!! Si blocca nel ripristino!

Ritratto di ferdybassi
ferdybassi
(Guru)
Offline
Guru
Iscritto: 11/09/2005
Messaggi: 2668

Sì, ma in quale punto del ripristino si blocca?
CHe ripristino hai scelto? Quali impostazioni hai dato?
Su, cerchiamo di essere precisi e di fornire elementi in grado di aiutare chi ti vuole aiutare...

Amministratore di
www.it-opensuse.org

Ritratto di ArticMan
ArticMan
(Geek)
Offline
Geek
Iscritto: 15/06/2006
Messaggi: 72

Io metto installation da grub perché rescue mi da la console che non so proprio cosa farci!
Una volta entrato faccio, invece di aggionrnamento/nuova installazione, altro e seleziono ripara sistema.
Attivo la partizione di swap come consiglia lui.
Poi dopo un po' mi dice:
Rimuovi voci fstab.
Impossibile trovare dispositivo per le seguenti righe fstab.
Selezionate le righe nella tabella e cambiate lo stato per rimuovere le righe da fstab.
Stato: ignora
riga fstab: debugfs /sys/kernel/debug debugfs noauto.
Questa votla invece di ignorare ho rimosso, proviamo.
Mi dice mount di tutte le partizioni in corso: PROBLEMATICO con sda2 e sdb2 che sono le partizioni windows.
Poi mi dice ricerca del catalogo dei pacchetti installati (o qualcosa del genere, non ho fatto in tempo ora mentre scrivo a leggere bene) legge qualcosa, torna alla schermata di boot tipica di suse (quella quando si avvia il computer dopo grub) e dopo un secondo viene sostituita da una schermata blu stile dos di una volta, come quando si faceva il setup per i giochi sulla scheda audio, ricordi?
Mi dice: si è verificato un errore durante l'installazione.
Premo ok e mi da un menu principale sempre stile dos con:
impostazioni, informazioni sul sistema, moduli del kernel...
Non so se può essere utile ma quando riavvio il computer normalmente leggo che gli mancano un bel po' di moduli!
Ho provato a fare illogin con una tastiera ps2 e funziona sia il mio user che il root, solo che non mi fa entrare in kde, da un sacco di errori.
Posso risolvere qualcosa daquel punto? C'è un modo per ripristinare il kernel come era prima?

Ritratto di leo72
leo72
(Guru)
Offline
Guru
Iscritto: 27/12/2004
Messaggi: 689

Anch'io tempo fa mi avventurai con la compilazione del kernel e fu un macello.

Per ripristinare rimisi tramite Yast i pacchetti RPM del kernel di default, quello presente sul disco originale. Dovresti poterlo fare anche tu avviando da console, loggandoti come root e lanciando da riga di comanda yast. Nella selezione dei pacchetti, reinstalla quelli del kernel e poi riavvia.

Per quanto riguarda il fatto che Suse ti si pianta durante le reinstallazione nella lettura dei pacchetti forse hai qualche problema anche con il DVD, perché non dovrebbe darti errore in quella fase dato che legge solo il catalogo del software presente sul disco ottico per confrontarlo con quello installato sul tuo sistema.

Leo.
------------------
Scegli software open-source: il mio sistema Suse Linux esegue OpenOffice, Mozilla Firefox e Thunderbird, The Gimp...

Ritratto di Arkan
Arkan
(Newbie)
Offline
Newbie
Iscritto: 18/07/2006
Messaggi: 3

Il problema dovrebbe stare tutto nel fatto che hai cambiato architettura del processore nel kernel e di conseguenza, non ti parte più neanche il vecchio perchè non è possibile inserire dei moduli compilati per un'architettura differente. Ricompila il kernel con la giusta architettura, se non sei sicuro usa la più generica possibile, poi sostituisci il kernel, riavvia e dovresti essere a posto.
Mi era capitata una cosa simile tempo fa e non montava più due partizioni, non andava la scheda audio e la maggior parte dei programmi non funzionavano.. poi ricompilando con la giusta architettura tutto ok.

Ciao

P.S. se hai bisogno di una mano per ricompilare fai sapere