Ho sbagliato hard disk

28 risposte [Ultimo messaggio]
Ritratto di Therion
Therion
(Junior)
Offline
Junior
Iscritto: 09/07/2006
Messaggi: 15

Salve a tutti,
oggi ho installato Linux Suse 9.3 su un hard disk esterno, però ho puntato il bootloader sul disco interno (ebbene si la ca**ata è stata fatta). Ora grub funziona solo quando accendo l'hdd esterno, e per giunta se provo ad entrare in Suse da grub, mi va in kernel panic, mentre se uso il cd e "avvio un sistema già installato" entro tranquillamente.

Potete aiutarmi a risolvere il problema?

PS. Sono anche entrato nel pannello di amministrazione, cercando di smanettare con il bootloader, ma siccome è la prima volta che uso una distro Linux, ho paura di compromettere l'hard disk interno.

Ritratto di Therion
Therion
(Junior)
Offline
Junior
Iscritto: 09/07/2006
Messaggi: 15

Perchè mi fa entrare solo da cd? c'è nessuno???

Ritratto di ap1978
ap1978
(Guru)
Offline
Guru
Iscritto: 01/10/2004
Messaggi: 2972

Probabilmente non riesce a montare l'hard disk esterno perché non ha il modulo, ma non ho esperienza in merito.

Ciao

ap Big Grin

Ritratto di DoobleD
DoobleD
(Junior)
Offline
Junior
Iscritto: 15/06/2006
Messaggi: 46

da premettere che è normale che non ti funzioni se hai il hd esterno spento che quando inizia il boot loading sul hd interno va a cercare i file presenti in quello esterno...

ti dico che non hai fatto nulla di errato perche anche se carichi il boot su hd esterno e lo stesso

in poche parole linux non tanto si interessa se e esterno o interno perche sopra non ci sono solo dati ma un sistema operativo!!!

cmq se vuoi provare a cambiare il tuo boot loader basta andare

YaST2 --> sistema --> configurazione bootloader

una volta entrato vai su installa boot loader e puoi spostarlo su l'hard disk che vuoi

Ma ti ripeto il problema non cambia perche dovrai sempre accendere il tuo HD esterno

Se hai ancora problemi basta chiedere

BY amministratore LINUX

Big Grin Big Grin Linux x sempre!! Big Grin Big Grin
:-P :-P KEVIN MITNICK FREE :-P :-P
8-) 8-) 8-) HACKERS 8-) 8-) 8-)

Ritratto di Therion
Therion
(Junior)
Offline
Junior
Iscritto: 09/07/2006
Messaggi: 15

Quote:

DoobleD ha scritto:
da premettere che è normale che non ti funzioni se hai il hd esterno spento che quando inizia il boot loading sul hd interno va a cercare i file presenti in quello esterno...

ti dico che non hai fatto nulla di errato perche anche se carichi il boot su hd esterno e lo stesso

in poche parole linux non tanto si interessa se e esterno o interno perche sopra non ci sono solo dati ma un sistema operativo!!!

cmq se vuoi provare a cambiare il tuo boot loader basta andare

YaST2 --> sistema --> configurazione bootloader

una volta entrato vai su installa boot loader e puoi spostarlo su l'hard disk che vuoi

Ma ti ripeto il problema non cambia perche dovrai sempre accendere il tuo HD esterno

Se hai ancora problemi basta chiedere

BY amministratore LINUX

Forse mi sono spiegato male Big Grin

Premesso che l'hd esterno è acceso (ovviamente, altrimenti grub mi darebbe error 21) il mio problema è un altro, grub mi fa scegliere tre opzioni, entra in suse, entra in winzozz, entra in suse failsafe (o almeno penso si chiami così)...
Quando provo ad entrare in suse o nel fail, appare una schermata di caricamento "initialing hardware" e poi si blocca in una sorta di terminale.. con tanto di $
Da li non so come muovermi.

Mentre se bootto da dvd ->installazione -> avvia un sistema già installato, suse parte tranquillamente, l'unica cosa è che non vorrei ogni volta inserire il dvd, e attendere tre ore per entrare, visto che c'è la disponibilità di usare grub.

PS. Oggi ho veramente pensato di ritornare a winzozz, cancellando tutto, per uno che non si intende di Linux, è veramente da suicidio!!!

Ritratto di Giovy1988
Giovy1988
(Geek)
Offline
Geek
Iscritto: 19/03/2006
Messaggi: 111

quando avvi... e appare quella specie di terminale digita startx e premi invio vedrai che non avrai più problemi...

SI VIS PACEM PARA BELLUM

Ritratto di Therion
Therion
(Junior)
Offline
Junior
Iscritto: 09/07/2006
Messaggi: 15

Quote:

Giovy1988 ha scritto:
quando avvi... e appare quella specie di terminale digita startx e premi invio vedrai che non avrai più problemi...

Ho fatto come dici tu, ma dice "startx not found"...

Ritratto di superpaia
superpaia
(Geek)
Offline
Geek
Iscritto: 17/05/2005
Messaggi: 172

ciao,
prova a vedere in /boot/grub/menu.lst dove va a puntare la sezione suse e poi postala qui (il boot loader deve però essere installato sull'hd interno)
ciao

:pint:

Citazione:

«Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee.»

Ritratto di Giovy1988
Giovy1988
(Geek)
Offline
Geek
Iscritto: 19/03/2006
Messaggi: 111

ok ho capito il terminale che tu dici non è quello di suse ma di grub... io non sono molto esperto del bootloader ma devi modificare la configurazione di grub e spostarlo sul disco interno...

SI VIS PACEM PARA BELLUM

Ritratto di superpaia
superpaia
(Geek)
Offline
Geek
Iscritto: 17/05/2005
Messaggi: 172

spostare grub:
grub-install /dev/hda (se questo è il tuo primo hard-disk, se è sata sarà /dev/sda)
e poi verifica in menu.lst

ciao

:pint:

Citazione:

«Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee.»

Ritratto di Therion
Therion
(Junior)
Offline
Junior
Iscritto: 09/07/2006
Messaggi: 15

Quote:

superpaia ha scritto:
spostare grub:
grub-install /dev/hda (se questo è il tuo primo hard-disk, se è sata sarà /dev/sda)
e poi verifica in menu.lst

ciao

Adesso provo questa soluzione..
Posso farla da terminale, o anche da cygwin?