Il sistema non si avvia

20 risposte [Ultimo messaggio]
Ritratto di Poalo73
Poalo73
(Junior)
Offline
Junior
Iscritto: 12/11/2015
Messaggi: 35

Ciao, ieri ho reinstallato la Tumbleweed sullo stesso pc dove c'era già (un portatile con BIOS uefi), ma il sistema stavolta non si avvia; provato anche a scaricare un'immagine più recente. Cioè, si avvia solo col dvd inserito, scegliendo l'opzione "boot linux system". Credo sia un problema di bootloader; ho quindi provato da yast a ricrearlo, ma niente da fare. Le partizioni sono le solite 4: /, /boot/efi, /home e swap. Ho letto un po' e son più confuso di prima…

Qualche idea?

Grazie in anticipo!

Opensuse Leap 42.3/Tumbleweeed
Squadra di traduzione di KDE
AMD Athlon X2-Athlon II-E1

Ritratto di CarloCC
CarloCC
(Geek)
Offline
Geek
Iscritto: 06/04/2017
Messaggi: 89

Salve, /boot-uefi deve essere la prima partizione del disco.
Qualche dettaglio hardware sarebbe utile, inoltre non parte proprio o si blocca o cosa ?

Acer Aspire E1-522 Amd Quad-Core E2-3800--Amd Radeon 8280
Acer Aspire M5500 Intel Core 2 - grafica Nvidia GeForce 315
Distribuzione OpenSuse Leap 42.2 Kde Plasma5 - Tumbleweed

Ritratto di Poalo73
Poalo73
(Junior)
Offline
Junior
Iscritto: 12/11/2015
Messaggi: 35

Grazie per la risposta. Dunque, il pc è questo, con l'e1 1200. Per quanto riguarda la partizione fat (/boot/efi), dovrebbe effettivamente essere la prima; ho fatto fare tutto a yast, tranne per il fatto che la / l'ho fatta ext4.

Il sistema non si avvia proprio, viene fuori "missing os" e le solite scritte del caso. Questo se faccio il boot dall'hard disk, mentre con l'altra opzione, boot da file uefi, c'è una riga vuota e non si può far niente. Però, come dicevo, riesco ad avviare con la chiavetta di installazione; accadendo alla partizione fat "qualcosa dentro c'è", ma credo che il problema stia lì....

Opensuse Leap 42.3/Tumbleweeed
Squadra di traduzione di KDE
AMD Athlon X2-Athlon II-E1

Ritratto di CarloCC
CarloCC
(Geek)
Offline
Geek
Iscritto: 06/04/2017
Messaggi: 89

...il portatile è molto simile al mio da un punto di vista hardware, quindi non dovresti avere problemi, anche se io devo dire che sul notebook in questione ho Tumbleweed. Per creare una chiavetta di opensuse https://it.opensuse.org/SDB:Creare_una_chiavetta_USB_Live_utilizzando_Windows
ricorda che la chiavetta deve avere una tabella partizioni GPT visto che il tuo pc è UEFI. Un saluto

Acer Aspire E1-522 Amd Quad-Core E2-3800--Amd Radeon 8280
Acer Aspire M5500 Intel Core 2 - grafica Nvidia GeForce 315
Distribuzione OpenSuse Leap 42.2 Kde Plasma5 - Tumbleweed

Ritratto di Poalo73
Poalo73
(Junior)
Offline
Junior
Iscritto: 12/11/2015
Messaggi: 35

Anch'io avevo Tumbleweed su quel portatile. La chiavetta l'ho fatta con Imagewriter da un altro pc con Tumbleweed (e ho provato pure da dvd). L'immagine l'avevo verificata con k3b, quindi escluderei problemi di mezzo. L'installazione avviene come al solito senza problemi, l'unica cosa strana è che mi chiede di configurare la rete (non ricordo di averlo fatto l'altra volta..), poi però la imposto e configuro i repository, scaricando da lì senza problemi. Quando riavvio....missing os, ma si avvia con la chiavetta di installazione, da "boot linux system", dopo aver controllato il disco.

Opensuse Leap 42.3/Tumbleweeed
Squadra di traduzione di KDE
AMD Athlon X2-Athlon II-E1

Ritratto di Poalo73
Poalo73
(Junior)
Offline
Junior
Iscritto: 12/11/2015
Messaggi: 35

Aggiornamento: dato che son sempre più convinto che il problema stia nel bootloader, ho provato a reinstallarlo seguendo questa guida. Quindi, accedo in modalità rescue e tutto ok, poi tutto ok fino a quando bisogna montare /proc e /sys: can't find in /etc/fstab. Se vado avanti con la procedura ottengo altri errori.

Accedendo al sistema da chiavetta d'installazione, il contenuto di /etc/fstab è:

UUID=44f18727-4c5e-4041-8e44-27e85db46208 swap                 swap       defaults              0 0
UUID=b4522b28-dde2-4560-b858-ef9f74f63879 /                    ext4       acl,user_xattr        1 1
UUID=8BF5-9291       /boot/efi            vfat       umask=0002,utf8=true  0 0
UUID=2e662816-33dc-4eaf-a544-a62e04dbbd49 /home                xfs        defaults              1 2

Inoltre ho delle difficoltà a configurare la rete.
Qualche idea?

Opensuse Leap 42.3/Tumbleweeed
Squadra di traduzione di KDE
AMD Athlon X2-Athlon II-E1

Ritratto di gi-gi
gi-gi
(Moderatore)
Offline
Moderatore
Iscritto: 09/12/2014
Messaggi: 395

Ciao.

Visto l'UUID della partizione di boot (/boot/efi) si direbbe che questa è su una chiavetta.

Giusto per chiarire le idee dovresti aprire Konsole, connetterti come superuser (su -) e quindi lanciare il comando blkid, e postare il risultato.

su -
 
blkid

gigi

Ritratto di Poalo73
Poalo73
(Junior)
Offline
Junior
Iscritto: 12/11/2015
Messaggi: 35

Ciao, può essere che sia la chiavetta da cui faccio il boot, cioè quella da cui ho installato il sistema; come dicevo è attualmente l'unico modo di avviare il sistema.

Il risultato del comando blkid è:

/dev/sda1: SEC_TYPE="msdos" UUID="8BF5-9291" TYPE="vfat" PARTLABEL="primary" PARTUUID="82dea40d-8771-49db-8a2a-3a7a396bb4e9"
/dev/sda2: UUID="44f18727-4c5e-4041-8e44-27e85db46208" TYPE="swap" PARTLABEL="primary" PARTUUID="3851c06a-61d0-411d-afdc-fd68bbb277ea"
/dev/sda3: UUID="b4522b28-dde2-4560-b858-ef9f74f63879" TYPE="ext4" PARTLABEL="primary" PARTUUID="f6eb977f-02f0-4272-86b9-f414ea913fb3"
/dev/sda4: UUID="2e662816-33dc-4eaf-a544-a62e04dbbd49" TYPE="xfs" PARTLABEL="primary" PARTUUID="244338ef-cc97-492a-a461-ed237cab262c"

Grazie.

Opensuse Leap 42.3/Tumbleweeed
Squadra di traduzione di KDE
AMD Athlon X2-Athlon II-E1

Ritratto di gi-gi
gi-gi
(Moderatore)
Offline
Moderatore
Iscritto: 09/12/2014
Messaggi: 395

Tutte le partizioni contenute in fstab sono su un unico disco (sda).

Probabilmente non è l'origine del problema, però potresti provare a modificare la riga di fstab che riguarda la partizione di boot come riportato sotto:

NB: prima di effettuare la modifica ricordati di fare una copia di backup del file fstab attuale

UUID=44f18727-4c5e-4041-8e44-27e85db46208 swap                 swap       defaults              0 0
UUID=b4522b28-dde2-4560-b858-ef9f74f63879 /                    ext4       acl,user_xattr        1 1
UUID=8BF5-9291       /boot/efi            vfat    defaults        0       1
#UUID=8BF5-9291       /boot/efi            vfat       umask=0002,utf8=true  0 0
UUID=2e662816-33dc-4eaf-a544-a62e04dbbd49 /home                xfs        defaults              1 2

Poi dovresti postare il contenuto del file grub.cfg presente nella cartella /boot/efi/grub2, così da verificare quale partizione tenta di avviare GRUB.

gigi

Ritratto di Poalo73
Poalo73
(Junior)
Offline
Junior
Iscritto: 12/11/2015
Messaggi: 35

Dunque, in realtà io il file grub.cfg ce l'ho in /boot/grub2/, e il suo contenuto è:

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub2-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#
 
### BEGIN /etc/grub.d/00_header ###
if [ -f ${config_directory}/grubenv ]; then
  load_env -f ${config_directory}/grubenv
elif [ -s $prefix/grubenv ]; then
  load_env
fi
 
if [ "${env_block}" ] ; then
  load_env -f "${env_block}"
fi
 
if [ "${next_entry}" ] ; then
   set default="${next_entry}"
   set next_entry=
   save_env next_entry
   if [ "${env_block}" ] ; then
     save_env -f "${env_block}" next_entry
   fi
   set boot_once=true
else
   set default="${saved_entry}"
fi
 
if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi
 
export menuentry_id_option
 
if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi
 
function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
    if [ "${env_block}" ] ; then
      save_env -f "${env_block}" saved_entry
    fi
 
  fi
}
 
function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}
 
if [ x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_gpt
insmod ext2
set root='hd0,gpt3'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt3 --hint-efi=hd0,gpt3 --hint-baremetal=ahci0,gpt3  b4522b28-dde2-4560-b858-ef9f74f63879
else
  search --no-floppy --fs-uuid --set=root b4522b28-dde2-4560-b858-ef9f74f63879
fi
    font="/usr/share/grub2/unicode.pf2"
fi
 
if loadfont $font ; then
echo "Please press t to show the boot menu on this console"
  set gfxmode=auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=POSIX
  insmod gettext
fi
terminal_output gfxterm
insmod part_gpt
insmod ext2
set root='hd0,gpt3'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt3 --hint-efi=hd0,gpt3 --hint-baremetal=ahci0,gpt3  b4522b28-dde2-4560-b858-ef9f74f63879
else
  search --no-floppy --fs-uuid --set=root b4522b28-dde2-4560-b858-ef9f74f63879
fi
insmod gfxmenu
loadfont ($root)/boot/grub2/themes/openSUSE/DejaVuSans-Bold14.pf2
loadfont ($root)/boot/grub2/themes/openSUSE/DejaVuSans10.pf2
loadfont ($root)/boot/grub2/themes/openSUSE/DejaVuSans12.pf2
loadfont ($root)/boot/grub2/themes/openSUSE/ascii.pf2
insmod png
set theme=($root)/boot/grub2/themes/openSUSE/theme.txt
export theme
if [ x${boot_once} = xtrue ]; then
  set timeout=0
elif [ x$feature_timeout_style = xy ] ; then
  set timeout_style=menu
  set timeout=8
# Fallback normal timeout code in case the timeout_style feature is
# unavailable.
else
  set timeout=8
fi
### END /etc/grub.d/00_header ###
 
### BEGIN /etc/grub.d/00_tuned ###
set tuned_params=""
set tuned_initrd=""
### END /etc/grub.d/00_tuned ###
 
### BEGIN /etc/grub.d/10_linux ###
menuentry 'openSUSE Tumbleweed'  --class opensuse --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-b4522b28-dde2-4560-b858-ef9f74f63879' {
	load_video
	set gfxpayload=keep
	insmod gzio
	insmod part_gpt
	insmod ext2
	set root='hd0,gpt3'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt3 --hint-efi=hd0,gpt3 --hint-baremetal=ahci0,gpt3  b4522b28-dde2-4560-b858-ef9f74f63879
	else
	  search --no-floppy --fs-uuid --set=root b4522b28-dde2-4560-b858-ef9f74f63879
	fi
	echo	'Loading Linux 4.13.4-1-default ...'
	linuxefi /boot/vmlinuz-4.13.4-1-default root=UUID=b4522b28-dde2-4560-b858-ef9f74f63879  resume=/dev/disk/by-uuid/b4522b28-dde2-4560-b858-ef9f74f63879 splash=silent quiet showopts
	echo	'Loading initial ramdisk ...'
	initrdefi /boot/initrd-4.13.4-1-default
}
submenu 'Advanced options for openSUSE Tumbleweed' --hotkey=1 $menuentry_id_option 'gnulinux-advanced-b4522b28-dde2-4560-b858-ef9f74f63879' {
	menuentry 'openSUSE Tumbleweed, with Linux 4.13.4-1-default' --hotkey=2 --class opensuse --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.13.4-1-default-advanced-b4522b28-dde2-4560-b858-ef9f74f63879' {
		load_video
		set gfxpayload=keep
		insmod gzio
		insmod part_gpt
		insmod ext2
		set root='hd0,gpt3'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt3 --hint-efi=hd0,gpt3 --hint-baremetal=ahci0,gpt3  b4522b28-dde2-4560-b858-ef9f74f63879
		else
		  search --no-floppy --fs-uuid --set=root b4522b28-dde2-4560-b858-ef9f74f63879
		fi
		echo	'Loading Linux 4.13.4-1-default ...'
		linuxefi /boot/vmlinuz-4.13.4-1-default root=UUID=b4522b28-dde2-4560-b858-ef9f74f63879  resume=/dev/disk/by-uuid/b4522b28-dde2-4560-b858-ef9f74f63879 splash=silent quiet showopts
		echo	'Loading initial ramdisk ...'
		initrdefi /boot/initrd-4.13.4-1-default
	}
	menuentry 'openSUSE Tumbleweed, with Linux 4.13.4-1-default (recovery mode)' --hotkey=3 --class opensuse --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.13.4-1-default-recovery-b4522b28-dde2-4560-b858-ef9f74f63879' {
		load_video
		set gfxpayload=keep
		insmod gzio
		insmod part_gpt
		insmod ext2
		set root='hd0,gpt3'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt3 --hint-efi=hd0,gpt3 --hint-baremetal=ahci0,gpt3  b4522b28-dde2-4560-b858-ef9f74f63879
		else
		  search --no-floppy --fs-uuid --set=root b4522b28-dde2-4560-b858-ef9f74f63879
		fi
		echo	'Loading Linux 4.13.4-1-default ...'
		linuxefi /boot/vmlinuz-4.13.4-1-default root=UUID=b4522b28-dde2-4560-b858-ef9f74f63879  
		echo	'Loading initial ramdisk ...'
		initrdefi /boot/initrd-4.13.4-1-default
	}
}
 
### END /etc/grub.d/10_linux ###
 
### BEGIN /etc/grub.d/20_linux_xen ###
 
### END /etc/grub.d/20_linux_xen ###
 
### BEGIN /etc/grub.d/20_memtest86+ ###
### END /etc/grub.d/20_memtest86+ ###
 
### BEGIN /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_os-prober ###
 
### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###
 
### BEGIN /etc/grub.d/41_custom ###
if [ -f  ${config_directory}/custom.cfg ]; then
  source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###
 
### BEGIN /etc/grub.d/80_suse_btrfs_snapshot ###
### END /etc/grub.d/80_suse_btrfs_snapshot ###
 
### BEGIN /etc/grub.d/90_persistent ###
### END /etc/grub.d/90_persistent ###
 
### BEGIN /etc/grub.d/95_textmode ###
 
    # On EFI systems we can only have graphics *or* serial, so allow the user
    # to switch between the two
    hiddenentry 'Text mode' --hotkey 't' {
	set textmode=true
	terminal_output console
    }
### END /etc/grub.d/95_textmode ###

Fatta modifica a fstab, ma non si avvia autonomamente...

Opensuse Leap 42.3/Tumbleweeed
Squadra di traduzione di KDE
AMD Athlon X2-Athlon II-E1

Ritratto di gi-gi
gi-gi
(Moderatore)
Offline
Moderatore
Iscritto: 09/12/2014
Messaggi: 395

Il problema sta nel file grub.cfg, dove dovrebbero essere presenti due stringhe UUID, una relativa alla partizione di boot (/boot), l'altra alla partizione radice(/).

Intervenendo a mano per risolvere il problema si rischia di rendere il PC non avviabile, per cui ti consiglio di installare nuovamente Tumbleweed facendo attenzione a formattare nuovamente le partizioni di boot e radice. In meno di mezz'ora dovresti risolvere il problema.

NB: NON FORMATTARE la partizione HOME!

gigi