installare programmi da file tar.gz

Ritratto di caunaudio
caunaudio
(Monster)
Offline
Monster
Iscritto: 23/08/2009
Messaggi: 433

ok fatto...

due domande inerenti...

1-adesso posso usare questa procedura per tutti i pacchetti rpm che voglio?

2- come messaggio mi ha detto tutto fatto ma lancio il programma ma non parte...mi lampeggia l'applicazione per un po e poi basta....cosa mi manca? Sad

FIERO DI ESSERCI

Leap 42.3 KDE 5.8.7 Intel I5 2500K-Kernel 4.4.104-39 - default x64-Geforce GT520

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Ho scaricato phasis e ho provato a vedere come e` la situazione veramente.

Allora, il programma non e` da compilare ma solamente da eseguire, dopo aver installato i pacchetti necessari.

Come prima cosa, avvia yast e installa i seguenti pacchetti: python-ReportLab, python-sqlite2, python-wxGTK e python-imaging. Poi apri un terminale (konsole) e spostati dove hai scaricato il file phasis-0.9.8-2.tar.gz. Ad esempio, se lo hai scaricato sul desktop, avvia la konsole e dai i seguenti comandi: cd Desktop<br />tar xfz phasis-0.9.8-2.tar.gz<br />cd phasis-0.9.8-2<br />./phasis.py
Dovrebbe partire phasis. Se non parte, riporta i messaggi d'errore qui sul forum.

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di caunaudio
caunaudio
(Monster)
Offline
Monster
Iscritto: 23/08/2009
Messaggi: 433

una volta risposo mi è venuto fuori il tuo mex.....

avendo gia installato phasis indi se installo da yast tutta quella roba li dovrebbe funzionare secondo te o devo togliere phasis e solo dopo aver installato quella roba rimetterlo?

FIERO DI ESSERCI

Leap 42.3 KDE 5.8.7 Intel I5 2500K-Kernel 4.4.104-39 - default x64-Geforce GT520

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Avendo installato un rpm di fedora, e` normale che non ti abbia tirato dietro le dipendenze. Intanto potresti provare ad installare i pacchetti indicati (ed altre eventuali dipendenze che essi richiedono) e poi provi a lanciare di nuovo il programma.

Se non funziona, lo disinstalli da yast e continui con la versione tar.gz.

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di deckard
deckard (non verificato)
()

Ho installato phasis da rpm. Non trova un qualcosa che ha a che fare con pysqlite2. Ho cercato in yast, ma non ho trovato nulla.
Per me a questo punto conviene la via i Orion. Lo puoi disinstallare da yast oppure da shell con questi due comandi:

su
zypper rm phasis

Vedi tu.
Ciao.

Ps: come ti ho spiegato puoi installare quello che vuoi, certo se il programma si trova in yast molto meglio.
Ps2: non preoccuparti di chiedere, a memoria tutti, tranne Orion e pochi altri, abbiamo avuto bisogno. Laughing

Ritratto di deckard
deckard (non verificato)
()

<br /><br />phasis<br />Traceback (most recent call last):<br />  File &quot;./phasis.py&quot;, line 66, in &lt;module&gt;<br />    import appmain<br />  File &quot;/opt/phasis/phasis/appmain.py&quot;, line 74, in &lt;module&gt;<br />    import mdi<br />  File &quot;/opt/phasis/phasis/mdi.py&quot;, line 40, in &lt;module&gt;<br />    import util<br />  File &quot;/opt/phasis/phasis/util.py&quot;, line 15, in &lt;module&gt;<br />    from pysqlite2 import dbapi2 as sqlite<br />ImportError: No module named pysqlite2<br /><br /><br />

Per dovere di cronaca, questo è l'errore.
Ciao.

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

pysqlite2 e` fornito da python-sqlite2, che e` una dipendenza richiesta ma non installata (causa rpm di fedora e non di openSUSE).

Se phasis parte, sei a posto. Non devi far altro (se non imparare ad usarlo).

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di caunaudio
caunaudio
(Monster)
Offline
Monster
Iscritto: 23/08/2009
Messaggi: 433

Quote:

orion ha scritto:

Se phasis parte, sei a posto. Non devi far altro (se non imparare ad usarlo).

adesso me li prendo gli insulti Laughing ma una volta chiuso come faccio a farlo ripartire...devo fare sempre quella procedura....spero di no Thinking

FIERO DI ESSERCI

Leap 42.3 KDE 5.8.7 Intel I5 2500K-Kernel 4.4.104-39 - default x64-Geforce GT520

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Quote:

caunaudio ha scritto:
Quote:
orion ha scritto:

Se phasis parte, sei a posto. Non devi far altro (se non imparare ad usarlo).

adesso me li prendo gli insulti Laughing ma una volta chiuso come faccio a farlo ripartire...devo fare sempre quella procedura....spero di no Thinking

Scusa, ma come lo hai fatto partire? Con i comandi che ti ho indicato io o in che altro modo?

Se con i comandi che ti ho indicato, allora devi solamente entrare nella directory e lanciare il programma: cd Desktop/phasis-0.9.8-2<br />./phasis.py

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di caunaudio
caunaudio
(Monster)
Offline
Monster
Iscritto: 23/08/2009
Messaggi: 433

Quote:

orion ha scritto:
Quote:
caunaudio ha scritto:
Quote:
orion ha scritto:

Scusa, ma come lo hai fatto partire? Con i comandi che ti ho indicato io o in che altro modo?

Se con i comandi che ti ho indicato, allora devi solamente entrare nella directory e lanciare il programma: cd Desktop/phasis-0.9.8-2<br />./phasis.py

e appunto quello che ho fatto ma nn va...mi parte la shermata iniziale del prog poi sparisce e basta

FIERO DI ESSERCI

Leap 42.3 KDE 5.8.7 Intel I5 2500K-Kernel 4.4.104-39 - default x64-Geforce GT520