installare suse e ubuntu su una macchina contenente windows xp

28 risposte [Ultimo messaggio]
Ritratto di daniloferrarott
Offline
Geek
Iscritto: 29/09/2007
Messaggi: 126

ciao a tutti,

sto cercando di installare ubuntu 8.10 su una macchina che monta gia suse 12.1 e windows xp . Ho guardato sulla guida e ho seguito i vari passi ma ogni volta pur partizionando il disco con due swap, due punti di montaggio / e due punti di montaggio /home, all'avvio nel grub o posso accedere su Suse (con ubuntu non accessibile sebbene visibile tra le partizioni) oppure (dopo aver reinstallato ubuntu) non vede proprio la partizione Suse pur essendoci.

Qualcuno potrebbe aiutarmi

grazie

Ritratto di doc_pluto
doc_pluto
(Guru)
Offline
Guru
Iscritto: 08/02/2007
Messaggi: 871

uno swap è sufficiente. così come anche una partizione per la /home, stando attenti a creare utenti diversi nei due sistemi gnu-linux.
cmq serve la tabella delle partizioni attuale dei dischi, per avere un'idea.

dovrebbe esserci (non per forza in quest'ordine)

  1. /boot: partizione di avvio (ext4 - primaria)
  2. C: partizione di windows xp (ntfs - primaria)
  3. swap
  4. partizione estesa
    • / di opensuse 12.1 (ext4 - logica)
    • / di ubuntu (ext4 - logica)
    • /home (ext4 - logica)
    • eventuale partizione dati da condividere con windows (nfts - logica)

Hardware: MB:P5E3_Deluxe - CPU:Core2Duo E8400 3.0GHz - RAM:Kingstone_2Gb_DDR3 - Video:GeForce9600GT/PCI/SSE2 - HD: 2x WDCaviarBlue 1TB
--------------------------------
Software: SO:openSuSE 12.1 - ARCH:64bit - DE:Gnome3 - DriverVideo:Ufficiali Nvidia

Ritratto di daniloferrarott
Offline
Geek
Iscritto: 29/09/2007
Messaggi: 126

sto reinstallando nuovamente suse e poi faccio con ubuntu usando un solo swap, appena terminato posto i dischi Wink cosi sarà più chiaro

Ritratto di daniloferrarott
Offline
Geek
Iscritto: 29/09/2007
Messaggi: 126

cerco di impostare le partizioni come mi hai suggerito tu,

grazie

Ritratto di doc_pluto
doc_pluto
(Guru)
Offline
Guru
Iscritto: 08/02/2007
Messaggi: 871

daniloferrarott ha scritto:

cerco di impostare le partizioni come mi hai suggerito tu,
grazie

wait.
probabile che se win c'era già la partizione di avvio con uno dei due /boot dei sistemi unix tu non possa metterla.
quindi occhio, prima facci vedere/dicci come è la situazione attuale.

Hardware: MB:P5E3_Deluxe - CPU:Core2Duo E8400 3.0GHz - RAM:Kingstone_2Gb_DDR3 - Video:GeForce9600GT/PCI/SSE2 - HD: 2x WDCaviarBlue 1TB
--------------------------------
Software: SO:openSuSE 12.1 - ARCH:64bit - DE:Gnome3 - DriverVideo:Ufficiali Nvidia

Ritratto di daniloferrarott
Offline
Geek
Iscritto: 29/09/2007
Messaggi: 126

avevo gia windows e suse 11.3 che poi ho tolto passando alla 12.1. Mi serviva installare anche ubuntu 8.10 e solo con quest'ultimo ho avuto problemi nel grub

Ritratto di daniloferrarott
Offline
Geek
Iscritto: 29/09/2007
Messaggi: 126

danilo@danilo-laptop:~$ sudo fdisk -l
ecco da ubuntu con fdisk l'output, purtroppo non vedo suse nel grub:

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xa6d9a6d9

Device Boot Start End Blocks Id System
/dev/sda1 1 4419 35495586 7 HPFS/NTFS
/dev/sda2 * 4420 5073 5244928 83 Linux
/dev/sda3 5073 5333 2096128 82 Linux swap / Solaris
/dev/sda4 5334 19457 113451030 f W95 Ext'd (LBA)
/dev/sda5 5334 7945 20972544 83 Linux
/dev/sda6 7945 16846 71503872 83 Linux
/dev/sda7 16847 19457 20972826 83 Linux
danilo@danilo-laptop:~$

Ritratto di doc_pluto
doc_pluto
(Guru)
Offline
Guru
Iscritto: 08/02/2007
Messaggi: 871

dentro /etc/fstab cosa c'è?

Hardware: MB:P5E3_Deluxe - CPU:Core2Duo E8400 3.0GHz - RAM:Kingstone_2Gb_DDR3 - Video:GeForce9600GT/PCI/SSE2 - HD: 2x WDCaviarBlue 1TB
--------------------------------
Software: SO:openSuSE 12.1 - ARCH:64bit - DE:Gnome3 - DriverVideo:Ufficiali Nvidia

Ritratto di daniloferrarott
Offline
Geek
Iscritto: 29/09/2007
Messaggi: 126

scusami, ho dovuto cambiare pc perchè mi ha dato problemi anche windows. Sto rifacendo le installazioni, appena terminato ti posto si fdisk che fstab

Abbi pazienza

grazie

Ritratto di daniloferrarott
Offline
Geek
Iscritto: 29/09/2007
Messaggi: 126

eccomi

fdisk da ubuntu:

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xa6d9a6d9

Device Boot Start End Blocks Id System
/dev/sda1 1 4419 35495586 7 HPFS/NTFS
/dev/sda2 4420 5073 5244928 83 Linux
/dev/sda3 5073 5333 2096128 82 Linux swap / Solaris
/dev/sda4 * 5334 19457 113451030 f W95 Ext'd (LBA)
/dev/sda5 5334 7945 20972544 83 Linux
/dev/sda6 7945 11208 26216448 83 Linux
/dev/sda7 11209 13820 20972544 83 Linux
/dev/sda8 13820 19457 45278208 83 Linux

etc/fstab sempre da ubuntu:

/etc/fstab: static file system information.
#
#
proc /proc proc defaults 0 0
# /dev/sda5
UUID=146d158e-693b-42ba-9072-5c4e1b74371e / ext3 relatime,errors=remount-ro 0 1
# /dev/sda3
UUID=dc07e190-f145-4a4d-a115-f24b77e2ec94 none swap sw 0 0
~

come posso intervenire per risolvere il problema?
non ho proprio idea

grazie a tutti

Ritratto di doc_pluto
doc_pluto
(Guru)
Offline
Guru
Iscritto: 08/02/2007
Messaggi: 871

vediamo se ho capito bene.

stato iniziale: winXP e OpenSuSE12.1 (opensuse da che supporto l'hai installato?, hai installato i sistemi in quest'ordine?)

vuoi aggiungere ubuntu >> stato finale: winXP, OpenSuSE12.1, Ubuntu.

- ovviamente hai fatto un backup di tutti i dati importanti nei due sistemi. se non l'hai fatto, beh fallo, non si sai mai.

- hai lo spazio libero per le partizioni, vero? se non ce l'hai defragga winXP e avviando con una live di GParted, ridimensiona le partizioni che hai adesso per avere un po' di spazio per la partizione di ubuntu. io ne farei solo una partizione da montare su /, utilizzando in comune la swap e la /home con l'accortezza di creare utenti con nomi diversi ed home diverse fra i due sistemi unix, in modo da essere sicuri di non compromettere configurazioni ed opzioni personali di nessuno dei due.

cmq, se hai il dvd di OpenSuSE, puoi, una volta installato tutti i sistemi operativi, avviare dal dvd e scegliere "Installa GRUb" o simile, lui farà un esame del disco e riconoscerà i sistemi installati configurandoti automaticamente il bootloader, con eventuali chainloader se necessari (come per winXP).

Hardware: MB:P5E3_Deluxe - CPU:Core2Duo E8400 3.0GHz - RAM:Kingstone_2Gb_DDR3 - Video:GeForce9600GT/PCI/SSE2 - HD: 2x WDCaviarBlue 1TB
--------------------------------
Software: SO:openSuSE 12.1 - ARCH:64bit - DE:Gnome3 - DriverVideo:Ufficiali Nvidia