installare suse e ubuntu su una macchina contenente windows xp

28 risposte [Ultimo messaggio]
Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2741

Installa Kgrubeditor,e una gui per grub
[url] Uploaded with ImageShack.us[/url]

SUSE Tumbleweed- kernel-5.8.7.1.2- kde-plasma-5.19.5.1- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.132.14- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di daniloferrarott
Offline
Geek
Iscritto: 29/09/2007
Messaggi: 126

ok, installato. Cosa devo fare ora?

ah l'errore quando avvio il boot ubuntu è error 13 avevo letto male

ciao

Ritratto di doc_pluto
doc_pluto
(Guru)
Offline
Guru
Iscritto: 08/02/2007
Messaggi: 871

riguardo l'errore ho trovato questo:

Citazione:

13 : "Inconsistent filesystem structure"
This error is returned by the filesystem code to denote an internal error caused by the sanity checks of the filesystem structure on disk not matching what it expects. This is usually caused by a corrupt filesystem or bugs in the code handling it in GRUB.


fonte: http://www.uruk.org/orig-grub/errors.html

forse hai impostato male la /

Hardware: MB:P5E3_Deluxe - CPU:Core2Duo E8400 3.0GHz - RAM:Kingstone_2Gb_DDR3 - Video:GeForce9600GT/PCI/SSE2 - HD: 2x WDCaviarBlue 1TB
--------------------------------
Software: SO:openSuSE 12.1 - ARCH:64bit - DE:Gnome3 - DriverVideo:Ufficiali Nvidia

Ritratto di daniloferrarott
Offline
Geek
Iscritto: 29/09/2007
Messaggi: 126

ho impostato la / sia di suse che di ubuntu allo stesso modo, e infatti il boot va regolarmente sia di suse che di ubuntu finchè non modifico il menu.lst e tramite rescue system imposto il grub di suse. solo in quel caso ubuntu non si carica dando error 13

Ritratto di daniloferrarott
Offline
Geek
Iscritto: 29/09/2007
Messaggi: 126

anche con kgrubeditor riesco a vedere il grub di ubuntu ma non riesco a modificare le impostazioni ed errore 13 continua a rimanermi all'avvio.

se pero con il dvd di suse modifico il grub da (hd0,4) quello suse a (hd0,6) quello di ubuntu il sistema operativo ubuntu parte senza problemi. solo quando modifico il menu.lst di suse non riesco a caricarlo.
sinceramente non so più che fare.

suggerimenti?

grazie

Ritratto di spock
spock
(Guru)
Offline
Guru
Iscritto: 03/08/2006
Messaggi: 1198

Prova allora ad inserire nel menu.lst di suse questo nella riga relativa ad ubuntu:

root (hd0,6)
kernel /boot/grub/core.img

al posto di

rootnoverify (hd0,6)
chainloader +1

Ritratto di daniloferrarott
Offline
Geek
Iscritto: 29/09/2007
Messaggi: 126

ho provato ma ho in risposta

error 15: file not found

Ritratto di spock
spock
(Guru)
Offline
Guru
Iscritto: 03/08/2006
Messaggi: 1198

Non avevo notato che hai installato ubuntu 8.10, che dovrebbe avere ancora grub legacy invece che grub2. In questo caso se riesci ad accedere ad ubuntu copia la righe del file menu.lst di ubuntu direttamente nel menu.lst di suse(ovviamente solo quelle relative all'avvio di ubuntu stessa).
Ciao