Installato OpenSuse 11.3, non parte più WIndows 7!!

5 risposte [Ultimo messaggio]
Ritratto di Maiden
Maiden
(Geek)
Offline
Geek
Iscritto: 08/12/2009
Messaggi: 96

ragazzi ho bisogno di un aiuto urgente...

ho appena finito di installare OpenSuse 11.3 sul mio pc con Windows 7, e ora non riesco più ad avviare Windows!!
quando da Grub lo seleziono mi compare una schermata nera con scritto:

rootnoverify (hd0,1)
chainloader +1

BOOTMGR mancante
CTRL+ALT+CANC per riavviare

cosa può essere successo?!cosa posso fare per far funzionare nuovamente Windows?!
grazie mille a tutti....

Ritratto di Romolo
Romolo
(Junior)
Offline
Junior
Iscritto: 07/06/2006
Messaggi: 36

Be....
ti manca il file in questione "BOOTMGR ",
ripristinalo e tutto dovrebbe andare correttamente.
ciao

Ritratto di Maiden
Maiden
(Geek)
Offline
Geek
Iscritto: 08/12/2009
Messaggi: 96

e come faccio a ripristinarlo??

Ritratto di Maiden
Maiden
(Geek)
Offline
Geek
Iscritto: 08/12/2009
Messaggi: 96

se dovesse servire a qualcuno, dopo diverse prove senza successo, ho ripristinato Windows 7 tramite il suo dvd...
ora penserò a come ripristinare Grub e avere entrambi i sistemi operativi funzionanti....

Ritratto di Alfio
Alfio
(Guru)
Offline
Guru
Iscritto: 30/08/2005
Messaggi: 2678

Questo succede per un semplice motivo.
Dovete sempre considerare che grub va installato nel mbr e non sulla partizione di root.
Quando installi windows in generale e dopo una qualsiasi distro assicurati di non usare l'installazione automatica ,anche se capisco che sei alle prime armi di sforzarci a usare il forum ma anche il nostro amico google per riuscire a installarlo manualmente.
La cosa essenziale che grub si trova al suo agio nell'mbr.
Tornando al tuo problema fai partire il disco e dovrebbe darti delle opzioni per fare partire opensuse dal disco poi usa Yast per reinstallare grub sull'mbr.
Ciao

Ritratto di Maiden
Maiden
(Geek)
Offline
Geek
Iscritto: 08/12/2009
Messaggi: 96

non avevo visto la risposta, per cui rispondo solo ora...
grazie per le info, non lo sapevo..fino a prima di questa installazione ho sempre avuto Windows XP, e con tutte le distro linux che ho provato ho sempre lasciato fare tutto in automatico e non ho mai avuto problemi, per questo anche questa volta ho fatto lo stesso....

comunque, come ho già detto, ho risolto prima ripristinando Windows 7 con il suo dvd, e poi seguendo questa guida per ripristinare Grub, dato che dalla 11.3 quel tool di cui parlavi nel dvd non è più presente, e provandoci col dvd della 11.2 mi dava errore...