Installazione Leap 43.2 su mobo MSI con UEFI non parte.

45 risposte [Ultimo messaggio]
Ritratto di carmalao
carmalao
(Geek)
Offline
Geek
Iscritto: 06/01/2009
Messaggi: 95

Buongiorno.
Ho un pc fisso con installata OpenSuse 13.2.
La mobo è una MSi con attivato il UEFI+Legacy come bios.
Ho scaricato la Leap 43.2, controllato il SHA (tutto ok) e masterizzato con K3B un dvd+r in modalità AUTO.
Seleziono (con F11 al boot) il dvd come sorgente, parte la videata, scelgo INSTALLATION (solo in inglese in UEFI ho letto....), carica il Kernel, medita, torna al boot.
Ho provato di TUTTO.
Qualche suggerimento per favore?
Grazie

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2704

Controllato se è corotta l'iso scaricata.
https://it.opensuse.org/openSUSE:UEFI
devi preparare il disco in GPT

SUSE Tumbleweed- kernel-4.18-7-1.5- kde-plasma-5.13.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.77- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di carmalao
carmalao
(Geek)
Offline
Geek
Iscritto: 06/01/2009
Messaggi: 95

Ho controllato il codice SHA e corrispondeva... altro non ho fatto.
Suggerimenti?

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1681

Disattiva "avvio rapido" di Windows (Fast startup o Fast Booot, tanto è un bene anche per win che non si incrocchia) e controlla se non esiste qualche opzione di blocco in più nel BIOS/UEFI

Qui, anche se altra distro, come gestire il BIOS/UEFI
https://wiki.ubuntu-it.org/AmministrazioneSistema/Uefi

In Installazione, alla primissima schermata, puoi scegliere la Lingua ed esiste ITALIANO

SO: Linux desktop Sistema: OpenSUSE Leap 15 (32bit) TDE 4 / Mate
SO: Linux desktop Sistema: OpenSUSE Leap 15 (64bit) KDE 5
Miao

Ritratto di carmalao
carmalao
(Geek)
Offline
Geek
Iscritto: 06/01/2009
Messaggi: 95

mauriziod ha scritto:

Disattiva "avvio rapido" di Windows (Fast startup o Fast Booot, tanto è un bene anche per win che non si incrocchia) e controlla se non esiste qualche opzione di blocco in più nel BIOS/UEFI

Qui, anche se altra distro, come gestire il BIOS/UEFI
https://wiki.ubuntu-it.org/AmministrazioneSistema/Uefi

In Installazione, alla primissima schermata, puoi scegliere la Lingua ed esiste ITALIANO

Grazie per la risposta.
Allora, nel bios era già tutto disattivato le modalità del merdoz. Dopo ricontrollo e darò una occhiata al link.
Per quanto riguarda la prima schermata, se nel bios metto UEFI+LEGACY e faccio partire il dvd come LEGACY, allora parte in modalità "vecchia" e posso scegliere lingua ecc., se facccio solo UEFI o faccio partire il dvd come UEFI, allora la modalità è la UEFI e quindi niente scelte. È scritto anche da qualche parte online su opensuse.org....

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1681

Alla prima schermata di OpenSuse 42.3 premendo i tasti funzione puoi settare la lingua, qui puoi settare anche la modalità grafica dell'installazione che nel caso che sia problematica (magari è per quello che fa la schermata nera) può essere settata la più bassa possibile oppure la modalità gui semplice.

Come vedi è F2 per scegliere la lingua e F3 per la risoluzione video

SO: Linux desktop Sistema: OpenSUSE Leap 15 (32bit) TDE 4 / Mate
SO: Linux desktop Sistema: OpenSUSE Leap 15 (64bit) KDE 5
Miao

Ritratto di carmalao
carmalao
(Geek)
Offline
Geek
Iscritto: 06/01/2009
Messaggi: 95

So so, so tutto, sono 15 anni che uso Suse.
Il problema è che partendo in UEFI le opzioni sotto non ci sono. Ho provato. Se faccio la partenza come DVD "legacy" ci sono, se come UEFI-DVD non ci sono.
È scritto anche qui: https://doc.opensuse.org/documentation/leap/startup/single-html/book.opensuse.startup/index.html#id2484

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1681

Adesso capisco (ATTENZIONE: "secure boot" su Linux non serve)
premendo "E" poi esegui questa guida
https://en.opensuse.org/SDB:Linuxrc

# set screen size to 800 x 600
XVideo=800x600

SO: Linux desktop Sistema: OpenSUSE Leap 15 (32bit) TDE 4 / Mate
SO: Linux desktop Sistema: OpenSUSE Leap 15 (64bit) KDE 5
Miao

Ritratto di carmalao
carmalao
(Geek)
Offline
Geek
Iscritto: 06/01/2009
Messaggi: 95

Fatto, regola la risoluzione video, ma torna sempre al boot...
Forse centra qualcosa la tabella delle partizioni? Non credo sia in GPT, anzi vedo una partizione in BTRFS....

Ritratto di mauriziod
mauriziod
(Guru)
Offline
Guru
Iscritto: 01/06/2009
Messaggi: 1681

Non mi dire che montavi prima la OpenSuse 12!

Allora in quel caso DEVI cancellare (lascia la partizione vuota, non formattata) prima la BTRFS (tanto è solo Sistema e Programmi), in quanto adesso usa la BTRFS-2 e non più la vecchia BTRFS-1 ed è probabile che in quel punto che si inca.

SO: Linux desktop Sistema: OpenSUSE Leap 15 (32bit) TDE 4 / Mate
SO: Linux desktop Sistema: OpenSUSE Leap 15 (64bit) KDE 5
Miao

Ritratto di carmalao
carmalao
(Geek)
Offline
Geek
Iscritto: 06/01/2009
Messaggi: 95

Scusa, sto usando la 13.2.
È il computer dell'ufficio, non posso permettermi di fare "vaccate"....