Installazione neofita

20 risposte [Ultimo messaggio]
Ritratto di matteo87
matteo87
(Junior)
Offline
Junior
Iscritto: 18/05/2010
Messaggi: 14

Ciao, ho installato da poco suse e in passato avevo usato un pò ubuntu, ho seguito un corso base di linux ma le mie conoscenze sono molto elementari. Il problema è che ho mandato l'installazione di suse da windows con un iso attraverso periferica virtuale usando un programma alchool (credendo ingenuamente che avrei potuto evitare di masterizzare il dvd) al riavvio di windows mi partiva un menu autonominatosi di startup in cui mi comparivano due opzioni
1) installa suse
2) fai partire windows

ma selezionando entrambi partiva l'installazione di suse. Ho masterizzato il dvd e ho installato suse ma windows non ne vuole sapere di partire. Al riavvio mi compare lo stesso menu ma selezionando l'avvio di windows cerca di installare di nuovo suse. La partizione è ancora esistente, lo vedo dal boot loader, ma ne modificando alcune opzioni nel boot loader nè dal bios ho ottenuto risultati. Ho perso definitivamente il sistema windows?
Ho un HP TouchSmart tx2, grazie!

Ritratto di Mirko
Mirko
(Guru)
Offline
Guru
Iscritto: 19/12/2005
Messaggi: 1602

Hai avuto una pessima idea. Tra l'altro dubito che ti possa concretamente aiutare, visto che hai usato un metodo/programma che - credo - qui conosceranno pochi. Io, personalmente, non conoscevo nemmeno questa possibilità.
Per il futuro installa sempre da dvd o da chiavetta usb, lascia perdere altri metodi/programmi.

Veniamo a noi. Prima domanda: attualmente riesci ad avviare openSuse?
Che significa "la partizione è ancora esistente, lo vedo dal boot loader"?

Dobbiamo innanzitutto installare Grub e configurarlo, direi.
Rispondimi alla due domande. Poi prova così: avvia il dvd, trovi l'opzione "Ripara". Scegli la modalità automatica e segui tutti i passaggi.

Per quanto riguarda Windows, è difficile stabilire con queste informazioni cosa gli possa essere successo (se gli è successo qualcosa). Ma se durante l'installazione il partizionatore ti ha lasciato la partizione con Win, dovrebbe essere ancora lì e il problema dovrebbe essere solo di avvio.

Ritratto di Mirko
Mirko
(Guru)
Offline
Guru
Iscritto: 19/12/2005
Messaggi: 1602

Se riesci ad avviare openSuse, apri un terminale, loggati come root (su, INVIO, password, INVIO) e dai questi due comandi:

fdisk -l
cat /boot/grub/menu.lst

Copia-incolla l'output qui (nel primo comando quella è una elle minuscola e NON una i maiuscola).

Ritratto di matteo87
matteo87
(Junior)
Offline
Junior
Iscritto: 18/05/2010
Messaggi: 14

Si adesso sto usando suse, la partizione di windows è ancora lì, ho installato suse su una partizione di circa 10 Gb..Ho bisogno urgente e disperato di recuperare perlomeno i dati su windows, per il resto posso anche formattare...

Ritratto di matteo87
matteo87
(Junior)
Offline
Junior
Iscritto: 18/05/2010
Messaggi: 14

cosa intendi con su? scusami tanto ma non ho tanta pratica...Per accedere come root? premendo su mi compare l'ultimo comando digitato su terminale

Ritratto di Mirko
Mirko
(Guru)
Offline
Guru
Iscritto: 19/12/2005
Messaggi: 1602

No no no. Non devi premere la freccia su.
Apri il terminale, digiti "su" (senza virgolette), premi invio, inserisci la password di root (non viene visualizzata, tranquillo), premi ancora invio.
Così hai i privilegi di root (che, volendo fare un paragone un po' grossolano con Windows, corrisponde all'amministratore del sistema).
La password di root l'hai impostata durante l'installazione.

Poi dai quei due comandi e copi-incolli l'output (quello che il terminale ti stampa in risposta dopo aver dato i comandi).

p.s. hai provato a fare "ripara" col dvd come ti avevo detto?

Ritratto di deckard
deckard (non verificato)
()

Ma col filemanager di Suse (se kde, dolphin, se gnome, nautilus) non vedi e non navighi sulla partizione win?

Ritratto di matteo87
matteo87
(Junior)
Offline
Junior
Iscritto: 18/05/2010
Messaggi: 14

linux-6348:/home/matteo # fdisk -l

Disco /dev/sda: 320.1 GB, 320072933376 byte

255 testine, 63 settori/tracce, 38913 cilindri
Unità = cilindri di 16065 * 512 = 8225280 byte
Identificativo disco: 0x186afea2

Dispositivo Boot Start End Blocks Id System
/dev/sda1 1 34469 276872211 7 HPFS/NTFS
/dev/sda2 37538 38913 11048960 7 HPFS/NTFS
/dev/sda3 * 34470 37537 24643710 5 Esteso
/dev/sda5 36237 37476 9960268+ 83 Linux
/dev/sda6 37477 37537 489951 82 Linux swap / Solaris
/dev/sda7 34470 36156 13550764+ 83 Linux
/dev/sda8 36157 36236 642568+ 82 Linux swap / Solaris

Le voci nella tabella delle partizioni non sono nello stesso ordine del disco
linux-6348:/home/matteo # cat /boot/grub/menu.lst
# Modified by YaST2. Last modification on lun mag 17 16:34:50 CEST 2010
# THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
# Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,4)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE
root (hd0,4)
kernel /boot/vmlinuz root=/dev/disk/by-id/ata-ST9320320AS_5SX2M65J-part5 devfs=mount,dall resume=/dev/disk/by-id/ata-ST9320320AS_5SX2M65J-part8 splash=silent quiet showopts vga=0x31A
initrd /boot/initrd

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE
root (hd0,4)
kernel /boot/vmlinuz root=/dev/disk/by-id/ata-ST9320320AS_5SX2M65J-part5 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x31A
initrd /boot/initrd

###Don't change this comment - YaST2 identifier: Original name: other###
title windows
map (hd0) (hd0)
map (hd0) (hd0)
rootnoverify (hd0,0)
chainloader +1

Ritratto di Mirko
Mirko
(Guru)
Offline
Guru
Iscritto: 19/12/2005
Messaggi: 1602

Allora... Windows c'è ancora. Ma sono due partizioni? Hai C: e D:?
Mi sa anche che hai installato due volte openSuse Smile Io vedo due partizioni / e due swap, eheheheh.

Come dice Deckard, non vedi le partizioni di Windows da openSuse?
Dai un'occhiata in /windows, dovresti averle.
Se dai (sempre da root):

ls /windows/C/

Cosa vedi?

Ultima domanda: ma quando avvii la schermata che vedi è di grub o no?

Ritratto di matteo87
matteo87
(Junior)
Offline
Junior
Iscritto: 18/05/2010
Messaggi: 14

Allora mi compare una schermata dove vi sono in realtà due suse selezionabili, a questo punto credo di averlo installato due volte...La terza opzione è windows che selezionata mi manda nel menu startup che diucevo prima e mi fa ripartire l'installazione di suse...

Credo di averlo installato due volte perchè modificando delle opzioni sul boot loader su suse mi compariva al riavvio solo il menu start up e quindi ho dovuto riparare/reinstallare suse visto che windows non ne voleva sapere proprio di avviarsi...che caos!

Ritratto di matteo87
matteo87
(Junior)
Offline
Junior
Iscritto: 18/05/2010
Messaggi: 14

linux-6348:/home/matteo # ls /windows/C/
autoexec.bat menu.lst $RECYCLE.BIN
boot mirc.ini sqmdata00.sqm
bootmgr MSDOS.SYS sqmnoopt00.sqm
config.sys MSOCache SwSetup
Documents and Settings openSUSE System.sav
grldr openSUSE_hitme.txt System Volume Information
grldr.mbr pagefile.sys ubuntu
hiberfil.sys PerfLogs Users
HP ProgramData Windows
IO.SYS Program Files
MATLAB6p5 Programmi