LINUX E NOTEBOOK

20 risposte [Ultimo messaggio]
Ritratto di Dylan
Dylan
(Monster)
Offline
Monster
Iscritto: 24/07/2005
Messaggi: 203

Allora, per la partizione sono riuscito a risolvere... ho detto io come partizionare e tutto è andato bene... per l'audio nulla da fare... sono andato in Kmix e ho fatto i controlli consigliati... tutto regolato alla meglio, ma l'audio non funziona... pensandoci bene non si sente nemmeno "la campanella di sistema"...

questo è l'output del comando lspci:

00:00.0 Host bridge: ATI Technologies Inc RS480 Host Bridge (rev 10)<br />00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge<br />00:06.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge<br />00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)<br />00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)<br />00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller (rev 80)<br />00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 81)<br />00:14.1 IDE interface: ATI Technologies Inc Standard Dual Channel PCI IDE Controller ATI (rev 80)<br />00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge (rev 80)<br />00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge (rev 80)<br />00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC&#039;97 Audio Controller (rev 80)<br />00:14.6 Modem: ATI Technologies Inc ATI SB400 - AC&#039;97 Modem Controller (rev 80)<br />00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration<br />00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map<br />00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller<br />00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control<br />01:05.0 VGA compatible controller: ATI Technologies Inc RS482 [Radeon Xpress 200M]<br />02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8053 PCI-E Gigabit Ethernet Controller (rev 19)<br />03:07.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller<br />03:07.2 FireWire (IEEE 1394): Texas Instruments OHCI Compliant IEEE 1394 Host Controller<br />03:07.3 Mass storage controller: Texas Instruments PCIxx21 Integrated FlashMedia Controller<br />03:07.4 Class 0805: Texas Instruments PCI6411, PCI6421, PCI6611, PCI6621, PCI7411, PCI7421, PCI7611, PCI7621 Secure Digital (SD) Controller<br />03:09.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

e questo è l'output del comando lsmod:

Module                  Size  Used by<br />ppp_deflate             6528  0<br />zlib_deflate           20504  1 ppp_deflate<br />bsd_comp                6144  0<br />ppp_async              11392  1<br />crc_ccitt               2560  1 ppp_async<br />ppp_generic            29600  7 ppp_deflate,bsd_comp,ppp_async<br />slhc                    7168  1 ppp_generic<br />nls_iso8859_1           5504  0<br />nls_cp437               7296  0<br />vfat                   13568  0<br />fat                    52144  1 vfat<br />cpufreq_ondemand        6956  1<br />cpufreq_userspace       4500  0<br />cpufreq_powersave       2176  0<br />powernow_k8            10512  0<br />freq_table              5128  1 powernow_k8<br />edd                    10504  0<br />bnep                   16896  2<br />rfcomm                 37032  15<br />hidp                   17280  2<br />l2cap                  23176  16 bnep,rfcomm,hidp<br />snd_pcm_oss            49024  0<br />snd_mixer_oss          18304  1 snd_pcm_oss<br />snd_seq                55712  0<br />snd_seq_device          9360  1 snd_seq<br />snd_atiixp             20756  2<br />snd_ac97_codec        102232  1 snd_atiixp<br />snd_ac97_bus            2816  1 snd_ac97_codec<br />snd_pcm                97292  3 snd_pcm_oss,snd_atiixp,snd_ac97_codec<br />snd_timer              24968  2 snd_seq,snd_pcm<br />snd                    65192  12 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_atiixp,snd_ac97_codec,snd_pcm,snd_timer<br />soundcore              10656  1 snd<br />snd_page_alloc         10640  2 snd_atiixp,snd_pcm<br />lp                     13192  0<br />parport_pc             39656  0<br />parport                39180  2 lp,parport_pc<br />usb_storage            80960  0<br />xt_pkttype              2304  3<br />ipt_LOG                 6656  9<br />xt_limit                2944  9<br />ip6t_REJECT             6016  3<br />xt_tcpudp               3712  5<br />ipt_REJECT              6016  3<br />xt_state                2560  12<br />iptable_mangle          3328  0<br />iptable_nat             8964  0<br />ip_nat                 18860  1 iptable_nat<br />ip6table_mangle         2816  0<br />ip_conntrack           57228  3 xt_state,iptable_nat,ip_nat<br />nfnetlink               7240  2 ip_nat,ip_conntrack<br />ip6table_filter         3328  1<br />ip6_tables             13904  2 ip6table_mangle,ip6table_filter<br />af_packet              22028  0<br />iptable_filter          3456  1<br />ip_tables              12368  3 iptable_mangle,iptable_nat,iptable_filter<br />x_tables               14216  10 xt_pkttype,ipt_LOG,xt_limit,ip6t_REJECT,xt_tcpudp,ipt_REJECT,xt_state,iptable_nat,ip6_tables,ip_tables<br />joydev                 11136  0<br />sg                     35240  0<br />st                     38692  0<br />sd_mod                 17688  0<br />sr_mod                 16548  0<br />scsi_mod              145328  5 usb_storage,sg,st,sd_mod,sr_mod<br />ipv6                  252000  19 ip6t_REJECT<br />button                  7968  0<br />battery                11016  0<br />ac                      5896  0<br />apparmor               53540  0<br />aamatch_pcre           14464  1 apparmor<br />nls_utf8                2432  1<br />ntfs                  185320  1<br />loop                   16016  0<br />dm_mod                 59976  0<br />usbhid                 43296  0<br />hci_usb                15892  7<br />bluetooth              47780  17 bnep,rfcomm,hidp,l2cap,hci_usb<br />pcmcia                 39704  0<br />firmware_class         11648  1 pcmcia<br />shpchp                 45440  0<br />pci_hotplug            28136  1 shpchp<br />yenta_socket           26892  1<br />rsrc_nonstatic         12928  1 yenta_socket<br />pcmcia_core            42652  3 pcmcia,yenta_socket,rsrc_nonstatic<br />ohci1394               32584  0<br />ieee1394              101624  1 ohci1394<br />ide_cd                 40480  0<br />sky2                   38272  0<br />cdrom                  36008  2 sr_mod,ide_cd<br />ohci_hcd               19460  0<br />ehci_hcd               30216  0<br />usbcore               130600  6 usb_storage,usbhid,hci_usb,ohci_hcd,ehci_hcd<br />reiserfs              222464  2<br />fan                     5640  0<br />thermal                15888  0<br />processor              26068  2 powernow_k8,thermal<br />atiixp                  6160  0 [permanent]<br />ide_disk               16512  5<br />ide_core              145380  4 usb_storage,ide_cd,atiixp,ide_disk

Ragazzi sono nelle vostre mani... accetto tutti i consigli.

Ritratto di Dylan
Dylan
(Monster)
Offline
Monster
Iscritto: 24/07/2005
Messaggi: 203

Dai ragazzi... datemi una mano...

Ritratto di auris
auris
(Guru)
Offline
Guru
Iscritto: 10/09/2004
Messaggi: 4923

Il modulo per la gestione dell'audio è giusto (snd-atiixp):
http://gentoo-wiki.com/HARDWARE_Gentoo_on_HP_Pavilion_dv8000z#Sound_.2F_Modem

Se sei stanco di virus e schermate blu passa a Linux

Ritratto di Dylan
Dylan
(Monster)
Offline
Monster
Iscritto: 24/07/2005
Messaggi: 203

Quote:

auris ha scritto:
Il modulo per la gestione dell'audio è giusto (snd-atiixp):
http://gentoo-wiki.com/HARDWARE_Gentoo_on_HP_Pavilion_dv8000z#Sound_.2F_Modem

Eccomi.. allora ho dato un'occhiata al link... il file in questione /etc/modules.d/alsa non è presente nel mio computer... probabilmente dovrei crearlo... o forse non ho capito nulla.... puoi spiegarti meglio???

Grazie... come sempre sei tu che mi togli le castagne da sopra al fuoco!!

Ritratto di Dylan
Dylan
(Monster)
Offline
Monster
Iscritto: 24/07/2005
Messaggi: 203

Dai Auris... illuminami... Big Grin

Ritratto di Dylan
Dylan
(Monster)
Offline
Monster
Iscritto: 24/07/2005
Messaggi: 203

Ditemi solo una cosa... devo rassegnarmi??? Sto impazzendo senza audio!!!

Prego qualche anima pia di aiutarmi...

Ritratto di Stargatto
Stargatto
(Newbie)
Offline
Newbie
Iscritto: 26/09/2006
Messaggi: 1

Ciao Dylan

anche io ero interessato a quel notebook, in quanto ce l'ha un amico e mi e' sembrato ottimo come rapporto qualita' prezzo.

Mi sono informato subito sulla compatibilita' dei componenti; quindi ho letto il tuo post e mi sono fiondato dall'amico per provare la suse 10.1 LIVE cd e la knoppix 5.

In intrambe l'audio non si sente. Ma funziona e viene riconosciuto, cioe' amarok sembra riprodurre i file correttamente.

La prima domanda e': perche' l'audio che a rigore dovrebbe essere il chip integrato DIGITAL SOUNDMAX (ufficialmente non supportato da linux) viene riconosciuto come ATI XP RS400 (che e' il chipset della scheda madre)? Probabilmente e' il chipset ad interfacciare il soundmax che e' a livello hardware piu' basso.

Rimane il fatto che l'audio e' muto come un pesce. Allora in Internet
ho trovato diversi portabili con stesso chip (ati) che hanno problemi analoghi.
La prima soluzione che ti propongo e' quella di attivare le casse, aggiungendo la stringa

7a 2090

nel file

/proc/asound/card0/codec97#0/ac97#0-0+regs

(o simile nella stessa cartella)
come consigliato a questo indirizzo
http://starynkevitch.net/Basile/msi_s270_linux.html

Fammi sapere se ti funziona, cosi' ci faccio un doppio pensierino a prendere l'Olidata

Ritratto di Dylan
Dylan
(Monster)
Offline
Monster
Iscritto: 24/07/2005
Messaggi: 203

Ciao, scusa se ti rispondo in ritardo... ho fatto tutto quanto scritto nella guida da te postata... nulla!!! Assolutamente nulla!!! Grazie comunque per l'interessamento!!

Nel caso dovessi acquistarlo comunque tieni conto che anche la versione a 64 bit di Suse ha qualche problema... ieri ho reinstallato nuovamente suse ma la versione a 32 bit, ovviamente anche in questo caso l'audio non funziona!!! Altri problemi ci sono con la scheda video... il 3d non si riesce a configurare!!! Ribadisco un concetto!!! Non sono un genio di Linux ma queste cose le ho fatte e ripetute centinaia di volte, tutte andate a buon fine... per questo motivo ritengo che il problema sia il computer... Se tu hai qualche buona nuova avvertimi.
Grazie.

Ritratto di renegate
renegate
(Monster)
Offline
Monster
Iscritto: 22/06/2006
Messaggi: 202

Su impostazioni personali di kde/suono multimedia/sistema sulla impostazione hardware potresti settare il dispositivo audio OSS.
Nel mio portatile il sistema alsa alcune volte non si comportava molto bene. OSS dovrebbe usare dei driver (kernel) differenti da alsa.

Prova..

Linux user number 446455

Ritratto di Dylan
Dylan
(Monster)
Offline
Monster
Iscritto: 24/07/2005
Messaggi: 203

Le ho provate tutte... anche questa soluzione non ha avuto i risultati sperati...