matrox millennium G550

52 risposte [Ultimo messaggio]
Ritratto di Bennygoll
Bennygoll
(Junior)
Offline
Junior
Iscritto: 21/03/2007
Messaggi: 42

Mi Presento mi chiamo bernardo amodio sono sempre convinto che i sistemi linux siano i migliori anche perchè sono creati direttamente dagli utenti e non da aziende che tendono sempre verso direzioni politiche.
Purtroppo io non sono un forte forummista se così si può dire ma credetemi mi sono rotto il cccc voglio installare linux punto e basta.
Vi diro che non è la prima volta che installo linux e poi dopo l'abbandono perche non ho degli amici che mi risolvono gli eventuali problemi di configurazioni hardware che man mano si possono presentare.
Ho installato opensuse v 10.3 uno dei primi problemi che evidenzio sono la non abilitazione della scheda video in 3d sono andato sul sito della matrox ed ho scaricato questo file matrox_driver-x86_32-src-4.4.0 cera anche questo matrox_driver-x86_32-4.4.0 ma come devo fare per installarlo.

OpenSUSE 10.3 (s.m.P4S5A/DX -s.v.MatroxM./G550/32Mb -P4 1.7GHz -DDR 512Mb -HP Laserjet2200dn -HP Scanjet 3530c)

Ritratto di ferdybassi
ferdybassi
(Guru)
Offline
Guru
Iscritto: 11/09/2005
Messaggi: 2668

Prova a postare il link da dove hai scaricato, che vediamo se c'erano anche le istruzioni...
Che estensione hanno i files scaricati?
Ciao ciao

Amministratore di
www.it-opensuse.org

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Ho provato a scaricare i sorgenti e ho visto che sono disponibili fino all'Xorg 7.0 (mentre opensuse monta 7.2), quindi non credo funzionino.

Questo perche` ho provato il primo passo per la compilazione e va in cerca di file che non sono presenti, o che comunque hanno cambiato nome e posizione.

Comunque, stando a quanto riportato in questa pagina: http://en.opensuse.org/HCL/Video_Cards#G550 la scheda dovrebbe essere riconosciuta e il 3d abilitato in automatico.

Provato a configurarla via yast?

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di Bennygoll
Bennygoll
(Junior)
Offline
Junior
Iscritto: 21/03/2007
Messaggi: 42

La prima cosa vi volevo ringraziare per quanto riguarda il link http://www.matrox.com/graphics/it/corpo/support/drivers/driverList.php

OpenSUSE 10.3 (s.m.P4S5A/DX -s.v.MatroxM./G550/32Mb -P4 1.7GHz -DDR 512Mb -HP Laserjet2200dn -HP Scanjet 3530c)

Ritratto di Bennygoll
Bennygoll
(Junior)
Offline
Junior
Iscritto: 21/03/2007
Messaggi: 42

Ragazzi se non mi aiutate purtroppo anche questa volta dovro formattare per mettere windows Come si usa Yast ?

OpenSUSE 10.3 (s.m.P4S5A/DX -s.v.MatroxM./G550/32Mb -P4 1.7GHz -DDR 512Mb -HP Laserjet2200dn -HP Scanjet 3530c)

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Dopo averlo avviato (dal menu di avvio lo trovi dentro System. Quando lo avvii, ti chiede la password di root; la inserisci e poi yast parte), vai in Hardware, clicchi su Graphic card & Monitor e ti si apre una schermata in cui viene riportato modello del monitor e della scheda. Piu` sotto c'e` la risoluzione e i colori; poi la possibilita` di abilitare il secondo video e in basso la possibilita` di abilitare l'accelerazione 3d.

Prova a postare uno screenshot di yast oppure a descriverlo. Comunque, dopo che hai fatto le modifiche e clicchi su ok, ti viene fornita la possibilita` di testare le impostazioni. Effettua il test e nella schermata che compare controlla se il 3d e` attivo o no (si capisce dallo stato del segnale di divieto sulla scritta 3d).

Comunque, per essere sicuro che il 3d funzioni, e` sufficiente che usi chromium o supertuxkart, che sono due giochi che lo sfruttano.

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di Bennygoll
Bennygoll
(Junior)
Offline
Junior
Iscritto: 21/03/2007
Messaggi: 42

Appena clicco su Graphics Card and Monitor mi compare il seguente messaggio:
3D acceleration not supported
SaX2 cannot offer activation of the 3D subsystem because your graphics card/driver doesn't support 3D

OpenSUSE 10.3 (s.m.P4S5A/DX -s.v.MatroxM./G550/32Mb -P4 1.7GHz -DDR 512Mb -HP Laserjet2200dn -HP Scanjet 3530c)

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Come vedi dalla mia firma, ho un'altra scheda / altra marca, quindi non e` che possa aiutarti piu` di tanto.

Come prima cosa, dovresti postare il file /etc/X11/xorg.conf e poi dare una letta a questa pagina: http://xorg.freedesktop.org/releases/X11R7.0/doc/html/mga.4.html

Probabilmente si riesce a ricostruire un xorg.conf con il 3d funzionante. Solo che sarebbe da sapere se la tua scheda e` agp, pci, pciexpress; se e` millennium o millennium II.

Comunque, anche se compare tale messaggio, andando avanti nella sequenza che ti ho indicato, cosa ottieni?

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di Bennygoll
Bennygoll
(Junior)
Offline
Junior
Iscritto: 21/03/2007
Messaggi: 42

tutto quello che hai detto tranne qualsiasi comando che mi dii la possibilità di abilitare in qualche modo il 3D

OpenSUSE 10.3 (s.m.P4S5A/DX -s.v.MatroxM./G550/32Mb -P4 1.7GHz -DDR 512Mb -HP Laserjet2200dn -HP Scanjet 3530c)

Ritratto di Bennygoll
Bennygoll
(Junior)
Offline
Junior
Iscritto: 21/03/2007
Messaggi: 42

Non ho ancora risolto un bel niente per quanto riguarda il file xorg.conf è questo:

# /.../
# SaX generated X11 config file
# Created on: 2007-11-12T09:56:35+0100.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "it"
Option "XkbModel" "pc102"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "9"
Option "Device" "/dev/input/mice"
Option "Name" "ImExPS/2 Generic Explorer Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
DisplaySize 304 228
HorizSync 30-60
Identifier "Monitor[0]"
ModelName "SAMSUNG SYNCMASTER"
Option "DPMS"
VendorName "SAM"
VertRefresh 43-75
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1024x768" 80.71 1024 1080 1192 1360 768 769 772 802
Modeline "800x600" 48.91 800 840 920 1040 600 601 604 627
Modeline "800x600" 45.50 800 840 920 1040 600 601 604 625
Modeline "800x600" 42.11 800 840 920 1040 600 601 604 623
Modeline "800x600" 38.22 800 832 912 1024 600 601 604 622
EndSection

Section "Screen"
DefaultDepth 16
SubSection "Display"
Depth 15
Modes "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Device"
BoardName "G550"
BusID "1:0:0"
Driver "vesa"
Identifier "Device[0]"
VendorName "Matrox"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection

OpenSUSE 10.3 (s.m.P4S5A/DX -s.v.MatroxM./G550/32Mb -P4 1.7GHz -DDR 512Mb -HP Laserjet2200dn -HP Scanjet 3530c)

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Per forza il 3d non funziona, stai usando i driver vesa.

Prova cosi`: nella section Module aggiungi Load &quot;dri&quot;
nella section Device, al posto di Driver &quot;vesa&quot;
metti Driver &quot;mgag550&quot;
e aggiungi la riga VideoRam <i>dimensione</i>
dove al posto di dimensione metti la quantita` di memoria della tua scheda, espressa il kilobyte (ad esempio, 65536 se la tua scheda ha 64Mb di ram)

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde