"Missing bootmgr" da Windows 7, OpenSUSE 11.4 in dual boot...

6 risposte [Ultimo messaggio]
Ritratto di Hackuity
Hackuity
(Newbie)
Offline
Newbie
Iscritto: 08/04/2011
Messaggi: 3

Buonasera a tutti, amici Susini...il mio problema temo sia abbastanza frequente, ma nessuna delle soluzioni che ho provato finora ha funzionato, vi imploro per avere aiuto, sono disperato Sad
Situazione: ho un HDD interno da 500 GB, diviso in due sezioni da 250 GB ciascuna. Sulla prima c'è installato Windows 7, mentre solo 100 GB della seconda sono adibiti a SUSE...il problema è quello del titolo, GRUB se la cava bene ma quando deve caricare Windows proprio non c'è modo, mi dice Missing bootmgr Raised Eyebrow
La partizione di Windows è sda2, quella di SUSE sda5...
Per completezza, vi riporto un paio di comandi da terminale...

Citazione:

zerouno:/home/davide # fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x36fbca17

Device Boot Start End Blocks Id System
/dev/sda1 2048 821247 409600 27 Hidden NTFS WinRE
/dev/sda2 * 821248 488245247 243712000 7 HPFS/NTFS/exFAT
/dev/sda3 488245248 780945564 146350158+ 7 HPFS/NTFS/exFAT
/dev/sda4 780947454 976771071 97911809 5 Extended
/dev/sda5 780947456 968718335 93885440 83 Linux
/dev/sda6 968720384 976771071 4025344 82 Linux swap / Solaris

Citazione:

zerouno:/home/davide # cat /boot/grub/menu.lst
# Modified by YaST2. Last modification on Fri Apr 8 22:23:32 CEST 2011
# THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
# Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,4)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.4
root (hd0,4)
kernel /boot/vmlinuz-2.6.37.1-1.2-default root=/dev/disk/by-uuid/f0764609-78d3-49bf-83ea-19e135944706 resume=/dev/disk/by-id/ata-TOSHIBA_MK5065GSXN_X0KFS38AS-part6 splash=silent quiet showopts vga=0x317
initrd /boot/initrd-2.6.37.1-1.2-default

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.4
root (hd0,4)
kernel /boot/vmlinuz-2.6.37.1-1.2-default root=/dev/disk/by-uuid/f0764609-78d3-49bf-83ea-19e135944706 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x317
initrd /boot/initrd-2.6.37.1-1.2-default

###Don't change this comment - YaST2 identifier: Original name: linux###
title Kernel-2.6.37.1-1.2-default
root (hd0,4)
kernel /boot/vmlinuz-2.6.37.1-1.2-default root=/dev/disk/by-uuid/f0764609-78d3-49bf-83ea-19e135944706 resume=/dev/disk/by-id/ata-TOSHIBA_MK5065GSXN_X0KFS38AS-part6 splash=silent quiet showopts vga=0x317
initrd /boot/initrd-2.6.37.1-1.2-default

###Don't change this comment - YaST2 identifier: Original name: linux###
title Winzoz
rootnoverify (hd0,1)
makeactive
chainloader +1

Citazione:

zerouno:/home/davide # cat /etc/fstab
/dev/disk/by-id/ata-TOSHIBA_MK5065GSXN_X0KFS38AS-part6 swap swap defaults 0 0
UUID=f0764609-78d3-49bf-83ea-19e135944706 / ext4 errors=remount-ro 1 1
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

Vi prego, non ditemi di usare il CD di installazione di Windows, perchè non ce l'ho...Toshiba da' solo la possibilità di creare dischi di ripristino, e bootando quelli formatta tutto quanto...aiutatemi Crying

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2721

http://www.crismonblog.org/opensuse-102/opensuse-102-italian/fix-grub-bootloader.html
Segui la guida dovresti risolvere
ciao

SUSE Tumbleweed- kernel-5.1.4-1.2- kde-plasma-5.15.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di Hackuity
Hackuity
(Newbie)
Offline
Newbie
Iscritto: 08/04/2011
Messaggi: 3

No, non ci siamo capiti. GRUB funziona a meraviglia. Non ho bisogno di fixarlo, ma di far bootare quella dannata partizione Crying

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2721

ripristinando grub si sceglie di avviare da MBR,quindi dovresti risolvere,e suse ti vedrà window7
http://www.it-opensuse.org/installato-opensuse-11-3-non-parte-piu-windows-7-t104-40.html
http://linuxguide.altervista.org/Guida_openSUSE/Sistema.html#Boot_Loader
segui anche questa discussione dove si e risolto avendo il tuo stesso problema
ciao

SUSE Tumbleweed- kernel-5.1.4-1.2- kde-plasma-5.15.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di Hackuity
Hackuity
(Newbie)
Offline
Newbie
Iscritto: 08/04/2011
Messaggi: 3

In questo momento non ho modo di scaricare il DVD consigliato per riparare GRUB, domani provo...la mia domanda (ad ogni modo, grazie per le risposte): se il punto è far bootare dal MBR, non posso semplicemente impostare questa opzione dal configuratore di Yast? Ci ho anche provato, ma non funziona...

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2721

http://guidalinux.altervista.org/suselinux-manual_it-10.1-4/sec.boot.yast2.config.html
ciao

SUSE Tumbleweed- kernel-5.1.4-1.2- kde-plasma-5.15.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2721

[img] Uploaded with ImageShack.us[/img]
http://www.debianitalia.org/guide/installazione-configurazione/guida-alla-configurazione-di-grub#altriso
Grazie a Doc_pluto,per avermela ricordata
avvia da record principale,lo spunti.
mbr
ciao

SUSE Tumbleweed- kernel-5.1.4-1.2- kde-plasma-5.15.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/