non riesco a montare il lettore dvd

29 risposte [Ultimo messaggio]
Ritratto di bloody
bloody
(Junior)
Offline
Junior
Iscritto: 05/11/2006
Messaggi: 7

Ciao a tutti... sono un nuovo utente Linux... Ho installato suse 10.0 e ovviamente qualcosa non va!! quando provo ad sfogliare il lettore dvd mi da errore. mi dice che non posso montare il lettore perche non sono root. ho provato con yast, lo monto(come root) però non cambia nulla, e lo stesso per il floppy.
Ho cercato l'impossibile, ma non trovo nulla che mi possa aiutare Sad aiuto vi prego altrimenti divento matto

Ritratto di pernix
pernix
(Guru)
Offline
Guru
Iscritto: 07/07/2006
Messaggi: 995

Posta quello che hai nel file /etc/fstab

In a world without walls and fences, who needs Windows ad Gates?

openSUSE 10.3 - KDE+Compiz
Dell Latitude D820N: Intel T7200 2GHz; 2GB RAM 667MHz; Nvidia Quadro NVS 120M 512MB

Ritratto di scastagnoli
scastagnoli
(Monster)
Offline
Monster
Iscritto: 15/12/2005
Messaggi: 237

Ciao e benvenuto!
Dovrebbe essere sufficiente aprire una consolle shell e scrivere (come root) il seguente comando:

mount -t iso9660 -o ro /dev/cdrom /cdrom

quello che può cambiare è il nome del dispositivo che vuoi montare (dai un'occhiata a dmesg | grep -i ide) e la directory, che nell'esempio che ti hospecificato è /cdrom. Questa directory deve esistere e se vuoi leggere il contenuto del CD anche come utente non root, è necessario che tale directory abbia diritti tipo 744 (vedi chmod).

Se ti serve qualche indicazione chiedi pure.

Stefano C.

Ritratto di bloody
bloody
(Junior)
Offline
Junior
Iscritto: 05/11/2006
Messaggi: 7

ciao,grazie del consiglio, sfortunatamente, non sono in grado di capire cosa devo cambiare, ho dato il comando per vedere le periferiche ma non so quale riportare, e poi non so.... come faccio a creare la cartella dvdrom?
l'errore che mi da è: mount point..........does not exsist

Ritratto di scastagnoli
scastagnoli
(Monster)
Offline
Monster
Iscritto: 15/12/2005
Messaggi: 237

Prova a riportare l'output di dmesg.

Stefano C.

Ritratto di bloody
bloody
(Junior)
Offline
Junior
Iscritto: 05/11/2006
Messaggi: 7

linux:~ # dmesg | grep -i ide
BIOS-provided physical RAM map:
CPU: After generic identify, caps: 078bfbff e3d3fbff 00000000 00000000 00000001 00000000 00000001
CPU: After vendor identify, caps: 078bfbff e3d3fbff 00000000 00000000 00000001 00000000 00000001
Boot video device is 0000:03:00.0
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
NFORCE-MCP51: IDE controller at PCI slot 0000:00:0d.0
ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:pio
ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:DMA, hdd:pio
Probing IDE interface ide0...
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Probing IDE interface ide1...
ide1 at 0x170-0x177,0x376 on irq 15

Ritratto di Veleno_SNAP
Veleno_SNAP
(Junior)
Offline
Junior
Iscritto: 10/11/2006
Messaggi: 7

8-) :-P
Ah caro bloody.....come sei messo....tra un paio di giorni porterò pure io un hd a linux e li vedremo cosa sono in grado di fare e che casini farò nascere. N
el frattempo volevo sapere da qualcuno più esperto di noi se bisogna sempre,in ogni pc,configurare i vari tipi di hardware che si installano,tipo:monitor,mouse,tastiera,dolby,vga e scheda audio!! C'è qualcosa che si installa in automatico o dobbiamo configurare tutto a manina?
se bisogna configurare tutto a manina ci sono delle guide disponibili in rete o libri da acquistare per risolvere questi problemi?
Vi ringrazio sin da ora per l'aiuto che darete a noi Veleno e Bloody SNAP.

Ritratto di Veleno_SNAP
Veleno_SNAP
(Junior)
Offline
Junior
Iscritto: 10/11/2006
Messaggi: 7

8-)
Allora.....ho installato suse 10.0 in un singolo hd privo di partizioni. non ho problemi per mouse,tastiera,monitor e vga per il momento.....dovrei solo installare i driver da cd e il problema è proprio questo!!!!
Il masterizzatore dvd della LG viene rilevato!!! Se inserisco un cd originale o masterizzato al suo interno e vado su Applicazioni/multimedia/lettore cd....il sistema mi riproduce il suo contenuto.

Ma se vado su Computer e seleziono il dispositivo media mi compare l'errore " mount: only root can mount / dev/dvdram on /media/

Che significa? Come posso risolvere questo errore?
Grazie per l'aiuto che mi darete!

Ritratto di bloody
bloody
(Junior)
Offline
Junior
Iscritto: 05/11/2006
Messaggi: 7

Veleno, il problema che hai, è lo stesso problema per il quale ho aperto questo forum, prova a guardare i messaggi precedenti e vedi se ti riescie di risolvere sto problema............... :-P :-P

Ritratto di bloody
bloody
(Junior)
Offline
Junior
Iscritto: 05/11/2006
Messaggi: 7

SCASTA......................AIUTO, COSA DICI DEL MESSAGIO, SAI DIRMI QUALCOSA??

Ritratto di bloody
bloody
(Junior)
Offline
Junior
Iscritto: 05/11/2006
Messaggi: 7

questo è il mio fstab

/dev/hda2 / reiserfs acl,user_xattr 1 1
/dev/hda3 /home reiserfs acl,user_xattr 1 2
/dev/hda1 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/fd0 /media/floppy auto noauto,user,sync 0 0