problema 3d su ati x700

45 risposte [Ultimo messaggio]
Ritratto di Godzilla
Godzilla
(Junior)
Offline
Junior
Iscritto: 18/02/2007
Messaggi: 13

salve.ho completato la mia prima installazione di suse(collegato in rete )e con mio sommo piacere a installazione terminata(a differenza di quanto accadeva con mandriva e ubuntu) il serverx si è avviato tranquillamente senza intoppi,con una risoluzione dello schermo alta..tutto apposto,ho pensato...il fatto è che non sono riuscito ad attivare gli effetti 3d...ho seguito la guida su ati e 3d presente nella sezione apposita,ma al momento in cui do il comando sax2 -r - m la macchina si blocca!che errore commetto?
ps in mandriva una volta riuscito ad accedere all'interfaccia grafica era sufficiente andare sulle impostazioni di sistema e attivare gli effetti 3d..qui invece?
grazie

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

il comando che dai e` sax2 -r -m 0=fglrx, vero? Controlla in /var/log/Yast/y2log o in /var/log/Sax2.log se c'e` qualche informazione sul blocco.
L'rpm dei driver viene generato correttamente? L'installazione dell'rpm non da` problemi?

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di Godzilla
Godzilla
(Junior)
Offline
Junior
Iscritto: 18/02/2007
Messaggi: 13

si..l'rpm viene generato normalmente e l'installazione non da problemi... Sad

Ritratto di Godzilla
Godzilla
(Junior)
Offline
Junior
Iscritto: 18/02/2007
Messaggi: 13

scusate non riesco a capire una cosa...io faccio l'installazione collegato al cavo dsl.terminata il serverx si avvia..mi da la possibilità di configurare i parametri della scheda video..scelgo accelerazione 3d..tutto ok..la risoluzione va bene..ora...per attivare gli effetti 3d sul desktop (cubi finestre tremolanti ecc..)è necessario seguire la guida su ati e 3d???scusate..forse sono un po ottuso ma questo passaggio non mi è chiaro..grazie mille

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Chiarisci un attimo questo punto: il 3d della scheda ti funziona?
Cosa ottieni se dai i comandi fglrxinfo e glxinfo|grep direct?

Il cubo, finestre tremolanti e compagnia varia e` un problema risolvibile dopo che la scheda video ti fornisce correttamente il 3d (e per far questo, segui la guida su beryl).

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di Godzilla
Godzilla
(Junior)
Offline
Junior
Iscritto: 18/02/2007
Messaggi: 13

al comando fglrx ottengo come output:comand non found..mentre se do glxinfo | grep rendering ottengo un bel NO...come fare?

Ritratto di Godzilla
Godzilla
(Junior)
Offline
Junior
Iscritto: 18/02/2007
Messaggi: 13

suseMachine:/home/andrea # fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Tungsten Graphics, Inc.
OpenGL renderer string: Mesa DRI R300 20060815 x86/MMX/SSE2 TCL
OpenGL version string: 1.3 Mesa 6.5.1

suseMachine:/home/andrea # glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
GLX_OML_swap_method, GLX_SGI_swap_control, GLX_SGIS_multisample,
GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample,
GLX_ATI_pixel_format_float, GLX_ATI_render_texture
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_multisample
OpenGL vendor string: Tungsten Graphics, Inc.
OpenGL renderer string: Mesa DRI R300 20060815 x86/MMX/SSE2 TCL
OpenGL version string: 1.3 Mesa 6.5.1
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x24 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
0x25 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 Slow
0x26 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 Slow
0x27 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x28 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
0x29 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 Slow
0x2a 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 Slow
0x2b 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x2c 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
0x2d 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 1 0 Slow
0x2e 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 1 0 Slow
0x2f 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 1 0 None
0x30 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 1 0 None
0x31 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 1 0 Slow
0x32 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 1 0 Slow
suseMachine:/home/andrea #

Ritratto di Godzilla
Godzilla
(Junior)
Offline
Junior
Iscritto: 18/02/2007
Messaggi: 13

dunque ragazzi,dopo varie prove(coadiuvato da alcuni colleghi)credo che la guida su ati e 3d non funzioni sulla mia scheda video...partendo da un sistema fresco e pulito di formattazione e installazione,seguendola guida procedo tranquillamente fino a "init 3 ----> cd/usr/....../i386 ----->
rpm -Uvh fgl*.rpm: a questo punto una volta installato il pacchetto vengono visualizzati alcuni messaggi di errore che ti dicono di installare kernel-source , gcc, ecc ecc;torno all'interfaccia grafica installo pacchetti e dipendenze da yast....riavvio il sistema riprendo da init 3 rpm ecc ecc, le dipendenze ora sono soddisfatte ma una serie di simpatici "warning" dicono che qualcosa non va..tipo non èstato possibile rimuovere alcune voci dalla directory,altre non sono state trovate..se si prosegue con la guida..dopo sax 2 etc etc..schermata nera..sistema in crash!reboot...schermata nera e stop!come risolvo il problema?io ho seguito la guida alla lettera...più volte oltretutto..ho cercato info su google..ma nulla..scusate se mi sono dilungato,ma volevo spiegare bene il problema..spero di esserci riuscito...buonanotte... :-o

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Prova cosi`: ti fai un elenco dei file contenuti nell'rpm di fglrx; poi fai pulizia dell'installazione del driver con un bel rpm -e flgrx... (il nome dell'rpm) e controlli che siano stati eliminati tutti i file contenuti nell'rpm. Se qualcosa e` rimasto, toglilo (cancellalo o spostalo o rinominalo, vedi tu). Inoltre assicurati che X funzioni con i driver radeon standard (recupera qualche xorg.conf di backup e usa quello)

Poi aggiungi il repository http://www2.ati.com/suse/10.2, avvii yast e installi i pacchetti ati-fglrxG01-kmp-default-8.33.6_2.6.18.2_34.1-1.1 e x11-video-fglrxG01-8.33.6-1.1 (il primo in accordo al tipo di kernel che hai installato, lo trovi con il comando uname -r).
Una volta installati i due pacchetti, usa sax2 -r per configurare X (come indicato qui)

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di Godzilla
Godzilla
(Junior)
Offline
Junior
Iscritto: 18/02/2007
Messaggi: 13

non mi accetta il repo..
ps vedo che tu hai la mia stessa scheda...non hai avuto problemi?io ho seguito alla lettera la guida ufficiale di open suse..ma nulla!

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Strano che non ti accetti il repo. Io lo uso sotto yast e funziona.

Comunque con la mia scheda non ho avuto alcun problema a installare i driver della ati, seguendo i canonici passi:
- installare il kernel-source, xorg-x11-devel e il compilatore (non so di preciso se il devel di xorg serva effettivamente)
- scaricare l'installer e renderlo eseguibile,
- generare il pacchetto (./ati... --buildpkg SuSE/SUSE102-IA32)
- installare il pacchetto generato (rpm -ivh fglrx*)
- lanciare aticonfig --initial --input=/etc/X11/xorg.conf
- lanciare sax2 -r -m 0=fglrx
- riavviare X

Ora che ho l'xorg pronto, uso i pacchetti del repo.

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde