problema negli aggiornamenti di yast

6 risposte [Ultimo messaggio]
Ritratto di Isaia
Isaia
(Monster)
Offline
Monster
Iscritto: 16/11/2007
Messaggi: 214

sto tentando di aggiornare il sistema tramite yast, ma mi si presenta questo errore:

2 Problemi: Problema:Usando solo i risolubili per la migliore architettura compatibile non è stata trovata alcuna soluzione valida. Problema:Impossibile installare vlc. Alcune dipendenze sono mancanti Problema:Usando solo i risolubili per la migliore architettura compatibile non è stata trovata alcuna soluzione valida. Con questo tentativo sono stati analizzati solo i risolubili con la migliore architettura. Analizzare tutti i possibili risolvibili richiede del tempo ma può anche fornire un risultato valido. Soluzione 1:Esegui un tentativo risolutore usando TUTTE le possibilità. Analisi di tutti i risolvibili con un'architettura compatibile.

notare che per prova ho tolto vlc dai programmi da aggiornare... perchè fa qusto scherzo? il vero problema è che con questo errore mi è impossibile aggiornare tutti i programmi.... che faccio?

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Per caso hai aggiunto il repository di vlc?
Prova a non fare l'aggiornamento di vlc, vlc-mozillaplugins e x264.

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di Isaia
Isaia
(Monster)
Offline
Monster
Iscritto: 16/11/2007
Messaggi: 214

il repository l'avevo aggiunto tempo fa, adesso togliendo anche x264 come mi ha i detto tu oltre ai due di vlc mi sta aggiornando... cosa devo fare per risolvere il problema di vlc?

modifica: l'aggiornamento non è andato a buon fine, mi è uscito questo errore:
Installazione di [S1:1][package]gstreamer010-plugins-good-0.10.6-42.pm.4.i586 fallita: (con --nodeps --force) Errore: Subprocess failed. Error: RPM failed: warning: /var/adm/mount/AP_0x00000004/i586/gstreamer010-plugins-good-0.10.6-42.pm.4.i586.rpm: Header V3 DSA signature: NOKEY, key ID 9a795806 I/O warning : failed to load external entity "/etc/gconf/schemas/gstreamer-0.10.schemas" Failed to open `/etc/gconf/schemas/gstreamer-0.10.schemas': No such file or directory error: %post(gstreamer010-plugins-good-0.10.6-42.pm.4.i586) scriptlet failed, exit status 1 (con --nodeps --force) Errore

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Il problema con gstreamer lo ho avuto anch'io, quando ho aggiornato ieri sera. Comunque il pacchetto e` andato su lo stesso.

Per vlc, il problema e` un'incompatibilita` di versione tra la nuova versione di x264 e mplayer, mi sembra di ricordare. In attesa che venga distribuita una versione aggiornata di mplayer alle nuove x264, l'unica cosa da fare e` non aggiornare i tre pacchetti in questione.

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di Isaia
Isaia
(Monster)
Offline
Monster
Iscritto: 16/11/2007
Messaggi: 214

beh allora aspetterò... gstreamer comunque non l'ha aggiornato... grazie dell'aiuto...

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Anche a me non lo aveva aggiornato (anche se risultava installato).

Comunque, per risolvere il problema dell'aggiornamento di gstreamer, basta dare, come root ovviamente, il comando ln -s /etc/usr/gconf/schemas/gstreamer-0.10.schemas /etc/gconf/schemas/gstreamer-0.10.schemas

Per qualche arcano motivo, va a scrivere sul file /etc/usr/gconf/schemas/gstreamer-0.10.schemas ma lo cerca come /etc/gconf/schemas/gstreamer-0.10.schemas (nota la mancanza della sottodirectory usr)

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2742

http://www.suseitalia.org/modules/newbb/viewtopic.php?topic_id=15617&forum=5&post_id=86469#forumpost86469

SUSE Tumbleweed- kernel-5.8.15.1.2- kde-plasma-5.20.1- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.132.14- SSD samsung 850 pro 512 gb http://opensuse-community.org/