problema risoluzione video

17 risposte [Ultimo messaggio]
Ritratto di sapir
sapir
(Junior)
Offline
Junior
Iscritto: 07/11/2006
Messaggi: 12

ciao a tutti,
ho un problema con il monitor, in pratica impostando la risoluzione video 1024X768 si vede tutto sfocato.... dunque sono costretto ad usare la 1280X1024 che proprio non riesco a digerire..... ho provato a cambiare anche la frequenza ma non risolvo niente... il monitor è un belinea lcd 101710 (presente fra i modelli elencati in X11).. come posso risolvere??
ciao
grazie
P.S. scusate se ho sbagliato sezione......

Ritratto di ferny
ferny
(Monster)
Offline
Monster
Iscritto: 04/08/2006
Messaggi: 249

Ciao, usando una risoluzione più bassa di quella impostata di default, si ottengono dei caratteri meno definiti e che, quindi, possono apparire come sfocati. Se non digerisci la 1280x1024, presumo, sia a causa delle dimensioni delle icone e dei caratteri.Se è questo il problema, è facilmente risolvibile accedendo al centro di controllo di kde ( digita kcontrol in esegui comando ) e li, in aspetto e temi, vai sulle voci caratteri, icone, ed accedendo alle loro caratteristiche avanzate, ne puoi regolare tipo e dimensione, personalizzando il tutto e portandolo ad un livello "digeribile".

Ritratto di sapir
sapir
(Junior)
Offline
Junior
Iscritto: 07/11/2006
Messaggi: 12

ma davvero non c'è altra soluzione??? davvero su linux non si può scegliere la risoluzione a proprio piacimento?

Ritratto di ascanio
ascanio
(Monster)
Offline
Monster
Iscritto: 29/10/2005
Messaggi: 317

Su linux la risoluzione si cambia.Penso che il problema più che allo schermo sia dovuto alla scheda video.Due domande ,che scheda video hai ,e se hai installato i driver.

ascans

Ritratto di sapir
sapir
(Junior)
Offline
Junior
Iscritto: 07/11/2006
Messaggi: 12

la scheda video è integrata nella scheda madre... il pc è un vecchio PIII.. non ho installato nessun driver... che faccio?
grazie per le risposte

Ritratto di sapir
sapir
(Junior)
Offline
Junior
Iscritto: 07/11/2006
Messaggi: 12

aggiungo che la scheda video integrata è basata sul chip 815... e che questo è riconosciuto dal sistema X11...

Ritratto di ascanio
ascanio
(Monster)
Offline
Monster
Iscritto: 29/10/2005
Messaggi: 317

La marca è intel?
Intanto prova a cambiare tipo di monitor ,usa sempre nell'elenco i drive "lcd" oppure "vesa".Prova sempre la configurazione prima di salvare e ricorda che i cambiamenti hanno effetto dopo il riavvio del server grafico.

ascans

Ritratto di sapir
sapir
(Junior)
Offline
Junior
Iscritto: 07/11/2006
Messaggi: 12

si, il chip 815 è intel

Ritratto di ascanio
ascanio
(Monster)
Offline
Monster
Iscritto: 29/10/2005
Messaggi: 317

Prova ad impostare i colori a 16 bit ,e se non risolvi postami il file "/etc/X11/xorg.conf" il drive in uso per questa scheda dovrebbe essere "i810"

ascans

Ritratto di sapir
sapir
(Junior)
Offline
Junior
Iscritto: 07/11/2006
Messaggi: 12

allora, ho provato sia vesa che lcd, ma il risultato è sempre lo stesso, si vede tutto sfocato con una qualità pessima....

ho provato anche impostando i colori a 16bit ma niente...

a proposito del driver della scheda madre, in effetti sul sito intel per questo chip c'è un driver chiamato "XFcom_i810...ecc ecc" con estensione .rpm.... io ho provato ad installarlo con il software di installazione dei pacchetti ma forse non è la procedura giusta Laughing .... scusatemi ma ho linux solo da un paio di giorni....

allego il file richiesto

P.S. ti ringrazio per la disponibilità Big Grin

# /.../
# SaX generated X11 config file
# Created on: 2006-11-13T13:43:14+0100.
#
# Version: 7.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (7.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
Load "v4l"
Load "dri"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "it"
Option "XkbModel" "pc102"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "7"
Option "Device" "/dev/input/mice"
Option "Name" "ImExPS/2 Generic Explorer Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
DisplaySize 345 259
HorizSync 28-81
Identifier "Monitor[0]"
ModelName "101710"
Option "DPMS"
VendorName "BELINEA"
VertRefresh 57-60
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1024x768" 61.89 1024 1080 1184 1344 768 769 772 794
Modeline "1024x600" 47.26 1024 1064 1168 1312 600 601 604 621
Modeline "800x600" 36.88 800 832 912 1024 600 601 604 621
Modeline "768x576" 33.74 768 792 872 976 576 577 580 596
Modeline "640x480" 23.06 640 656 720 800 480 481 484 497
Modeline "1280x1024" 105.15 1280 1360 1496 1712 1024 1025 1028 1059
Modeline "1280x960" 97.68 1280 1352 1488 1696 960 961 964 993
Modeline "1280x800" 80.58 1280 1344 1480 1680 800 801 804 827
Modeline "1152x864" 78.82 1152 1216 1336 1520 864 865 868 894
Modeline "1280x768" 77.37 1280 1344 1480 1680 768 769 772 794
Modeline "1280x600" 58.78 1280 1328 1456 1632 600 601 604 621
Modeline "640x480" 55.00 640 672 732 864 480 488 494 530
EndSection

Section "Screen"
DefaultDepth 16
SubSection "Display"
Depth 15
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Device"
BoardName "I815"
BusID "0:2:0"
Driver "i810"
Identifier "Device[0]"
Option "ShowCache"
Option "NoAccel"
Option "SWcursor"
Option "DRI"
Option "Dac6Bit"
Option "PageFlip"
Option "NoDDC"
Screen 0
VendorName "Intel"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection

Ritratto di ascanio
ascanio
(Monster)
Offline
Monster
Iscritto: 29/10/2005
Messaggi: 317

L'rpm che hai trovato è per vecchi kernel .
Il drive usato è già quello giusto,mi dispiace ma non trovo niente di strano.
Su win usavi 1024x768 senza problemi?
Proviamo a configurare sax dalla shell
apri il terminale >loggati come root >digta init 3.
Ti trovi davanti al promt .Digita sax2
Seleziona la configurazione preferita provala e salva,esci da sax.
Digita init 5 per riavviare il server grafico.

ascans