Problemi con aggiornamenti

16 risposte [Ultimo messaggio]
Ritratto di ILSECCO
ILSECCO
(Geek)
Offline
Geek
Iscritto: 22/01/2010
Messaggi: 76

Ciao
non mi si installano i nuovi aggiornamenti:
KDE 4.3.5 update, libpoppler-devel e mozillaFirefox;
se faccio installa esce il seguente errore:

PackageKit Error cannot-remove-system-package: Subprocess failed. Error: RPM failed: error: package kdebase4-libkonq-4.3.1-5.6.3.i586 is not installed

e dice di installare manualmente con yast ma anche così niente. Sad
Che fare?
Ciao ciao

Sistema: openSUSE 12.1 (i586) KDE: 4.7.2 (4.7.2) "release 5" nVidia Corporation GeForce 6200 Driver 2D: nvidia Driver 3D: NVIDIA 275.21 Processore (CPU): AMD Sempron(tm) Processor 3000+ Velocità: 1.599,75 MHz Memoria totale (RAM): 983,5 MiB Memoria disponibile: 14,7 MiB (+ cache 274,1 MiB ) Swap disponibile: 2,0 GiB

Ritratto di enziosavio
enziosavio (non verificato)
()

Prova a fare cosi.....> apri Yast->poi invece di "gestione pacchetti"
avvia " aggiornamenti in linea " se c' è qualche errore li lo rileva e lo
puoi correggere.......magari c' è da cambiare rivenditore a qualche pacchetto........
Prova poi fammi sapere
Ciao

Ritratto di ILSECCO
ILSECCO
(Geek)
Offline
Geek
Iscritto: 22/01/2010
Messaggi: 76

Ciao
con "aggiornamenti in linea" ci sono le seguenti patch:

-MozillaFirefox - MozillaFirefox: Upgrade to security release 3.5.8
-libpoppler-devel - libpoppler: Fixed ABI issue that broke xpdf
-kde-4.3.5 - KDE 4.3.5 Update

tutte con l'icona installazione automatica e i pacchetti con l'icona aggiornamenti automatici; quando faccio accetta esce questo errore:
"installazione del pacchetto non riuscita" e i dettagli sono
"Subprocess failed. Error: RPM non riuscito: error: package kdebase4-libkonq-4.3.1-5.6.3.i586 is not installed"
Grazie in anticipo

Sistema: openSUSE 12.1 (i586) KDE: 4.7.2 (4.7.2) "release 5" nVidia Corporation GeForce 6200 Driver 2D: nvidia Driver 3D: NVIDIA 275.21 Processore (CPU): AMD Sempron(tm) Processor 3000+ Velocità: 1.599,75 MHz Memoria totale (RAM): 983,5 MiB Memoria disponibile: 14,7 MiB (+ cache 274,1 MiB ) Swap disponibile: 2,0 GiB

Ritratto di enziosavio
enziosavio (non verificato)
()

Prova a guardare nel gestore dei pacchetti se kdebase4-libkonq è installato?????????
E anche se è installato prova ad aggiornarlo lo stesso e poi prova con
gli aggiornamenti........
Di più non so .....Ciao

Ritratto di ILSECCO
ILSECCO
(Geek)
Offline
Geek
Iscritto: 22/01/2010
Messaggi: 76

Il pacchetto c'è ma quando faccio aggiorna esce:

Subprocess failed. Error: RPM non riuscito: error: package dolphin-4.3.1-5.6.3.i586 is not installed

ma... aiuto!!!

Sistema: openSUSE 12.1 (i586) KDE: 4.7.2 (4.7.2) "release 5" nVidia Corporation GeForce 6200 Driver 2D: nvidia Driver 3D: NVIDIA 275.21 Processore (CPU): AMD Sempron(tm) Processor 3000+ Velocità: 1.599,75 MHz Memoria totale (RAM): 983,5 MiB Memoria disponibile: 14,7 MiB (+ cache 274,1 MiB ) Swap disponibile: 2,0 GiB

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Deve esserci qualcosa che e` saltato nelle dipendenze dei pacchetti.

Prova ad aprire un terminale e a dare il comando "zypper ve", postando il risultato.

Poi, prova a dare da terminale (come root) il comando "zypper up -r repo" dove al posto di "repo" metti il numero del repository degli aggiornamenti ufficiali (che puoi trovare dando il comando "zypper lr -u")

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di ILSECCO
ILSECCO
(Geek)
Offline
Geek
Iscritto: 22/01/2010
Messaggi: 76

Ciao orion
ecco i risultati da terminale:

secco@linux-dhcj:~> zypper ve
Recupero dei dati del repository...
Lettura dei pacchetti installati...

I seguenti pacchetti saranno RIMOSSI:
dolphin kdebase4-libkonq kdepimlibs4 kscd libkdegames4 mozilla-xulrunner191-translations-common

I seguenti pacchetti stanno per essere aggiornati:
kdebase4-workspace kdegames4 kdegames4-carddecks-other kdm kget konqueror konqueror-plugins kstars kwin
libakonadi4 MozillaFirefox MozillaFirefox-translations-common mozilla-xulrunner191-gnomevfs

13 pacchetti da aggiornare, 6 da rimuovere.
Dimensione complessiva del download: 31,5 MiB. Dopo l'operazione saranno liberati 14,1 MiB.
Alcune delle dipendenze dei pacchetti installati sono mancanti. Per correggerle sono necessarie le seguenti azioni:
Per correggere i pacchetti corrotti sono necessari i privilegi dell'utente root.

e questi da root:

zypper ve
Recupero dei dati del repository...
Lettura dei pacchetti installati...

I seguenti pacchetti saranno RIMOSSI:
dolphin kdebase4-libkonq kdepimlibs4 kscd libkdegames4 mozilla-xulrunner191-translations-common

I seguenti pacchetti stanno per essere aggiornati:
kdebase4-workspace kdegames4 kdegames4-carddecks-other kdm kget konqueror konqueror-plugins kstars kwin
libakonadi4 MozillaFirefox MozillaFirefox-translations-common mozilla-xulrunner191-gnomevfs

13 pacchetti da aggiornare, 6 da rimuovere.
Dimensione complessiva del download: 31,5 MiB. Dopo l'operazione saranno liberati 14,1 MiB.
Alcune delle dipendenze dei pacchetti installati sono mancanti. Per correggerle sono necessarie le seguenti azioni:
Continuare? [s/n/?] (s): s
Rimozione dolphin-4.3.1-5.6.3 [errore]
Rimozione di (28234)dolphin-4.3.1-5.6.3.i586(@System) fallita:
Errore: Subprocess failed. Error: RPM non riuscito: error: package dolphin-4.3.1-5.6.3.i586 is not installed

Annullare, riprovare, ignorare? [a/r/i] (a): r
Rimozione dolphin-4.3.1-5.6.3 [errore]
Rimozione di (28234)dolphin-4.3.1-5.6.3.i586(@System) fallita:
Errore: Subprocess failed. Error: RPM non riuscito: error: package dolphin-4.3.1-5.6.3.i586 is not installed

Annullare, riprovare, ignorare? [a/r/i] (a):

Il bello è che non ho mai toccato il terminale fin ora e ho sempre fatto tutti gli aggiornamenti automatici. :-S

Sistema: openSUSE 12.1 (i586) KDE: 4.7.2 (4.7.2) "release 5" nVidia Corporation GeForce 6200 Driver 2D: nvidia Driver 3D: NVIDIA 275.21 Processore (CPU): AMD Sempron(tm) Processor 3000+ Velocità: 1.599,75 MHz Memoria totale (RAM): 983,5 MiB Memoria disponibile: 14,7 MiB (+ cache 274,1 MiB ) Swap disponibile: 2,0 GiB

Ritratto di enziosavio
enziosavio (non verificato)
()

Penso che tu quando hai aggiornato a kde4.3.5 non hai risolto le dipendenze come si deve ..........
Altrimenti come spieghi Dolphin e altri pacchetti targati 4.3.1 ???????????
Prova da yast-> gestione pacchetti->repositori->Kde/kde4/Stable->switch system packages e accetti........
di sicuro hai delle dipendenze da risolvere........almeno penso!!!!!!!!!
Ciao

Ritratto di ILSECCO
ILSECCO
(Geek)
Offline
Geek
Iscritto: 22/01/2010
Messaggi: 76

Ho fatto switch system su tutti i repository e dopo 550mb scaricati e qualche "ignora" gli aggiornamenti dovevano ancora essere fatti e si verificava sempre lo stesso errore allora ho aperto yast e con clik destro sugli aggiornamenti ho fatto installa, ora mi ritrovo con ice wm e all'avvio un messaggio diceva che kde era (non ricordo) danneggiato o inutilizzabile.
Help

Sistema: openSUSE 12.1 (i586) KDE: 4.7.2 (4.7.2) "release 5" nVidia Corporation GeForce 6200 Driver 2D: nvidia Driver 3D: NVIDIA 275.21 Processore (CPU): AMD Sempron(tm) Processor 3000+ Velocità: 1.599,75 MHz Memoria totale (RAM): 983,5 MiB Memoria disponibile: 14,7 MiB (+ cache 274,1 MiB ) Swap disponibile: 2,0 GiB

Ritratto di enziosavio
enziosavio (non verificato)
()

Azz ........switch sul repo di kde4.3.5 e basta riprova da icewm......
mi sa che hai fatto un guazzabuglio con le dipendenze.........
ma..............la vedo dura............
Ciao

Ritratto di ILSECCO
ILSECCO
(Geek)
Offline
Geek
Iscritto: 22/01/2010
Messaggi: 76

Niente di fatto...forse non ho ben capito come procedere, comunque posso anche formattare tutto tranne l' home (anche se con mandriva non era andata benissimo)
ciao ciao

Sistema: openSUSE 12.1 (i586) KDE: 4.7.2 (4.7.2) "release 5" nVidia Corporation GeForce 6200 Driver 2D: nvidia Driver 3D: NVIDIA 275.21 Processore (CPU): AMD Sempron(tm) Processor 3000+ Velocità: 1.599,75 MHz Memoria totale (RAM): 983,5 MiB Memoria disponibile: 14,7 MiB (+ cache 274,1 MiB ) Swap disponibile: 2,0 GiB