Problemi con Grub su due hd sata

2 risposte [Ultimo messaggio]
Ritratto di giuped
giuped
(Monster)
Offline
Monster
Iscritto: 09/09/2004
Messaggi: 208

Ho recentemente cambiato hd e installato suse 10.0 ma ho avuto dei problemi causati dalle varie installazioni di Linux e dallo spostamento "fisico" dei ch Sata. Mi spiego meglio.
Ho 2 Hd Sata
Sda 80g con suse e windows
Sdb 200g archivio

Al boot parte un "vecchio" Grub, che credo sia nel mbr di sdb, il quale non riesce a trovare la dir dell'immagine e da errore al momento di lanciare linux (dice che sda2 è una fat cosa non vera dovrebbe essere sdb2 una fat). Il boot loader sembra essere corettamente installato su Sda infatti se avvio con il cd di installazione parte il grub giusto. Ho provato ad installare grud in sdb ma il risultato è lo stesso ho provato a "manomettere" lo mbr è la situazione peggiora ma riesco sempre ad avviare con il cd.

Come posso fare partire il boot di sda invece di sdb? ha a che fare con la partizione attiva? se si come la cambio?

grazie in anticipo.
Giuped

la mia distrostory:
RedHat->mandrake->suse->mandriva->suse->ubuntu->kubuntu->suse 10.1
Gira e rigira torno sempre da lei!!! Laughing

Ritratto di trueneo
trueneo
(Junior)
Offline
Junior
Iscritto: 27/03/2005
Messaggi: 15

Se togli quello da 200GB parte tutto normalmente?

Ritratto di giuped
giuped
(Monster)
Offline
Monster
Iscritto: 09/09/2004
Messaggi: 208

Risolto, purtroppo, usando il cd di Win Xp ho dato un fixmbr e tutto è partito come doveva.

la mia distrostory:
RedHat->mandrake->suse->mandriva->suse->ubuntu->kubuntu->suse 10.1
Gira e rigira torno sempre da lei!!! Laughing