Problemi con il boot

4 risposte [Ultimo messaggio]
Ritratto di Massimiliano
Massimiliano
(Junior)
Offline
Junior
Iscritto: 10/07/2008
Messaggi: 22

Salve a tutti. Nel mio pc ho 2 hardisk. Su uno ho installato windows xp e sull'altro opensuse 10.3. Prima con l'opzione di grub riuscivo ad andare o su xp o su linux quando volevo. Poi ho disinstallato opensuse 10.3 ed ho messo prima la 11.0 e poi mandriva. Ora sono ritornato alla opensuse 10.3 ma con il boot non riesco più a ritornare su xp. Malgrado la voce windows sulla schermata iniziale del boot, questo link non fa più partire xp. Potreste aiutarmi?
Un saluto
Massimiliano

Ritratto di Il_Cjargnel
Il_Cjargnel
(Guru)
Offline
Guru
Iscritto: 04/08/2005
Messaggi: 1886

- linux sta sul primario o sul secondario??
- postaci il contenuto di /boot/grub/menu.lst

cosi sarà più semplice vedere il problema

OpenSuse 11.0+ OpenSuse 11.2

Ritratto di Massimiliano
Massimiliano
(Junior)
Offline
Junior
Iscritto: 10/07/2008
Messaggi: 22

Questo è il file che mi hai chiesto
# Modified by YaST2. Last modification on lun lug 7 15:26:34 CEST 2008
default 0
timeout 8
gfxmenu (hd0,1)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.3
root (hd0,1)
kernel /boot/vmlinuz-2.6.22.5-31-default root=/dev/disk/by-id/scsi-SATA_Maxtor_6Y080P0_Y2D66CNE-part2 vga=0x317 resume=/dev/sda1 splash=silent showopts
initrd /boot/initrd-2.6.22.5-31-default

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
rootnoverify (hd0,1)
chainloader (hd1,0)+1

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 10.3
root (hd0,1)
kernel /boot/vmlinuz-2.6.22.5-31-default root=/dev/disk/by-id/scsi-SATA_Maxtor_6Y080P0_Y2D66CNE-part2 vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
initrd /boot/initrd-2.6.22.5-31-default

E questo è il mount da terminale

/dev/sda2 on / type ext3 (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/sda3 on /home type ext3 (rw,acl,user_xattr)
/dev/sdb1 on /windows/C type fuseblk (rw,noexec,nosuid,nodev,noatime,allow_other,default_permissions,blksize=4096)
securityfs on /sys/kernel/security type securityfs (rw)
/dev/sr0 on /media/SU1100.001 type iso9660 (rw,nosuid,nodev,noatime,uid=1000,utf8)

Un saluto
Massimiliano

Ritratto di Il_Cjargnel
Il_Cjargnel
(Guru)
Offline
Guru
Iscritto: 04/08/2005
Messaggi: 1886

se win è il secondario (non lo hai mica detto!!)

tuo file di win
###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
rootnoverify (hd0,1)
chainloader (hd1,0)+1

modificalo così:
###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
map (hd0) (hd1)
map (hd1) (hd0)
chainloader (hd1,0)+1

a me cosi (con win sul secondario!!!!!) funge!!

OpenSuse 11.0+ OpenSuse 11.2

Ritratto di Massimiliano
Massimiliano
(Junior)
Offline
Junior
Iscritto: 10/07/2008
Messaggi: 22

Risolto grazie! Modificando quelle righe, ora sono in grado di andarci. Grazie di nuovo e arrivederci

Massimiliano