Problemi di accesso dopo installazione

5 risposte [Ultimo messaggio]
Ritratto di bettiolognm
bettiolognm
(Newbie)
Offline
Newbie
Iscritto: 08/03/2007
Messaggi: 3

ciao a tutto il forum,
da poco sto facendo conoscenza del mondo linux e per cominciare ho installato Osuse 10.2 scegliende Gnome come interfiaccia.
Ho eseguito l'installazione ( usando i primi 3 CD ) facendo una installazione standard.
Ora quando il pc esegue il boot mi compare una schermata dove mi viene chiesto "user name" e poi una password.
Ora come user name ho provato root ma come password ( ne ho provate molte ) non ho proprio idea di cosa mettere.
Durante l'installazione non mi è stato chiesto di inserire una password per l'utente root.
Come posso eseguire il login ??
Grazie

BGM

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Mmm... sicuro (ma proprio sicuro) che non ti sia stata chiesta la password di root durante l'installazione?
Probabilmente ti e` stata chiesta, l'hai inserita ma al momento non ti ricordi di averlo fatto. Come pure ti e` stato chiesto di aggiungere degli utenti normali.

Potresti seguire questa procedura per resettare la password di root e poi aggiungi un utente normale tramite yast.

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di bettiolognm
bettiolognm
(Newbie)
Offline
Newbie
Iscritto: 08/03/2007
Messaggi: 3

Grazie per la pronta risposta.
Sono sicuro di non aver inserito nessuna password però devo aggiungere che l'installazione l'ho lanciata la sera e poi ho inserito l'ultimo CD ( il terzo ) senza seguire l'installazione e il giorno seguente ho trovato l'installaziuone completatata !!
Forse ho perso qualche passaggio??

Ora provo a seguire la procedura che mi hai segnalato e spero di poter cominciare ad usare Osuse.

Grazie ancora.

Ciao

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Un momento, prima bisogna vedere se hai effettivamente completato l'installazione: se mi ricordo bene le fasi dell'installazione da cd (l'ultima che ho fatto e` stata con la 9.3), inizi con il cd I, selezioni i vari pacchetti, e inizia a installare il software. Quando termina il cd I, ti fa riavviare il pc e poi ti chiede i cd successivi. Al termine dell'installazione del software dai cd successivi (non mi ricordo se domanda un reboot, ma mi sembra di no), ti chiede password di root, altri utenti ed eventuali configurazioni, e non dovrebbe consentire di andare avanti in automatico in questa fase.

Tu hai passato questi step?

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di bettiolognm
bettiolognm
(Newbie)
Offline
Newbie
Iscritto: 08/03/2007
Messaggi: 3

Quote:

orion ha scritto:
Un momento, prima bisogna vedere se hai effettivamente completato l'installazione: se mi ricordo bene le fasi dell'installazione da cd (l'ultima che ho fatto e` stata con la 9.3), inizi con il cd I, selezioni i vari pacchetti, e inizia a installare il software. Quando termina il cd I, ti fa riavviare il pc e poi ti chiede i cd successivi. Al termine dell'installazione del software dai cd successivi (non mi ricordo se domanda un reboot, ma mi sembra di no), ti chiede password di root, altri utenti ed eventuali configurazioni, e non dovrebbe consentire di andare avanti in automatico in questa fase.

Tu hai passato questi step?

Come dici tu io sono partito con il CD1 , poi ho seguito le varie fasi di installazione facendo le mie scelte ( pacchetti da installare , lingua, impostazioni di fuso orario etc..) a quel punto il sistema ha cominciato ad eseguire l'installazione delsoftware chiedendomi poi il CD2 ed il CD3.
Tornato in ufficio il mattino successivo ho trovato il sistema con la schermata di login.
Ho comunque provato a riavviare ( sulla finestra di login c'erano varie opzioni tra le quali riavvia e spegni).
Ma ad ogni modo non sono mai arrivato in un punto dove mi ha chiesto di inserire un utente o una password.
Questa è la seconda volta che lo installo e mi ritrovo sempre sulla finestra di login dove mi chiede utente e password !!!
Ora stavo cercando di seguire i passi che mi hai segnalato per il reset della password.
Io arrivo fino alla editazione del file passwd , cancello la X nella riga "root:X:0.....", ma poi non riesco a salvare il file.
Come faccio per salvarlo?
Qual'è la sequenza esatta di tasti per salvare il file?

Grazie ancora

Ciao

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Mi sono accorto di una cosa nella procedura indicata nel link: non fa riferimento alla directory /etc corretta, a parer mio.

Quindi e` meglio modificare leggermente il modo di lavorare: avvia normalmente il pc (non da cd) e, quando compare il grub, seleziona la suse e aggiungi alle opzioni di boot il valore single (mi sembra che devi premere b per avere le opzioni di boot). Dai invio e aspetta il boot. Dovrebbe partire un sistema minimale in cui sei direttamente loggato come root. Se cosi` e` (non ho mai provato), te ne accorgi in quanto il prompt termina con # invece di $ e dai il comando passwd. Non dovrebbe chiederti la password di root ma solo di inserirne una nuova. Una volta modificata, riavvia il sistema in modalita` standard (l'opzione single che avevi passato prima e` andata persa) e vedi se riesci ad autenticarti come root (se non in grafica, almeno in testuale). Se ti autentichi solo in testuale, dai il comando telinit 3 poi il comando startx e, dentro l'ambiente grafico ottenuto, fai partire yast2 e aggiungi un utente normale.
Quando lo hai aggiunto, fai logout (da grafica), torni sulla shell testuale e dai il comando telinit 5. A questo punto, autenticati con in nuovo utente che hai appena creato. Dovresti essere a posto, a questo punto.

Comunque, per salvare il file in vi basta premere Esc e poi :wq

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde