problemi vari post installazione con XFCE

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 878

sudo zypper in yast2-core yast2-control-center-qt yast2-control-center yast2-add-on yast2-installation yast2-pkg-bindings autoyast2-installation

Vediamo se manca qualcosa

Ritratto di bastia
bastia
(Junior)
Offline
Junior
Iscritto: 09/12/2015
Messaggi: 24

Problem: yast2-pkg-bindings-3.1.31-1.2.x86_64 requires libzypp.so.1519()(64bit), but this requirement cannot be provided
  uninstallable providers: libzypp-15.19.5-1.1.x86_64[openSUSE:Leap:42.1]
 Solution 1: Following actions will be done:
  deinstallation of libyui-qt-pkg6-2.44.7-8.1.x86_64
  deinstallation of libyui-gtk-pkg6-2.43.2-2.8.1.x86_64
  deinstallation of libyui-ncurses-pkg6-2.46.1-2.8.1.x86_64
 Solution 2: do not install yast2-pkg-bindings-3.1.31-1.2.x86_64
 Solution 3: break yast2-pkg-bindings-3.1.31-1.2.x86_64 by ignoring some of its dependencies

cosa consigli?

Ritratto di dragoncello
dragoncello
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/07/2005
Messaggi: 2724

Non usando il tuo DE xFCE,non sò aiutarti,provato con zypper dup anzichè UP,provare non costa niente,e non credo ti faccia casini il comando. Vediamo che pacchetti ti vuole installare,facci sapere.Mentre scrivevo Grinch postava un altra soluzione,vedi se con il comando zypper dup ti risolve le dipendenze installandoti tutti i pacchetti di yast2
che significa questa riga:(uninstallable providers: libzypp-15.19.5-1.1.x86_64[openSUSE:Leap:42.1])

SUSE Tumbleweed- kernel-5.1.7-1.2- kde-plasma-5.16.5- Intel Core i7 Asus P9x79 pro GeForce GTX 560-driver Nvidia-390.116.51- SSD samsung 850 pro 512 gb http://opensuse-community.org/

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 878

Soluzione 1)

Ritratto di bastia
bastia
(Junior)
Offline
Junior
Iscritto: 09/12/2015
Messaggi: 24

Grazie a tutti,

al momento Yast funziona correttamente.
L'update manuale anche, ma il "package updater" ancora no.

Riprovo e poi faro` sapere.

buon weekend
Applause

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 878

sudo zypper in PackageKit PackageKit-backend-zypp PackageKit-branding-openSUSE PackageKit-browser-plugin PackageKit-gtk3-module
sudo zypper ve
sudo zypper dup

E metti anche RISOLTO Party

Ritratto di bastia
bastia
(Junior)
Offline
Junior
Iscritto: 09/12/2015
Messaggi: 24

Questo e` il risultato se provo a fare l'aggiornamento

Failed to process request:
libzypp-15.19.5-1.1.x86_64 requires libsolv-tools = 0.6.14, but this requirement cannot be provided

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 878

Sicuramente dice qualcosa d' altro Party

Ritratto di bastia
bastia
(Junior)
Offline
Junior
Iscritto: 09/12/2015
Messaggi: 24

No, da la lista degli update da fare, c'e` solamente il: softwarestack update e se lo aggiorno mi dice:

Failed to process request
libzypp-15.19.5-1.1.x86_64 requires libsolv-tools = 0.6.14, but this requirement cannot be provided

null'altro Angel

p.s.
la prima soluzione che mi ha dato Grinch (sudo zypper in yast2-core yast2-control-center-qt yast2-control-center yast2-add-on yast2-installation yast2-pkg-bindings autoyast2-installation) e` servita solamente ad installare tutti i pacchetti di Yast?

mentre la seconda soluzione (

sudo zypper in PackageKit PackageKit-backend-zypp PackageKit-branding-openSUSE PackageKit-browser-plugin PackageKit-gtk3-module
sudo zypper ve
sudo zypper dup
) di preciso che cosa fa`? Angel

Ritratto di Grinch
Grinch
(Guru)
Offline
Guru
Iscritto: 05/12/2011
Messaggi: 878

Siccome stranamente ti mancava mezzo Yast anzi c'era Yast Ncurses, e mi dici che l' Updater automatico alias packagekit non funziona , ho pensato che manchi qualcosa anche per quest' ultimo , quindi i comandi installano il necessario per l'Updater automatico