Repository

20 risposte [Ultimo messaggio]
Ritratto di silvestro1
silvestro1
(Junior)
Offline
Junior
Iscritto: 06/02/2012
Messaggi: 15

adesso dice che PackageKit
è in esecuzione mentre non lo è.........

Ritratto di silvestro1
silvestro1
(Junior)
Offline
Junior
Iscritto: 06/02/2012
Messaggi: 15

Io ho appena installato la 12.1........ e credo il problema sia sui repo specifici..........

Ritratto di Suse98
Suse98
(Guru)
Offline
Guru
Iscritto: 03/10/2010
Messaggi: 1711

Scusa, vai da terminale e digiti
sudo zypper rr 2 3 4 5 8 9 12
poi
sudo zypper ref
e
sudo zypper clean

@doc_pluto, scusa, non ho visto il messaggio del farli eliminare, solo ora l'ho visto Batting Eyelashes

SUSE LINUX Rilascio 12.3 (Dartmounth) KDE 4.10 && GNOME 3.8

Ritratto di doc_pluto
doc_pluto
(Guru)
Offline
Guru
Iscritto: 08/02/2007
Messaggi: 871

silvestro1 ha scritto:

ho KDE

per KDE ti consiglio questi repo per la versione KDE SC 4.7:
Pacchetti base: http://download.opensuse.org/repositories/KDE:/Distro:/Stable/openSUSE_12.1/
Applicazioni aggiornate: http://download.opensuse.org/repositories/KDE:/UpdatedApps/openSUSE_12.1/
Extra: http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_12.1/

puoi aggiungerli in due modi:

1° da shell:
esegui questi comandi uno alla volta

sudo zypper ar -f http://download.opensuse.org/repositories/KDE:/Distro:/Stable/openSUSE_12.1/ KDE47_core
sudo zypper ar -f http://download.opensuse.org/repositories/KDE:/UpdatedApps/openSUSE_12.1/ KDE47_UpdateApp
sudo zypper ar -f http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_12.1/ KDE47_Extra

ti spiego:
_ zypper è il gestore dei pacchetti e necessita di privilegi di root per essere eseguito. per farlo ci sono vari modi, in questo caso è sufficiente usare sudo e dovrai inserire la password quando richiesta
_ ar sta per addrepo ed è uno dei possibili comandi di zypper
_ -f serve per abilitare l'auto refresh del repository appena aggiunto
_ l'URL è il link al repository
_ la stringa dopo l'URL sarà il nome sintetico associato al repository, così hai più chiaro cosa c'è dentro

2° da Yast > Repository dei Pacchetti (vedi post precedente)
questa volta clicchi su Aggiungi, e poi nella finestra che ti si apre selezioni Specifica URL 1 e poi clicchi Avanti 2

quindi inserisci un nome descrittivo per il repo ed incolli uno dei link

e poi clicchi avanti: farà tutto da solo.
prosegui così per gli altri repository.

Hardware: MB:P5E3_Deluxe - CPU:Core2Duo E8400 3.0GHz - RAM:Kingstone_2Gb_DDR3 - Video:GeForce9600GT/PCI/SSE2 - HD: 2x WDCaviarBlue 1TB
--------------------------------
Software: SO:openSuSE 12.1 - ARCH:64bit - DE:Gnome3 - DriverVideo:Ufficiali Nvidia

Ritratto di silvestro1
silvestro1
(Junior)
Offline
Junior
Iscritto: 06/02/2012
Messaggi: 15

Allora ho aggirnato ma il problema repo persiste , nel senso che spesso i repo si bloccano e occorre tentare più di una volta, come se il server fosse bloccato, provo oggi magari funzione meglio , grazie mille. Sono nuovo di suse e sto imparando, a proposito ma il comano di aggiornamento da termina ual'è?

Ritratto di silvestro1
silvestro1
(Junior)
Offline
Junior
Iscritto: 06/02/2012
Messaggi: 15

Ah dimenticavo ho ancora parte del menù di avvio e altre cosette in inglese............

Ritratto di doc_pluto
doc_pluto
(Guru)
Offline
Guru
Iscritto: 08/02/2007
Messaggi: 871

da quello che leggo posso dedurre che hai installato da LiveCD. confermi?

devi andare nelle Impostazioni di sistema > Localizzazione e selezionare la lingua e il layout della tastiera italiana.

se non dovessi averli a disposizione, per aggiungere i pacchetti con la lingua cerca info nel forum che c'è un topic con le info utili, ma che adesso non riesco a trovare.

per aggiornare il sistema hai due modi:

1_Utility
in Menu > Strumenti di sistema trovi Aggiornamento Software che ti richede la password di root e ti mostra a video l'elenco dei pacchatti disponibili per un aggiornamento di versione.

2_Shell
in una shell (quindi aprendo Konsole) esegui questi comandi:

su -
password:

si diventa amministratore del sistema

zypper ref
aggiorno l'elenco dei pacchetti contenuti nei repository

zypper up
controllo la disponibilità ed eventualemente eseguo l'aggiornamento dei pacchetti

con quale repo riscontri problemi?
nel caso proviamo a vedere se c'è un mirror da usare.

Hardware: MB:P5E3_Deluxe - CPU:Core2Duo E8400 3.0GHz - RAM:Kingstone_2Gb_DDR3 - Video:GeForce9600GT/PCI/SSE2 - HD: 2x WDCaviarBlue 1TB
--------------------------------
Software: SO:openSuSE 12.1 - ARCH:64bit - DE:Gnome3 - DriverVideo:Ufficiali Nvidia

Ritratto di silvestro1
silvestro1
(Junior)
Offline
Junior
Iscritto: 06/02/2012
Messaggi: 15

l'aggiornamento delle lingue l'ho fatto il menù del lanciatore e tutto quel che riguarda le impostazioni son rimaste in inglese, i repo sono quelli che ti ho postato ieri, ma in pratica ci mette un po , gli devi die riprova piu volte poi scarica, volevo provare da terminale per vedere se andava meglio, ma conosco i comandi debian........... adesso provo grazie........

Ritratto di silvestro1
silvestro1
(Junior)
Offline
Junior
Iscritto: 06/02/2012
Messaggi: 15

Errore di scaricamento (curl) per 'http://download.opensuse.org/repositories/KDE:/UpdatedApps/openSUSE_12.1/repodata/repomd.xml':
Codice di errore: Connection failed
Messaggio di errore: Resolving host timed out: download.opensuse.org

ecco che risponde il terminale...... ma riprovando piu volte alla fine gliela fa......

Ritratto di max.riservo
max.riservo
(Geek)
Offline
Geek
Iscritto: 04/02/2012
Messaggi: 188

Silvestro1 wrote:

Citazione:

l'aggiornamento delle lingue l'ho fatto il menù del lanciatore e tutto quel che riguarda le impostazioni son rimaste in inglese


prova a scaricare i seguenti pacchetti :
- bundle-lang-common-it, bundle-lang-kde-it;
- kde4-l10n-it, yast2-trans-it;
- bundle-lang-gnome-it, bundle-lang-gnome-extras-it;
- Desktop-data-openSUSE-extra, Desktop-translations;

ovviamente tramite Yast (oppure tramite Konsole).
Dovresti avere (quasi) tutti i testi tradotti in italiano.

A volte sono presente anche in altri forum di programmazione ....