Repository sbagliato ?

2 risposte [Ultimo messaggio]
Ritratto di obscuredbycloud
obscuredbycloud
(Junior)
Offline
Junior
Iscritto: 04/09/2008
Messaggi: 17

Ciao atutti ho installato la 12.2 e fin qui tutto OK.
Ho aggiunto come indicato in
http://www.suseitalia.org/guide/repository/giuda-sui-repository-di-opensuse?page=1

i repository che mi interesavano
facendo pero'

il repository di gnome :
http://download.opensuse.org/repositories/GNOME:/STABLE:/

mi da' pero' un errore :

zypper ref
Retrieving repository 'GNOME:Stable' metadata .......................................................................................[error]
Repository 'GNOME:Stable' is invalid.
[|] Valid metadata not found at specified URL(s)
Please check if the URIs defined for this repository are pointing to a valid repository.
Skipping repository 'GNOME:Stable' because of the above error.
Repository 'Kernel:Standard' is up to date.
Repository 'LibDVDcss' is up to date.
Repository 'LibreOffice_Stable' is up to date.
Repository 'Mozilla' is up to date.
Repository 'Packman' is up to date.
Repository 'VLC' is up to date.
Repository 'amd-fglrx-legacy' is up to date.
Repository 'home:alex_sh' is up to date.
Repository 'openSUSE-12.2-Non-Oss' is up to date.
Repository 'openSUSE-12.2-Oss' is up to date.
Repository 'openSUSE-12.2-Source' is up to date.
Repository 'openSUSE-12.2-Update' is up to date.
Repository 'openSUSE-12.2-Update-Non-Oss' is up to date.
Some of the repositories have not been refreshed because of an error.

Sbaglio perche' mi manca la versione di gnome ?

gnome-session --version
mi da ....

gnome-session 3.4.2.1

ho come il sopsetto di avere fatto un casino
per la 12.2 la versione di gnome dovrebbe essere:

http://download.opensuse.org/repositories/GNOME:/STABLE:/3.6/openSUSE_12.2/

se non sbaglio ?

Un grazie in aticipo per chi mi sapra' dare una zampa
Ciao & buona serata

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

Non hai fatto nessun casino, semplicemente GNOME 3.4 è la versione inclusa in openSUSE 12.2 e supportata ufficialmente, mentre la 3.6 è l'ultima versione stabile supportata dalla comunità.

L'errore che vedi è dovuto al fatto che l'URL corretto per aggiungere il repository di GNOME 3.6 con zypper/YaST è appunto http://download.opensuse.org/repositories/GNOME:/STABLE:/3.6/openSUSE_12.2/ che tu stesso hai riportato (o direttamente il file http://download.opensuse.org/repositories/GNOME:/STABLE:/3.6/openSUSE_12.2/GNOME:STABLE:3.6.repo, a seconda della guida che stai seguendo)
Se ti interessa puoi leggere anche http://it.opensuse.org/SDB:Add_package_repositories che contiene anche link ad altre pagine utili sull'argomento repository

Dimenticavo questo: http://it.opensuse.org/Repository_di_GNOME

Ritratto di obscuredbycloud
obscuredbycloud
(Junior)
Offline
Junior
Iscritto: 04/09/2008
Messaggi: 17

Grazie mille !