Ripristino boot loader

5 risposte [Ultimo messaggio]
Ritratto di Brutus
Brutus
(Junior)
Offline
Junior
Iscritto: 04/02/2009
Messaggi: 38

Salve a tutti!
Avendo preso un virus su windows, ho dovuto formattare la relativa partizione e reinstallarlo, e a questo punto cominciano i problemi di boot: naturalmente windows ha installato il proprio boot loader, allora ho inserito il dvd di openSuse e ho reinstallato il boot loader che però non è uguale a quello che verrebbe installato se reinstallassi openSuse! In particolare mi ritrovo solo le voci:

OPENSUSE
OPENSUSE FAILSAFE

o una roba simile: come faccio a ripristinare il grub e farlo tornare come era stamattina?

Grazie

Ritratto di spock
spock
(Guru)
Offline
Guru
Iscritto: 03/08/2006
Messaggi: 1198

Prova ad andare in yast-->sistema-->bootloader ed a reinstallare il bootloader da lì.
Ciao

Ritratto di Brutus
Brutus
(Junior)
Offline
Junior
Iscritto: 04/02/2009
Messaggi: 38

Cioè? Cosa devo selezionare precisamente nel boot loader?

Ritratto di anubis
anubis
(Guru)
Offline
Guru
Iscritto: 07/04/2007
Messaggi: 3656

Quote:

Brutus ha scritto:
Cioè? Cosa devo selezionare precisamente nel boot loader?

yast --> sistema --> bootloader

(in basso a destra) altro --> modifica file di configurazione

incolla in fondo al file "/boot/grub/menu.lst" queste linee:

<br />###Don&#039;t change this comment - YaST2 identifier: Original name: windows###<br />title Windows<br />    rootnoverify (hd0,0)<br />    chainloader +1

salva e riavvia per vedere se win parte

se no, posta l'output del comando

fdisk -l

dato da root

OpenSUSE Member,Packman Packager, Education Project Admin, LXDE Project Admin
Powered by http://en.opensuse.org/HP_Pavilion_dv6855el

Ritratto di Brutus
Brutus
(Junior)
Offline
Junior
Iscritto: 04/02/2009
Messaggi: 38

Anubis, la tua risposta è arrivata un attimo dopo che io avessi fatto un impiccio ben maggiore!!!
Smanettando ho trovato il file "menu.lst.old" che ho sostituito a "menu.lst": riavvio il sistema e come per magia il grub è tornato come prima!!! Avvio opensuse, ma dopo pochi secondi il caricamento del sistema operativo si blocca perché il file system è corrotto.
Ho provato a ripararlo mediante il dvd di installazione ma quando ci provo mi dice:

fsck.ext2: Device or resource busy while trying to<br />open /dev/sda. Filesystem mounted or opened<br />exclusively by another program?

Ritratto di Brutus
Brutus
(Junior)
Offline
Junior
Iscritto: 04/02/2009
Messaggi: 38

Forse ho fatto un passo avanti: ho avviato il sistema di salvataggio dal dvd, ho eseguito il comando:

e2fsck /dev/sda3

e mi ha detto che stava tutto a posto, poi l'ho rifatto forzando l'analisi col parametro -f, però suse ancora non si avvia. Da uno sguardo veloce ho notato che quella partizione non è più associata al punto di mount "/", potrebbe dipendere da questo? Se si come faccio a modificare il punto di mount senza formattare?