Sparite le partizioni radice e home

22 risposte [Ultimo messaggio]
Ritratto di maverick72
maverick72
(Geek)
Offline
Geek
Iscritto: 30/06/2008
Messaggi: 68

Salve, sto scrivendo da una distibuzione live cd in quanto opensuse 11 è sparito.
Mi spiego meglio, avevo installato OS11 creando tre partizioni
1 boot
1 radice ed una home

Un giorno riaccendendo il pc questo non andava a tal punto ho inserito il dvd di os11 per provare a riparare il sistema senza alcun successo.
A quel punto ho provato a reinstallare il sistema tenendo la home soltanto che quando arrivo alle partizioni mi rendo conto che riconosceva solo quella per il boot e sia la home che \ erano sparite.

Ora lavorando con un live cd ho provato a recuperare i dati in home ma neanche la versione live me la vede.

Mi date un consiglio perchè ho dei dati da recuperare, grazie

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Con la live, prova a postare il risultato di fdisk -l (e` una L minuscola).

Almeno vediamo se ci sono ancora le partizioni a livello di tabella delle partizioni.

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di maverick72
maverick72
(Geek)
Offline
Geek
Iscritto: 30/06/2008
Messaggi: 68

Quote:

orion ha scritto:
Con la live, prova a postare il risultato di fdisk -l (e` una L minuscola).

Almeno vediamo se ci sono ancora le partizioni a livello di tabella delle partizioni.

Disco /dev/sda: 81.9 GB, 81964302336 byte
255 heads, 63 sectors/track, 9964 cylinders
Units = cilindri of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000427c1

Dispositivo Boot Start End Blocks Id System
/dev/sda1 * 1 20 160618+ 83 Linux
/dev/sda2 21 9964 79875180 f W95 Esteso (LBA)
/dev/sda5 21 151 1052226 82 Linux swap / Solaris
/dev/sda6 152 2762 20972826 83 Linux
/dev/sda7 2763 9964 57850033+ 83 Linux

Disco /dev/sdb: 81.9 GB, 81964302336 byte
255 heads, 63 sectors/track, 9964 cylinders
Units = cilindri of 16065 * 512 = 8225280 bytes
Disk identifier: 0x03e403e3

Dispositivo Boot Start End Blocks Id System
/dev/sdb1 1 9964 80035798+ 83 Linux

Ritratto di Mirko
Mirko
(Guru)
Offline
Guru
Iscritto: 19/12/2005
Messaggi: 1602

Ti ho già letto qua e là, se non ricordo male non sei alle primissime armi, anzi credo tu sia più esperto di me. Quindi spero che la domanda non sia scontata:
cosa significa che non vede le partizioni?
Giacché come ben saprai un conto è se sono state piallate, e mi sa che ti tocca affidarti un software di recovery (a molti hanno dato grandi risultati, io cancellai una cartella contenente tre mesi di lavoro, provai un po' di tutto ma non ci fu verso di recupararla), un altro è se la partizione c'è ma il sistema non riesce a leggerla

p.s. è la prima volta che orion mi frega... ora so cosa provano gli altri, looooooool

Ritratto di maverick72
maverick72
(Geek)
Offline
Geek
Iscritto: 30/06/2008
Messaggi: 68

Quote:

Mirko ha scritto:
Ti ho già letto qua e là, se non ricordo male non sei alle primissime armi, anzi credo tu sia più esperto di me. Quindi spero che la domanda non sia scontata:
cosa significa che non vede le partizioni?
Giacché come ben saprai un conto è se sono state piallate, e mi sa che ti tocca affidarti un software di recovery (a molti hanno dato grandi risultati, io cancellai una cartella contenente tre mesi di lavoro, provai un po' di tutto ma non ci fu verso di recupararla), un altro è se la partizione c'è ma il sistema non riesce a leggerla

p.s. è la prima volta che orion mi frega... ora so cosa provano gli altri, looooooool

Ciao, forse mi avrai letto, sono un utente che da circa 10 mesi prova ad utilizzare linux cambiando diverse distribuzioni ma, purtroppo, non ho molta esperienza.

Non so cosa significa partizioni piallate, soltanto che utilizzando un software di gestione delle partizione mi fa vedere solo la partizione di boot che avevo creato e della partizione \ e home niente.

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Allora, le partizioni dovrebbero esserci ancora. Adesso bisogna vedere se contengono ancora un file-system valido oppure e` saltato.

Ad occhio, dalle dimensioni, mi sembra che sda6 fosse / e sda7 fosse /home

Mentre non saprei cosa sia contenuto in sdb.

Sempre dalla live, prova a dare questi comandi, in serie:mount -t auto /dev/sda6 /mnt<br />ls -l /mnt<br />umount /mnt<br /><br />mount -t auto /dev/sda7 /mnt<br />ls -l /mnt<br />umount /mnt<br /><br />mount -t auto /dev/sdb1 /mnt<br />ls -l /mnt<br />umount /mnt

Riporta se c'e` il contenuto atteso (home e sistema, oltre ad un qualcos'altro nella terza partizione).

E soprattutto indica qual era la partizione /

Poi, gia` che ci sei, posta il contenuto di /boot/grub/menu.lst (che puoi recuperare dalla live montanto la partizione /dev/sda1 in /mnt)

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di maverick72
maverick72
(Geek)
Offline
Geek
Iscritto: 30/06/2008
Messaggi: 68

provo a fare ciò che hai detto, anche se non mi è molto chiaro.

Intanto inizio con i comandi che mi hai detto omettendo quelli relativi ad sdb1 perchè questo è un secondo hd che uso come archivio e con la live si è montato correttamente.

la \ è, come da te intuito, sda6.

Ritratto di maverick72
maverick72
(Geek)
Offline
Geek
Iscritto: 30/06/2008
Messaggi: 68

Quote:

orion ha scritto:
Allora, le partizioni dovrebbero esserci ancora. Adesso bisogna vedere se contengono ancora un file-system valido oppure e` saltato.

Ad occhio, dalle dimensioni, mi sembra che sda6 fosse / e sda7 fosse /home

Mentre non saprei cosa sia contenuto in sdb.

Sempre dalla live, prova a dare questi comandi, in serie:mount -t auto /dev/sda6 /mnt<br />ls -l /mnt<br />umount /mnt<br /><br />mount -t auto /dev/sda7 /mnt<br />ls -l /mnt<br />umount /mnt<br /><br />mount -t auto /dev/sdb1 /mnt<br />ls -l /mnt<br />umount /mnt

Riporta se c'e` il contenuto atteso (home e sistema, oltre ad un qualcos'altro nella terza partizione).

E soprattutto indica qual era la partizione /

Poi, gia` che ci sei, posta il contenuto di /boot/grub/menu.lst (che puoi recuperare dalla live montanto la partizione /dev/sda1 in /mnt)

queste sono le risposte ottenute:

ubuntu@ubuntu:~$ sudo mount -t auto /dev/sda6 /mnt
mount: il device speciale /dev/sda6 non esiste

ubuntu@ubuntu:~$ sudo mount -t auto /dev/sda7 /mnt
mount: il device speciale /dev/sda7 non esiste

Ritratto di orion
orion
(Guru)
Offline
Guru
Iscritto: 11/07/2006
Messaggi: 2919

Strano che ti risponda che non esiste /dev/sda6 e 7...

Se fosse il file-system saltato, direbbe un'altra cosa.

Prova a dare un "ls -l /dev/sda* /dev/hda*" e riporta cosa ti viene restituito...

openSUSE 12.1 on Acer Aspire 1810tz - LXDE ultima versione dal repo x11:/lxde

Ritratto di maverick72
maverick72
(Geek)
Offline
Geek
Iscritto: 30/06/2008
Messaggi: 68

Quote:

orion ha scritto:
Strano che ti risponda che non esiste /dev/sda6 e 7...

Se fosse il file-system saltato, direbbe un'altra cosa.

Prova a dare un "ls -l /dev/sda* /dev/hda*" e riporta cosa ti viene restituito...

ubuntu@ubuntu:~$ ls -l /dev/sda* /dev/hda*
ls: cannot access /dev/hda*: No such file or directory
brw-rw---- 1 root disk 8, 0 2008-09-26 14:44 /dev/sda
brw-rw---- 1 root disk 8, 1 2008-09-26 14:44 /dev/sda1
brw-rw---- 1 root disk 8, 2 2008-09-26 14:44 /dev/sda2
brw-rw---- 1 root disk 8, 5 2008-09-26 14:45 /dev/sda5

Ritratto di maverick72
maverick72
(Geek)
Offline
Geek
Iscritto: 30/06/2008
Messaggi: 68

scusate se insisto, ma ripropongo il problema in quanto sono disperato.

grazie