Sparito file xorg.conf non riesco più a rigenerarlo in opensuse 11.4 i nuovi driver sle10 la via difficle

3 risposte [Ultimo messaggio]
Ritratto di paolom65
paolom65
(Geek)
Offline
Geek
Iscritto: 08/09/2006
Messaggi: 130

ho installato i driver sle10sp1 ho seguito diverse guide su opensuse per rigenerare il file xorg.conf che è sparito in /etc/X11/xorg.con ho provato con uno init 3 eppoi ho dato:

su -c "cp /etc/X11/xorg.conf.install /etc/X11/xorg.conf

ma il file rigenerato non mi mette più i driver nvidia ma i driver vesa e fbdev forse per intel, purtroppo, non riesco a postare perchè sto usando winzozz e non riesco a copiarlo nella partizione windows sono senza desktop grafico in opensuse.

Con nvidia-settings come faccio a rigenerarlo? Non so il comando esatto ho provato nvidia-settings --help ma mi posta i comandi in una schermata è veloce e non riesco a leggerli perciò me li fa saltare e non riesco a capire.

Augurando un buon ferragosto porgo un saluto alla community

hardware cpu athlon amd dual core 6000 64 bit scheda madre k9n2gm fih scheda video nvidia ge force twintech 9600 gt audio realtek alc 888 scheda ethernet realtek 8201 phy integrata 2 hard-disk sata e 2 hard-disk ide pm maxtor e western digital da 80 320 500 e 500 gigabytes

Ritratto di wal7er
wal7er
(Guru)
Offline
Guru
Iscritto: 21/09/2007
Messaggi: 572

Almeno su opensuse 11.4 xorg.conf non c'è più (ecco perchè non lo trovi), al suo posto c'è la cartella /etc/X11/xorg.conf.d con vari file che vengono assemblati "al volo" per generare la configurazione corrente.

PS:
Per leggere l'output di del comando comodamente:

#> nvidia-settings --help | less

scorri il testo con le frecce e il tasto q per terminare.

HP Pavilion dv5-1110el powered by OpenSUSE 13.2 64bit

http://linuxcounter.net/cert/432576.png

Ritratto di aksaf
aksaf
(Guru)
Offline
Guru
Iscritto: 08/03/2011
Messaggi: 957

non capisco: hai installato i driver della versione Enterprise su openSUSE 11.4?
Se è così da console (Ctrl Alt F1) come root lancia yast in modalità (semi)grafica disinstalla tali driver e poi aggiungi il "repository della comunità" nvidia Grap. Drivers sempre da YaST.
o segui questo http://it.opensuse.org/SDB:NVIDIA

P.S.: vedo anch'io che in quei wiki ci sono le sezioni per la SLE(D), ma sono per la SLE(D) suppongo, e l'unica "via difficile" che vedo è http://it.opensuse.org/SDB:NVIDIA_la_via_difficile che mi pare OK
(c'è anche http://www.suse.de/~sndirsch/nvidia-installer-HOWTO.html)

Ciao

--edit--
vedo che, mentre scrivevo il messaggio, hai modificato il messaggio iniziale: ignora quanto ho scritto.
O forse non tutto, se sulla sle c'è ancora sax2 puoi accedere a yast come scritto e poi configurare la scheda video alla voce apposita, anche nvidia-installer-HOWTO dovrebbe contenere le parti per sax2.

Ritratto di paolom65
paolom65
(Geek)
Offline
Geek
Iscritto: 08/09/2006
Messaggi: 130

il file xorg.conf esiste è nella cartella /etc/X11/xorg.conf.d/xorg.conf ho modificato il file del driver nella sezione nvidia con il driver noveau
cioè con la stringa "nv" ho modificato anche il file 50-screen.conf e ho messo invece di "radeon" "nvidia" il driver è ripartito senza problemi ho installato i driver originali di nvidia opensuse il repository per sle10sp1 mi diceva che non lo trovava. Vi ringrazio per i vostri consigli.